Loading ...
Sorry, an error occurred while loading the content.
 

Re: Need Help Running gvim (GUI version on Mac OSX)

Expand Messages
  • Unnsse Khan
    Matthew, Thanks for all of your help, but gvim still doesn t work on my Mac OSX! Am I not supposed to invoke executables like this: ./gvim ? This is what I
    Message 1 of 1 , Dec 6, 2004
      Matthew,

      Thanks for all of your help, but gvim still doesn't work on my Mac OSX!

      Am I not supposed to invoke executables like this:

      ./gvim

      ?

      This is what I tried after fixing my "typos":

      Last login: Mon Dec 6 22:17:46 on ttyp1
      Welcome to Darwin!
      Raven:~ untz$ gvim
      -bash: gvim: command not found
      Raven:~ untz$ cat .profile
      alias vim="/Developer/vim/Vim.app/Contents/MacOS/Vim"
      alias gvim="/Developer/vim/Vim.app/Contents/MacOS/Vim -g"
      test -r /sw/bin/init.sh && . /sw/bin/init.sh
      Raven:~ untz$

      Can anyone please help?

      All the best,

      Unnsse


      > From: "Matthew J. Stott" <stottm@...>
      > Date: Mon, 6 Dec 2004 22:19:38 -0500
      > To: Unnsse Khan <untzkhan@...>
      > Subject: Re: Need Help Running gvim (GUI version on Mac OSX)
      >
      > Looks like you made a typo on the executable filename. Unix is
      > notoriously case sensitive.
      >
      > Try this: (in .profile)
      >
      > alias vim="/Developer/vim/Vim.app/Contents/MacOS/Vim"
      > ^ ^
      > alias gvim="/Developer/vim/Vim.app/Contents/MacOS/Vim -g"
      > ^ ^
      >
      > Note the capital Vim.app and the actual executable Vim has the V in
      > capital.
      >
      > FYI, you can also just type the alias command at the prompt to test
      > it out. It sets the alias but won't save it if you close the terminal
      > session. If you place it .profile it gets run every time you start
      > a console session.
      >
      > Try using the tab name completion feature.
      > <tab> means to press the Tab key.
      >
      > - Open the Terminal
      > - Type cd /Dev<tab>
      > - It should replace /Dev with /Developer
      > - Type cd /Developer/vim/V<tab>
      > - Again, it will replace V with Vim.app
      > - Type cd /Developer/vim/Vim.app/Con<tab>
      > - Once more, you will begin to see the light...
      > - Type cd /Developer/vim/Vim.app/Contents/Ma<tab>
      >
      > Do this until you get the full path... This helps with avoiding
      > typos. Careful, tab completion is addictive ;-)
      >
      >
      >
      >
      >
      > On Dec 6, 2004, at 12:57 AM, Unnsse Khan wrote:
      >
      >> Dear Mr. Stott:
      >>
      >> I edited the .profile file in my OS and it contains this:
      >>
      >> alias vim="/Developer/vim/vim.app/Contents/MacOS/vim"
      >> alias gvim="/Developer/vim/gvim.app/Contents/MacOS/gvim"
      >>
      >> For gvim, I tried what you suggested...
      >>
      >> My .vimrc looks like this:
      >>
      >> syntax on
      >> colorscheme torte
      >> set ts=4
      >> set nu!
      >>
      >> The background does appear black and the line numbers are turned on...
      >>
      >> My problem, is that from the command line, I can't run gvim.
      >>
      >> I tried your suggestion of placing this in the .profile:
      >>
      >> alias vim="/Developer/vim/vim.app/Contents/MacOS/vim -g"
      >>
      >> And was still unable to run the GUI Vim... The same error happened
      >> when I
      >> tried replacing the same line .profile with:
      >>
      >> alias gvim="/Developer/vim/gvim.app/Contents/MacOS/gvim"
      >>
      >> This is what happened when I typed gvim from the command line:
      >>
      >> Raven:~ untz$ gvim
      >> -bash: gvim: command not found
      >> Raven:~ untz$
      >>
      >>
      >>
      >>> From: "Matthew J. Stott" <stottm@...>
      >>> Date: Fri, 3 Dec 2004 10:22:10 -0500
      >>> To: <untzkhan@...>
      >>> Cc: <vim-mac@...>
      >>> Subject: Re: Pathing issue (cmd line invocation trouble)
      >>>
      >>> The Panther version of vim 6.2 console (no GUI) is located in /usr/bin
      >>> which is in your path.
      >>>
      >>> You can do several things, but the easiest most reliable (will
      >>> withstand an Apple upgrade),
      >>> would be to create an alias to point vim to the ViM 6.3 version at the
      >>> console.
      >>>
      >>> Within ~/.profile or ~/.bashrc (dotfile within your home directory)
      >>>
      >>> alias vim="/Applications/Vim.app/Contents/MacOS/Vim"
      >>>
      >>> This will substitute vim with /Applications/Vim.app/Contents/MacOS/Vim
      >>> whenever you type vim
      >>> at the console. If you pass the parameter -g to the vim alias, it
      >>> will
      >>> then launch the GUI Vim. You
      >>> could create another alias to handle the GUI version.
      >>>
      >>> alias gvim="/Applications/Vim.app/Contents/MacOS/Vim -g"
      >>>
      >>> Obviously, change the path from
      >>> /Applications/Vim.app/Contents/MacOS/Vim to
      >>> /Developer/Vim.app/Contents/MacOS/Vim or where you installed Vim.app.
      >>> (.app is hidden in Apple finder but visible from console).
      >>>
      >>> You specify color schemes inside your .vimrc or .gvimrc. The .vimrc
      >>> is
      >>> used by the console
      >>> vim and .gvimrc is used when the GUI vim is launched. If you want
      >>> both
      >>> to be the same just
      >>> use .vimrc.
      >>>
      >>> Within ~/.vimrc
      >>>
      >>> syntax on
      >>> colorscheme torte
      >>>
      >>> I've specified torte but there are many others. Launch the GUI vim
      >>> and
      >>> click Edit then Colorscheme
      >>> and try a few of them out. Decide which one you like best and set it
      >>> in your .vimrc file.
      >>>
      >>>
      >>>
      >>>
      >>>
      >>> On Dec 2, 2004, at 11:56 PM, Unnsse Khan wrote:
      >>>
      >>>> If I downloaded the latest version of vim to /Developer/vim/
      >>>>
      >>>> How do I set the path where I can invoke gvim from the command line
      >>>> by
      >>>> typing gvim?
      >>>>
      >>>> Also, how do I set the background to black and the foreground to
      >>>> white?
      >>>
      >>
      >>
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.