Loading ...
Sorry, an error occurred while loading the content.

CJK and Xcode integration

Expand Messages
  • Da Woon Jung
    Hi, I m a regular Vim user and Carbon/Cocoa developer trying to get CJK (in particular, Hangul) to work in OS X Vim. As it is, it sort of works after setting
    Message 1 of 2 , Dec 4, 2004
    • 0 Attachment
      Hi,

      I'm a regular Vim user and Carbon/Cocoa developer trying to get CJK (in
      particular, Hangul) to work in OS X Vim. As it is, it sort of works
      after setting guifont correctly and switching on encoding=utf-8 but
      some words are not typing correctly. Moreover, direct input results in
      gibberish being typed, and monotype fonts combined with double-width
      characters looks squashed. If these are known bugs, I'd like to help
      out with fixing them. I've tried compiling from CVS with multibyte
      enabled but it doesn't seem to make a difference.

      Also I've noticed that when I set Vim as the editor for Xcode, things
      like double-clicking on Find results and compile errors take me to the
      correct source file and line! This must be some Apple Event magic (my
      Emacs-using friend was suitably impressed by this), except Vim is slow
      to respond. So if I double click a find result in Xcode, the Vim window
      immediately pops to the front with the correct file, but I have to
      click anywhere on the Vim window to make it go to the line. Another
      issue is compile errors go to the previous line, as if line indexing is
      off by one. I'd like to help out with fixing these too.

      My system: OS X 10.3.6, Vim 6.3.35 (CVS), Xcode 1.5

      Cheers,
      DW
      http://dwj.freeshell.org







      ___________________________________
      기본 250MB 최대 1GB, 더 이상 용량 고민없는 - 야후! 메일 (http://mail.yahoo.co.kr)
      최신곡, 추천곡, 가요, OST, 팝송, 뮤직비디오 - 야후! 비트박스 (http://kr.music.yahoo.com)
      최신 휴대폰 정보, 벨소리, 캐릭터, 문자메세지 - 야후! 모바일 (http://kr.mobile.yahoo.com)
    • Bram Moolenaar
      ... There are a few known problems with input modes in utf-8. So far we have not found someone who will work on this. Thus if you can improve this stuff that
      Message 2 of 2 , Dec 5, 2004
      • 0 Attachment
        Da Woon Jung wrote:

        > I'm a regular Vim user and Carbon/Cocoa developer trying to get CJK (in
        > particular, Hangul) to work in OS X Vim. As it is, it sort of works
        > after setting guifont correctly and switching on encoding=utf-8 but
        > some words are not typing correctly. Moreover, direct input results in
        > gibberish being typed, and monotype fonts combined with double-width
        > characters looks squashed. If these are known bugs, I'd like to help
        > out with fixing them. I've tried compiling from CVS with multibyte
        > enabled but it doesn't seem to make a difference.

        There are a few known problems with input modes in utf-8. So far we
        have not found someone who will work on this. Thus if you can improve
        this stuff that would be very much appreciated. I really want the utf-8
        support to work properly.

        > Also I've noticed that when I set Vim as the editor for Xcode, things
        > like double-clicking on Find results and compile errors take me to the
        > correct source file and line! This must be some Apple Event magic (my
        > Emacs-using friend was suitably impressed by this), except Vim is slow
        > to respond. So if I double click a find result in Xcode, the Vim window
        > immediately pops to the front with the correct file, but I have to
        > click anywhere on the Vim window to make it go to the line.

        Vim probably doesn't "wake up" and an event is needed to get going
        again. I don't know what event is sent to Vim, apparently it's not
        handled properly.

        > Another issue is compile errors go to the previous line, as if line
        > indexing is off by one. I'd like to help out with fixing these too.

        That should be easy to fix, when you know what event is sent to Vim.
        I don't have Xcode, thus I can't try it out.

        > My system: OS X 10.3.6, Vim 6.3.35 (CVS), Xcode 1.5

        If you start working on this, please do this with Vim 7. It's in
        another branch of CVS. You can send me patches.

        --
        Managers are like cats in a litter box. They instinctively shuffle things
        around to conceal what they've done.
        (Scott Adams - The Dilbert principle)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy LOTR 3 and help AIDS victims -- http://ICCF.nl/lotr.html ///
      Your message has been successfully submitted and would be delivered to recipients shortly.