Loading ...
Sorry, an error occurred while loading the content.

Help configuring gvim on Mac OSX

Expand Messages
  • Unnsse M. Khan
    Hello, I need help configuring gvim for the Mac OSX platform... I downloaded and installed in it: /Developer/vim when I click on the shortcut on the desktop, I
    Message 1 of 2 , Nov 30, 2004
    • 0 Attachment
      Hello,

      I need help configuring gvim for the Mac OSX platform...

      I downloaded and installed in it:

      /Developer/vim

      when I click on the shortcut on the desktop, I get this error message:

      Error detected while processing /Users/untz/.vimrc
      line 1:
      E488: Trailing characters: nocompatible^M
      line 2:
      E15: Invalid expression: $USERPROFILE^M
      line 3:
      E484: Can't open file /Applications/vim/Vim.app/runtime/vimrc_example.vim^M
      line

      the .vimrc file's contents are:

      set nocompatible
      let $HOME=$USERPROFILE
      source $VIMRUNTIME/vimrc_example.vim
      source $VIMRUNTIME/mswin.vim
      set nu
      set ts=4
      hi Normal guibg=black guifg=grey90
      set bg=dark
      syn on

      What I want to do is:

      (1) Have it automatically match the syntax coloring according to the particular file type.
      (2) Set the background to black.
      (3) Set the tab spacing to 4.
      (4) Turn the line numbers on.

      Also, how do I set it so I can run it on the command line by typing:

      gvim

      I know that some of these settings are from my WinXP vimrc file...

      Can anyone help?

      Thanks again!


      -Unnsse
    • Bram Moolenaar
      ... Your .vimrc file apparently is in DOS format. You can fix it this way: vim -u NONE ... -- We apologise again for the fault in the subtitles. Those
      Message 2 of 2 , Dec 1, 2004
      • 0 Attachment
        Unnsse wrote:

        > I need help configuring gvim for the Mac OSX platform...
        >
        > I downloaded and installed in it:
        >
        > /Developer/vim
        >
        > when I click on the shortcut on the desktop, I get this error message:
        >
        > Error detected while processing /Users/untz/.vimrc
        > line 1:
        > E488: Trailing characters: nocompatible^M
        > line 2:
        > E15: Invalid expression: $USERPROFILE^M
        > line 3:
        > E484: Can't open file /Applications/vim/Vim.app/runtime/vimrc_example.vim^M
        > line

        Your .vimrc file apparently is in DOS format.

        You can fix it this way:

        vim -u NONE
        :set nocp
        :edit .vimrc
        :set ff=unix
        :wq

        --
        We apologise again for the fault in the subtitles. Those responsible for
        sacking the people who have just been sacked have been sacked.
        "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
      Your message has been successfully submitted and would be delivered to recipients shortly.