Loading ...
Sorry, an error occurred while loading the content.

Re: :split and scrolling doesn't work?

Expand Messages
  • Bram Moolenaar
    ... scrollbind is default off, it must have been set somewhere. -- hundred-and-one symptoms of being an internet addict: 108. While reading a magazine, you
    Message 1 of 9 , Oct 10, 2004
    • 0 Attachment
      Daryl Basil Biberdorf wrote:

      > Setting noscrollbind did the trick. Not sure how/why scrollbind
      > is set. I wasn't aware of the setting. Thanks for the help!
      > On Oct 9, 2004, at 5:18 PM, Stephen Riehm wrote:

      Try:

      :verbose set scrollbind?

      'scrollbind' is default off, it must have been set somewhere.

      --
      hundred-and-one symptoms of being an internet addict:
      108. While reading a magazine, you look for the Zoom icon for a better
      look at a photograph.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
    • Daryl Basil Biberdorf
      What is the best way to get the output of :verbose set scrollbind with gvim under OS X? My problem: I added set noscrollbind to .vimrc. It works under vim when
      Message 2 of 9 , Oct 12, 2004
      • 0 Attachment
        What is the best way to get the output of :verbose set scrollbind
        with gvim under OS X?

        My problem: I added set noscrollbind to .vimrc. It works under vim
        when used in a terminal window. But when using gvim, it has no
        effect at all. I added set noscrollbind to .gvimrc as well, which
        seems redundant, but to no effect as well. Other settings in .gvimrc
        and ,vimrc are getting picked up, so my scrollbind setting must be
        getting overridden somewhere. Yes, this is just maddening. Even
        more frustrating is that I'm still figuring OS X out. If this were
        Linux, I'd already have it done. :)

        On another note, this list has been generating a lot of spam for me
        in the last couple of days, mostly in the form of messages saying the
        originate from people on the list (Bram in particular).

        Basil
        On Oct 10, 2004, at 6:56 AM, Bram Moolenaar wrote:

        >
        > Daryl Basil Biberdorf wrote:
        >
        >> Setting noscrollbind did the trick. Not sure how/why scrollbind
        >> is set. I wasn't aware of the setting. Thanks for the help!
        >> On Oct 9, 2004, at 5:18 PM, Stephen Riehm wrote:
        >
        > Try:
        >
        > :verbose set scrollbind?
        >
        > 'scrollbind' is default off, it must have been set somewhere.
        >
        > --
        > hundred-and-one symptoms of being an internet addict:
        > 108. While reading a magazine, you look for the Zoom icon for a better
        > look at a photograph.
        >
        > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net
        > \\\
        > /// Sponsor Vim, vote for features --
        > http://www.Vim.org/sponsor/ \\\
        > \\\ Project leader for A-A-P -- http://www.A-A-P.org
        > ///
        > \\\ Buy at Amazon and help AIDS victims --
        > http://ICCF.nl/click1.html ///
        >
      • Bram Moolenaar
        ... Eh, type the command? ... Very strange. Perhaps this gvim does not use your startup files? That would be strange. Use :scriptnames to see which script
        Message 3 of 9 , Oct 12, 2004
        • 0 Attachment
          Daryl Basil Biberdorf wrote:

          > What is the best way to get the output of :verbose set scrollbind
          > with gvim under OS X?

          Eh, type the command?

          > My problem: I added set noscrollbind to .vimrc. It works under vim
          > when used in a terminal window. But when using gvim, it has no
          > effect at all. I added set noscrollbind to .gvimrc as well, which
          > seems redundant, but to no effect as well. Other settings in .gvimrc
          > and ,vimrc are getting picked up, so my scrollbind setting must be
          > getting overridden somewhere. Yes, this is just maddening. Even
          > more frustrating is that I'm still figuring OS X out. If this were
          > Linux, I'd already have it done. :)

          Very strange. Perhaps this gvim does not use your startup files? That
          would be strange. Use ":scriptnames" to see which script files have
          been used.

          > On another note, this list has been generating a lot of spam for me
          > in the last couple of days, mostly in the form of messages saying the
          > originate from people on the list (Bram in particular).

          E-mail address harvesters are very annoying. There does not seem to be
          a remedy against it, without disabling others from replying to you.

          --
          hundred-and-one symptoms of being an internet addict:
          126. You brag to all of your friends about your date Saturday night...but
          you don't tell them it was only in a chat room.

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
          \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
        • Daryl Basil Biberdorf
          Bram, apologies for my ignorance. I did some reading on OS X bundles, and finally figured out how to do what I needed to do. I removed the set noscrollbind
          Message 4 of 9 , Oct 12, 2004
          • 0 Attachment
            Bram, apologies for my ignorance. I did some reading
            on OS X bundles, and finally figured out how to do what
            I needed to do. I removed the 'set noscrollbind' commands
            I added to ~/.gvimrc and ~/.vimrc and started Vim with:
            /Applications/Vim.app/Contents/MacOS/Vim -g -c 'verbose set scrollbind?'
            from the OS X terminal window.

            Nothing is setting scrollbind, so, in this OS X build
            at least, scrollbind is the default, rather than noscrollbind.

            The configure script for building the app didn't reveal anything,
            but I'm an autoconf neophyte also.

            As a final complication, even if I add 'set noscrollbind' as the
            very last line in ~/.gvimrc, it has no effect, even when Vim
            indicates ~/.gvimrc is the last file sourced (according to
            /Applications/Vim.app/Contents/MacOS/Vim -g -V).

            Can anyone else here confirm the default scrollbind behavior
            in the Vim 6.3 Mac OS X build?

            Basil

            Bram Moolenaar wrote:
            > Daryl Basil Biberdorf wrote:
            >
            >
            >>What is the best way to get the output of :verbose set scrollbind
            >>with gvim under OS X?
            >
            >
            > Eh, type the command?
            >
            >
            >>My problem: I added set noscrollbind to .vimrc. It works under vim
            >>when used in a terminal window. But when using gvim, it has no
            >>effect at all. I added set noscrollbind to .gvimrc as well, which
            >>seems redundant, but to no effect as well. Other settings in .gvimrc
            >>and ,vimrc are getting picked up, so my scrollbind setting must be
            >>getting overridden somewhere. Yes, this is just maddening. Even
            >>more frustrating is that I'm still figuring OS X out. If this were
            >>Linux, I'd already have it done. :)
            >
            >
            > Very strange. Perhaps this gvim does not use your startup files? That
            > would be strange. Use ":scriptnames" to see which script files have
            > been used.
            >
            >
            >>On another note, this list has been generating a lot of spam for me
            >>in the last couple of days, mostly in the form of messages saying the
            >>originate from people on the list (Bram in particular).
            >
            >
            > E-mail address harvesters are very annoying. There does not seem to be
            > a remedy against it, without disabling others from replying to you.
            >
          • Bram Moolenaar
            ... In that case it must be an autocommand kicking in. Check for a VimEnter autocommand somewhere. Also, try editing a different kind of file. Although
            Message 5 of 9 , Oct 12, 2004
            • 0 Attachment
              Daryl Basil Biberdorf wrote:

              > Bram, apologies for my ignorance. I did some reading
              > on OS X bundles, and finally figured out how to do what
              > I needed to do. I removed the 'set noscrollbind' commands
              > I added to ~/.gvimrc and ~/.vimrc and started Vim with:
              > /Applications/Vim.app/Contents/MacOS/Vim -g -c 'verbose set scrollbind?'
              > from the OS X terminal window.
              >
              > Nothing is setting scrollbind, so, in this OS X build
              > at least, scrollbind is the default, rather than noscrollbind.
              >
              > The configure script for building the app didn't reveal anything,
              > but I'm an autoconf neophyte also.
              >
              > As a final complication, even if I add 'set noscrollbind' as the
              > very last line in ~/.gvimrc, it has no effect, even when Vim
              > indicates ~/.gvimrc is the last file sourced (according to
              > /Applications/Vim.app/Contents/MacOS/Vim -g -V).

              In that case it must be an autocommand kicking in. Check for a
              "VimEnter" autocommand somewhere. Also, try editing a different kind of
              file. Although it's unlikely that a filetype plugin would set
              'scrollbind'.

              > Can anyone else here confirm the default scrollbind behavior
              > in the Vim 6.3 Mac OS X build?

              I'm quite sure 'scrollbind' is off by default in all builds.

              --
              Never eat yellow snow.

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
              \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
            • Stephen Riehm
              What you re describing is most bizarre indeed - and no-one else has noticed it? Do you mind if I ask you to do a little copy and pasting? 1: what version of
              Message 6 of 9 , Oct 12, 2004
              • 0 Attachment
                What you're describing is most bizarre indeed - and no-one else has
                noticed it?

                Do you mind if I ask you to do a little copy and pasting?

                1: what version of vim do you have? I'm running vim 6.3.13 on OS-X
                10.3.5

                2: could you post the output from :scriptnames?
                here's mine:
                1: /Users/steve/.vimrc
                2: /Applications/Vim.app/runtime/syntax/nosyntax.vim
                3: /Users/steve/.vim.bracketing.macros
                4: /Users/steve/.vim.bracketing.base
                5: /Applications/Vim.app/runtime/plugin/explorer.vim
                6: /Applications/Vim.app/runtime/plugin/gzip.vim
                7: /Applications/Vim.app/runtime/plugin/netrw.vim
                8: /Applications/Vim.app/runtime/plugin/rrhelper.vim
                9: /Applications/Vim.app/runtime/plugin/tohtml.vim
                10: /Applications/Vim.app/runtime/menu.vim
                11: /Users/steve/.gvimrc
                12: /Applications/Vim.app/runtime/colors/peachpuff.vim
                13: /Applications/Vim.app/runtime/syntax/syntax.vim
                14: /Applications/Vim.app/runtime/syntax/synload.vim
                15: /Applications/Vim.app/runtime/syntax/syncolor.vim
                16: /Applications/Vim.app/runtime/filetype.vim

                3: when the problem arises in gvim, does it go away when you set
                noscrollbind manually?

                4: How exactly are you starting gvim? Do you click or drag'n'drop the
                icon, or do you use the full path (via an alias)?

                5: Doe the problem occur when you :split and when you :new?

                6: Does the problem occur when you are editing a README.txt and a
                READYOU.txt file? What about C, C++, Perl, Python or other code files?

                Steve
              Your message has been successfully submitted and would be delivered to recipients shortly.