Loading ...
Sorry, an error occurred while loading the content.

vim file creator problems

Expand Messages
  • Stewart Smith
    Hello, I m totally new here so please forgive any questions I have that have been answered many times before. I tried to read the FAQ from the list which
    Message 1 of 4 , Jul 13, 2001
    • 0 Attachment
      Hello,
      I'm totally new here so please forgive any questions I have that have been
      answered many times before. I tried to read the FAQ from the list which didn't
      exist and yahoogroups refuses point blank to let me read the archive (A yahoo
      problem rather than anything else). Anyway I'm a PhD student who uses vim on a
      Solaris network, mostly to edit troff/groff and LaTeX files. I've just been
      lent a powerbook 520 (68k, MacOS 7.5.1) to use at home to let me try and get
      some of my thesis written and I've spent most of today getting the 5.7.9+
      version of Mac Vim from Axel Keilhorn's site and setting it up on the laptop.
      Anwyay it all works fine except that all of the help files and any files that
      the 68k version creates are marked so that the computer thinks that it was the
      PPC version that created them. This means I have to drop them into the 68k
      appicon in order to run them as I get an error if I try to double click to open
      them. Has this come up before? Are there any fixes that would be easy for a
      Mac novice? Thanks in advance for any help.

      Regards
      Stewart
      --
      Stewart Smith
      Scottish Microelectronics Centre, University of Edinburgh.
      http://www.ee.ed.ac.uk/~sxs/
    • Eugene Lee
      ... Just trash the PPC version. Finder should then use the 68k version, as that s the only version available. -- Eugene Lee eugene@anime.net
      Message 2 of 4 , Jul 13, 2001
      • 0 Attachment
        On Fri, Jul 13, 2001 at 03:04:57PM +0100, Stewart Smith wrote:
        :
        : I've just been lent a powerbook 520
        : (68k, MacOS 7.5.1) to use at home to let me try and get some of my
        : thesis written and I've spent most of today getting the 5.7.9+ version
        : of Mac Vim from Axel Keilhorn's site and setting it up on the laptop.
        : Anwyay it all works fine except that all of the help files and any
        : files that the 68k version creates are marked so that the computer
        : thinks that it was the PPC version that created them. This means I
        : have to drop them into the 68k appicon in order to run them as I get
        : an error if I try to double click to open them. Has this come up
        : before? Are there any fixes that would be easy for a Mac novice?
        : Thanks in advance for any help.

        Just trash the PPC version. Finder should then use the 68k version, as
        that's the only version available.


        --
        Eugene Lee
        eugene@...
      • Stewart Smith
        ... Thanks for the help. That did the trick. Also thanks to Eugene Lee for the other reply. Now I m just going to have to get used to not having ^a mapped to
        Message 3 of 4 , Jul 14, 2001
        • 0 Attachment
          Dick Brooks wrote:
          >
          > Stewart,
          > I think you can cause the finder to "re-associate" files with the 68k vim
          > executable by deleting the PPC executable and then "rebuilding the desktop".
          > You may wish to refer to AppleCare Tech Info Library article 7828 at: http://til.info.apple.com/techinfo.nsf/artnum/n7828 which explains how to
          > do this. Good luck.
          > --
          > Regards,
          > Richard Brooks
          > dickb@...
          >

          Thanks for the help. That did the trick. Also thanks to Eugene Lee for the
          other reply. Now I'm just going to have to get used to not having ^a mapped to
          fmt.

          Stewart
          --
          Stewart Smith
          Scottish Microelectronics Centre, University of Edinburgh.
          http://www.ee.ed.ac.uk/~sxs/
        • Eugene Lee
          ... Why need fmt when gq does so much more? :-) -- Eugene Lee eugene@anime.net
          Message 4 of 4 , Jul 14, 2001
          • 0 Attachment
            On Sat, Jul 14, 2001 at 01:22:31PM +0100, Stewart Smith wrote:
            :
            : Thanks for the help. That did the trick. Also thanks to Eugene Lee for the
            : other reply. Now I'm just going to have to get used to not having ^a mapped to
            : fmt.

            Why need fmt when 'gq' does so much more? :-)


            --
            Eugene Lee
            eugene@...
          Your message has been successfully submitted and would be delivered to recipients shortly.