Loading ...
Sorry, an error occurred while loading the content.

Fwd: Re: How to get keypad keys to work [MacOSX, vim]

Expand Messages
  • Sven Guckes
    Can you help Bill here? Do we have testers for Mac OS X here? Ripley? Sven === From: Bill Tschumy Newsgroups: comp.editors Subject: Re:
    Message 1 of 8 , Mar 30, 2001
    • 0 Attachment
      Can you help Bill here?
      Do we have testers for Mac OS X here? Ripley?

      Sven

      ===
      From: Bill Tschumy <bill@...>
      Newsgroups: comp.editors
      Subject: Re: How to get keypad keys to work [MacOSX, vim]
      Date: Thu, 29 Mar 2001 21:44:01 -0600
      Message-ID: <01HW.B6E95D21004A388C11C99950@...>

      One other bit of info. When I "make" using the stock system it dies
      trying to compile term.c because termcap.h is not found. This file isn't
      on my MacOSX system (although I've installed all the developer files).

      Here is the compile output:

      localhost% make
      CC="cc -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp "
      srcdir=. sh ./osdef.sh
      osdef0.c:8: termcap.h: No such file or directory
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp buffer.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp charset.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp digraph.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp edit.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp eval.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ex_cmds.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ex_docmd.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ex_getln.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp fileio.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp getchar.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp if_cscope.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp main.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp mark.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp memfile.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp memline.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp menu.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp message.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp misc1.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp misc2.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp multbyte.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp normal.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ops.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp option.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp os_unix.c
      creating pathdef.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp pathdef.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp quickfix.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp regexp.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp screen.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp search.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp syntax.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp tag.c
      cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp term.c
      term.c:32: termcap.h: No such file or directory
      make: *** [term.o] Error 1

      * Bill Tschumy <bill@...>:
      > I am trying to use vim (non-gui version) on the
      > new MacOSX operating system (finally Unix on Mac).
      > The "Terminal" app that comes with the OS does vt100 emulation.
      > When I start up vim I get the opening message:
      > Terminal entry not found in terminfo
      > vt100 not known
      > <lists 4 terminal options>
      > defaulting to 'ansi'
      > I assume my arrow keys and other keypad keys are not working
      > (generally just beeps) because it doesn't know about vt100.
      > What do I need to do to get this working?

      * Sven Guckes:
      > Install vim with "+builtin_terms"? Please try.

      --
      Bill Tschumy
      Otherwise -- Austin, TX
      bill@...
    • Bill Tschumy
      I have gotten this to compile, but probably not in the correct way. First in feature.h I commented in the definition of NO_BUILTIN_TCAPS #ifdef HAVE_TGETENT #
      Message 2 of 8 , Mar 30, 2001
      • 0 Attachment
        I have gotten this to compile, but probably not in the correct way.

        First in feature.h I commented in the definition of NO_BUILTIN_TCAPS

        #ifdef HAVE_TGETENT
        # define NO_BUILTIN_TCAPS
        #endif


        Then in config.h I manually commented out the define of
        HAVE_TERMCAP_H (I know this is auto-generated and there probably
        something else I could change but I couldn't find it). This file
        does not appear to be present on Mac OSX.

        /* Define if you have the <termcap.h> header file. */
        /*#define HAVE_TERMCAP_H 1*/

        This seemed to compile correctly and VIM now recognizes my vt100 terminal type.


        >Can you help Bill here?
        >Do we have testers for Mac OS X here? Ripley?
        >
        >Sven
        >
        >===
        >From: Bill Tschumy <bill@...>
        >Newsgroups: comp.editors
        >Subject: Re: How to get keypad keys to work [MacOSX, vim]
        >Date: Thu, 29 Mar 2001 21:44:01 -0600
        >Message-ID: <01HW.B6E95D21004A388C11C99950@...>
        >
        >One other bit of info. When I "make" using the stock system it dies
        >trying to compile term.c because termcap.h is not found. This file isn't
        >on my MacOSX system (although I've installed all the developer files).
        >
        >Here is the compile output:
        >
        >localhost% make
        >CC="cc -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp "
        >srcdir=. sh ./osdef.sh
        >osdef0.c:8: termcap.h: No such file or directory
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp buffer.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp charset.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp digraph.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp edit.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp eval.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ex_cmds.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ex_docmd.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ex_getln.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp fileio.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp getchar.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp if_cscope.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp main.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp mark.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp memfile.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp memline.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp menu.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp message.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp misc1.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp misc2.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp multbyte.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp normal.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp ops.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp option.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp os_unix.c
        >creating pathdef.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp pathdef.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp quickfix.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp regexp.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp screen.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp search.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp syntax.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp tag.c
        >cc -c -I. -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp term.c
        >term.c:32: termcap.h: No such file or directory
        >make: *** [term.o] Error 1
        >
        >* Bill Tschumy <bill@...>:
        >> I am trying to use vim (non-gui version) on the
        >> new MacOSX operating system (finally Unix on Mac).
        >> The "Terminal" app that comes with the OS does vt100 emulation.
        >> When I start up vim I get the opening message:
        >> Terminal entry not found in terminfo
        >> vt100 not known
        >> <lists 4 terminal options>
        >> defaulting to 'ansi'
        >> I assume my arrow keys and other keypad keys are not working
        >> (generally just beeps) because it doesn't know about vt100.
        >> What do I need to do to get this working?
        >
        >* Sven Guckes:
        >> Install vim with "+builtin_terms"? Please try.
        >
        >--
        >Bill Tschumy
        >Otherwise -- Austin, TX
        >bill@...

        --
        Bill Tschumy
        Otherwise -- Austin, TX
        bill@...
      • Dave Chen
        ... When I do a configure and then make it does the right thing. If uses termios.h, not termcap.h. Not sure why your configure doesn t get it right. Dave
        Message 3 of 8 , Mar 30, 2001
        • 0 Attachment
          Bill Tschumy wrote:

          > I have gotten this to compile, but probably not in the correct way.
          >
          > First in feature.h I commented in the definition of NO_BUILTIN_TCAPS
          >
          > #ifdef HAVE_TGETENT
          > # define NO_BUILTIN_TCAPS
          > #endif
          >
          > Then in config.h I manually commented out the define of
          > HAVE_TERMCAP_H (I know this is auto-generated and there probably
          > something else I could change but I couldn't find it). This file
          > does not appear to be present on Mac OSX.
          >
          > /* Define if you have the <termcap.h> header file. */
          > /*#define HAVE_TERMCAP_H 1*/
          >
          > This seemed to compile correctly and VIM now recognizes my vt100 terminal type.

          When I do a "configure" and then "make" it does the right thing.

          If uses termios.h, not termcap.h. Not sure why your configure doesn't

          get it right.

          Dave

          --
          ___( mailto:dave@..., http://visual.nlm.nih.gov/~dave )___
          The only thing that allows me to keep my slender grip on reality
          is the friendship I share with my collection of singing potatoes.
          -- Holly, "Red Dwarf"
        • Bill Tschumy
          ... I definitely did a configure before make, but it got it wrong. Not sure either. -- Bill Tschumy Otherwise -- Austin, TX bill@otherwise.com
          Message 4 of 8 , Mar 30, 2001
          • 0 Attachment
            At 11:21 AM -0500 3/30/01, Dave Chen wrote:
            >Bill Tschumy wrote:
            >
            >> I have gotten this to compile, but probably not in the correct way.
            >>
            >> First in feature.h I commented in the definition of NO_BUILTIN_TCAPS
            >>
            >> #ifdef HAVE_TGETENT
            >> # define NO_BUILTIN_TCAPS
            >> #endif
            >>
            >> Then in config.h I manually commented out the define of
            >> HAVE_TERMCAP_H (I know this is auto-generated and there probably
            >> something else I could change but I couldn't find it). This file
            >> does not appear to be present on Mac OSX.
            >>
            >> /* Define if you have the <termcap.h> header file. */
            >> /*#define HAVE_TERMCAP_H 1*/
            >>
            >> This seemed to compile correctly and VIM now recognizes my vt100
            >>terminal type.
            >
            >When I do a "configure" and then "make" it does the right thing.
            >
            >If uses termios.h, not termcap.h. Not sure why your configure doesn't
            >
            >get it right.
            >
            >Dave
            >

            I definitely did a configure before make, but it got it wrong. Not
            sure either.

            --
            Bill Tschumy
            Otherwise -- Austin, TX
            bill@...
          • Bram Moolenaar
            ... Since this inside a #ifdef HAVE_TERMCAP_H, there must be something wrong with running configure. Any idea why HAVE_TERMCAP_H was defined while the
            Message 5 of 8 , Mar 30, 2001
            • 0 Attachment
              Bill Tschumy wrote:

              > One other bit of info. When I "make" using the stock system it dies
              > trying to compile term.c because termcap.h is not found. This file isn't
              > on my MacOSX system (although I've installed all the developer files).
              >
              > Here is the compile output:
              >
              > localhost% make
              > CC="cc -Iproto -DHAVE_CONFIG_H -O2 --traditional-cpp "
              > srcdir=. sh ./osdef.sh
              > osdef0.c:8: termcap.h: No such file or directory

              Since this inside a #ifdef HAVE_TERMCAP_H, there must be something
              wrong with running configure. Any idea why HAVE_TERMCAP_H was defined
              while the compiler can't find it?

              --
              ARTHUR: Now stand aside worthy adversary.
              BLACK KNIGHT: (Glancing at his shoulder) 'Tis but a scratch.
              ARTHUR: A scratch? Your arm's off.
              "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

              /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
              ((( Creator of Vim - http://www.vim.org -- ftp://ftp.vim.org/pub/vim )))
              \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
            • Bram Moolenaar
              ... You could also do this with a compiler argument -DNO_BUILTIN_TCAPS ... Strange. This is checked with the standard autoconf check AC_CHECK_HEADERS.
              Message 6 of 8 , Mar 30, 2001
              • 0 Attachment
                Bill Tschumy wrote:

                > I have gotten this to compile, but probably not in the correct way.
                >
                > First in feature.h I commented in the definition of NO_BUILTIN_TCAPS
                >
                > #ifdef HAVE_TGETENT
                > # define NO_BUILTIN_TCAPS
                > #endif

                You could also do this with a compiler argument -DNO_BUILTIN_TCAPS

                > Then in config.h I manually commented out the define of
                > HAVE_TERMCAP_H (I know this is auto-generated and there probably
                > something else I could change but I couldn't find it). This file
                > does not appear to be present on Mac OSX.
                >
                > /* Define if you have the <termcap.h> header file. */
                > /*#define HAVE_TERMCAP_H 1*/

                Strange. This is checked with the standard autoconf check
                AC_CHECK_HEADERS. Perhaps the shell isn't 100% compatible?

                --
                Any resemblance between the above views and those of my employer, my terminal,
                or the view out my window are purely coincidental. Any resemblance between
                the above and my own views is non-deterministic. The question of the
                existence of views in the absence of anyone to hold them is left as an
                exercise for the reader. The question of the existence of the reader is left
                as an exercise for the second god coefficient. (A discussion of
                non-orthogonal, non-integral polytheism is beyond the scope of this article.)
                (Ralph Jennings)

                /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                ((( Creator of Vim - http://www.vim.org -- ftp://ftp.vim.org/pub/vim )))
                \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
              • H. Eckert
                ... No time at all from me, but you re welcome to visit me at my place and use my G3 for it. Greetings, Ripley -- H. Eckert, 12051 Berlin ISO 8859-1: Ä=Ae,
                Message 7 of 8 , Apr 3, 2001
                • 0 Attachment
                  Quoting Sven Guckes (guckes@...):
                  > Can you help Bill here?
                  > Do we have testers for Mac OS X here? Ripley?

                  No time at all from me, but you're welcome to visit me at
                  my place and use my G3 for it.


                  Greetings,
                  Ripley
                  --
                  H. Eckert, 12051 Berlin
                  ISO 8859-1: Ä=Ae, Ö=Oe, Ü=Ue, ä=ae, ö=oe, ü=ue, ß=sz.
                • Bill Tschumy
                  Wanted to let the list know that I did get this to work. The config problem seemed to be due to the distribution I used (downloaded from someone who said he
                  Message 8 of 8 , Apr 3, 2001
                  • 0 Attachment
                    Wanted to let the list know that I did get this to work. The config
                    problem seemed to be due to the distribution I used (downloaded from
                    someone who said he had compiled for Mac OS X). When I downloaded
                    the "official" distribution and configed/compiled it there was no
                    problem. It now recognizes the vt100 terminal and I have my arrow
                    keys working.

                    If anyone needs anything checked out on OSX just let me know.

                    BTW: Has there been any discussion of getting gvim running on OSX?

                    At 9:05 AM +0200 4/3/01, H. Eckert wrote:
                    >Quoting Sven Guckes (guckes@...):
                    >> Can you help Bill here?
                    >> Do we have testers for Mac OS X here? Ripley?
                    >
                    >No time at all from me, but you're welcome to visit me at
                    >my place and use my G3 for it.
                    >
                    >
                    >Greetings,
                    > Ripley
                    >--
                    >H. Eckert, 12051 Berlin
                    >ISO 8859-1: Ä=Ae, Ö=Oe, Ü=Ue, ä=ae, ö=oe, ü=ue, ß=sz.

                    --
                    Bill Tschumy
                    Otherwise -- Austin, TX
                    bill@...
                  Your message has been successfully submitted and would be delivered to recipients shortly.