Loading ...
Sorry, an error occurred while loading the content.

Re: Syntax highlighting & window sizes in Carbon Vim

Expand Messages
  • Nickolay Kolev
    ... Thanks for the default directory stuff Benji, I nicked those lines from your vimrc... :-) Moving swiftly along, I noticed another small glitch. Carbon vim
    Message 1 of 5 , Mar 21, 2004
    • 0 Attachment
      > if has("gui_running")
      > autocmd VimEnter * if getcwd()=="/" | if strlen(@%) | cd %:p:h | else
      > | cd | endif | endif
      > endif

      Thanks for the default directory stuff Benji, I nicked those lines from
      your vimrc... :-)

      Moving swiftly along, I noticed another small glitch. Carbon vim can
      not display directory names with non-ASCII characers.

      http://www.uni-bonn.de/~nmkolev/vim_dir.png

      On the left is a Terminal with vim running, on the right - Carbon Vim.

      Any ideas what might be done to remedy the situation?

      Nicky
    • Benji Fisher
      ... Is this specifically a problem with directory names on the command line, or is it more general than that? For example, if you try =@% in Insert mode
      Message 2 of 5 , Mar 24, 2004
      • 0 Attachment
        On Mon, Mar 22, 2004 at 07:35:57AM +0100, Nickolay Kolev wrote:
        > >if has("gui_running")
        > > autocmd VimEnter * if getcwd()=="/" | if strlen(@%) | cd %:p:h |
        > > else | cd | endif | endif
        > >endif
        >
        > Thanks for the default directory stuff Benji, I nicked those lines from
        > your vimrc... :-)
        >
        > Moving swiftly along, I noticed another small glitch. Carbon vim can
        > not display directory names with non-ASCII characers.
        >
        > http://www.uni-bonn.de/~nmkolev/vim_dir.png
        >
        > On the left is a Terminal with vim running, on the right - Carbon Vim.
        >
        > Any ideas what might be done to remedy the situation?
        >
        > Nicky

        Is this specifically a problem with directory names on the command
        line, or is it more general than that? For example, if you try

        <C-R>=@%

        in Insert mode to put the directory name into the buffer, do the
        characters display properly?

        Have you read the various :help topics on multibyte characters,
        guifont option, etc.? There are also some tips regarding multibyte
        characters, encoding, and so on on www.vim.org .

        HTH --Benji Fisher
      Your message has been successfully submitted and would be delivered to recipients shortly.