Loading ...
Sorry, an error occurred while loading the content.

Strange display in 6.2.285 (or earlier)

Expand Messages
  • Axel Kielhorn
    Hello! I started building Vim myself on MacOSX using the Makefile and gcc from XCode 1.1. I m building Vim with --enable-multibyte to get iconv support.
    Message 1 of 6 , Feb 27, 2004
    • 0 Attachment
      Hello!

      I started building Vim myself on MacOSX using the Makefile and gcc from
      XCode 1.1.
      I'm building Vim with --enable-multibyte to get iconv support.

      Starting with 6.2.285 I get a strange display:

      I'm using a Colorscheme with light background (based on zellner.vim,
      this will work to show the problem.)
      When using GUI vim and typing :ver I get the text black on white, but
      the empty space between the words is black instead of white.

      This did not happen in 6.2.253 which I build with the same
      configuration.
      If I remove --enable-multibyte, the behaviour returns to normal.

      I'm now patched up to 6.2.293 without change.

      Any ideas where to look?

      Axel
    • Bram Moolenaar
      ... My first guess was that the antialias patch would cause this. But that was 6.2.210, and you mention 6.2.253 was still OK. Can t think of what patch
      Message 2 of 6 , Feb 27, 2004
      • 0 Attachment
        Axel Kielhorn wrote:

        > I started building Vim myself on MacOSX using the Makefile and gcc from
        > XCode 1.1.
        > I'm building Vim with --enable-multibyte to get iconv support.
        >
        > Starting with 6.2.285 I get a strange display:
        >
        > I'm using a Colorscheme with light background (based on zellner.vim,
        > this will work to show the problem.)
        > When using GUI vim and typing :ver I get the text black on white, but
        > the empty space between the words is black instead of white.
        >
        > This did not happen in 6.2.253 which I build with the same
        > configuration.
        > If I remove --enable-multibyte, the behaviour returns to normal.
        >
        > I'm now patched up to 6.2.293 without change.
        >
        > Any ideas where to look?

        My first guess was that the antialias patch would cause this. But that
        was 6.2.210, and you mention 6.2.253 was still OK.

        Can't think of what patch between 6.2.253 and 6.2.285 would cause this
        problem. Are you sure it's not something in your setup?

        --
        DINGO: And after the spanking ... the oral sex.
        GALAHAD: Oh, dear! Well, I...
        GIRLS: The oral sex ... The oral sex.
        GALAHAD: Well, I suppose I could stay a BIT longer.
        "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
      • Benji Fisher
        ... Axel: If you are running OS X.iii, then you can try the version I uploaded yesterday, 6.2.293, on http://macvim.swdev.org/OSX/ . Then we can decide whether
        Message 3 of 6 , Feb 27, 2004
        • 0 Attachment
          On Fri, Feb 27, 2004 at 04:34:00PM +0100, Axel Kielhorn wrote:
          > Hello!
          >
          > I started building Vim myself on MacOSX using the Makefile and gcc from
          > XCode 1.1.
          > I'm building Vim with --enable-multibyte to get iconv support.
          >
          > Starting with 6.2.285 I get a strange display:
          >
          > I'm using a Colorscheme with light background (based on zellner.vim,
          > this will work to show the problem.)
          > When using GUI vim and typing :ver I get the text black on white, but
          > the empty space between the words is black instead of white.
          >
          > This did not happen in 6.2.253 which I build with the same
          > configuration.
          > If I remove --enable-multibyte, the behaviour returns to normal.
          >
          > I'm now patched up to 6.2.293 without change.
          >
          > Any ideas where to look?
          >
          > Axel

          Axel:

          If you are running OS X.iii, then you can try the version I
          uploaded yesterday, 6.2.293, on http://macvim.swdev.org/OSX/ .
          Then we can decide whether this is a run-time problem or a compile-time
          problem.

          I take it the problem does not show up without the color scheme?

          HTH --Benji Fisher
        • Axel Kielhorn
          ... In the meantime I patched to 6.2.311 and the problem is gone. Probably gremlins in my system. Axel
          Message 4 of 6 , Mar 3, 2004
          • 0 Attachment
            Am 27.02.2004 um 16:34 schrieb Axel Kielhorn:

            > Hello!
            >
            > I started building Vim myself on MacOSX using the Makefile and gcc
            > from XCode 1.1.
            > I'm building Vim with --enable-multibyte to get iconv support.
            >
            > Starting with 6.2.285 I get a strange display:
            >
            > I'm using a Colorscheme with light background (based on zellner.vim,
            > this will work to show the problem.)
            > When using GUI vim and typing :ver I get the text black on white, but
            > the empty space between the words is black instead of white.
            >
            > This did not happen in 6.2.253 which I build with the same
            > configuration.
            > If I remove --enable-multibyte, the behaviour returns to normal.
            >
            > I'm now patched up to 6.2.293 without change.
            >
            >
            In the meantime I patched to 6.2.311 and the problem is gone. Probably
            gremlins in my system.

            Axel
          • Eckehard Berns
            ... I had similar problems when (not fully) recompiling Vim with different settings (for me even the border was drawn in a dark color). A make clean && make
            Message 5 of 6 , Mar 4, 2004
            • 0 Attachment
              >> Starting with 6.2.285 I get a strange display:
              >>
              >> I'm using a Colorscheme with light background (based on zellner.vim,
              >> this will work to show the problem.)
              >> When using GUI vim and typing :ver I get the text black on white, but
              >> the empty space between the words is black instead of white.
              >
              > In the meantime I patched to 6.2.311 and the problem is gone. Probably
              > gremlins in my system.

              I had similar problems when (not fully) recompiling Vim with different
              settings (for me even the border was drawn in a dark color). A "make
              clean && make && make install" solved the problem for me. Since your
              problems don't show up now, they might have been caused by a similar
              problem. My guess would be that sometimes an object file isn't rebuild
              and thus a pointer to some color value get's mixed up in the resulting
              executable.

              --
              Eckehard Berns
            • Axel Kielhorn
              ... After seeing the problem the first time, I did a make clean. It didn t help. Axel
              Message 6 of 6 , Mar 4, 2004
              • 0 Attachment
                Am 04.03.2004 um 22:35 schrieb Eckehard Berns:

                >>> Starting with 6.2.285 I get a strange display:
                >>>
                >>> I'm using a Colorscheme with light background (based on zellner.vim,
                >>> this will work to show the problem.)
                >>> When using GUI vim and typing :ver I get the text black on white,
                >>> but the empty space between the words is black instead of white.
                >>
                >> In the meantime I patched to 6.2.311 and the problem is gone.
                >> Probably gremlins in my system.
                >
                > I had similar problems when (not fully) recompiling Vim with different
                > settings (for me even the border was drawn in a dark color). A "make
                > clean && make && make install" solved the problem for me.

                After seeing the problem the first time, I did a make clean. It didn't
                help.

                Axel
              Your message has been successfully submitted and would be delivered to recipients shortly.