Loading ...
Sorry, an error occurred while loading the content.
 

"cannot write..."

Expand Messages
  • peiman khosravi
    Hello, since I ve upgraded to the latest version (snapshot 73) on mavericks I m getting this error when trying to save a html document, and the file doesn t
    Message 1 of 4 , Apr 26 5:55 PM
      Hello, since I've upgraded to the latest version (snapshot 73) on mavericks I'm getting this error when trying to save a html document, and the file doesn't get saved:

      E382: Cannot write, 'buftype' option is set.

      Any pointer are much appreciated. 

      Many Thanks
      Peiman 

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • peiman khosravi
      ... ​Just to clarify. I am opening a html file directly from the server and editing it. In the past I was able to save the edits by just saving the file. But
      Message 2 of 4 , Apr 27 2:08 AM
        On 27 April 2014 01:55, peiman khosravi <peimankhosravi@...> wrote:
        Hello, since I've upgraded to the latest version (snapshot 73) on mavericks I'm getting this error when trying to save a html document, and the file doesn't get saved:

        E382: Cannot write, 'buftype' option is set.

        ​Just to clarify. I am opening a html file directly from the server and editing it. In the past I was able to save the edits by just saving the file. But now it seems that macvim is opening the file content inside a temporary buffer​ rather than opening the original file. Please see the screenshots attached. 

        Have I accidentally change my settings or is it the new version of macvim? 

        Many Thanks
        Peiman

        Inline images 1Inline images 2

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • peiman khosravi
        ... Now I can write the file. P -- -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are replying
        Message 3 of 4 , Apr 27 3:45 AM

          E382: Cannot write, 'buftype' option is set.

          ​FYI I figured it out. Just did 

          :set buftype: " "​

          Now I can write the file. 

          P

           

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • James Pope
          Did you ever find a better solution? I think it might be vim-jedi screwing it up - I had this problem a while back, uninstalled a bunch of stuff, and here I am
          Message 4 of 4 , Jul 9, 2015
            Did you ever find a better solution?

            I think it might be vim-jedi screwing it up -

            I had this problem a while back, uninstalled a bunch of stuff, and here I am having this problem after installing vim-python-jedi again...





            On Sunday, April 27, 2014 at 6:45:06 AM UTC-4, peiman khosravi wrote:
            > E382: Cannot write, 'buftype' option is set.
            >
            >
            > ​FYI I figured it out. Just did 
            >
            >
            >
            > :set buftype: " "​
            >
            >
            >
            > Now I can write the file. 
            >
            >
            >
            > P
            >
            >
            >  


            --

            ------------------------------
            This message (including any attachments) contains information that is
            confidential to IDology, Inc. and that is for the sole use of the intended
            recipients. If you are not an intended recipient, you may not read, print,
            retain, use, copy, distribute, forward or disclose to anyone this message
            or any information contained in this message (including any attachments).
            If you have received this message in error, please advise the sender of
            this error by reply e-mail, and please destroy all copies of this message
            (including any attachments).

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.