Loading ...
Sorry, an error occurred while loading the content.

Ctrl-o not working with non-QWERTY keyboard layout

Expand Messages
  • Ivan Brennan
    I m playing around with an alternative keyboard layout (Workman) and noticed that if I try Ctrl-o to jump back in the jump list, MacVim doesn t register the
    Message 1 of 2 , Feb 5, 2014
    • 0 Attachment
      I'm playing around with an alternative keyboard layout (Workman) and noticed that if I try Ctrl-o to jump back in the jump list, MacVim doesn't register the Ctrl modifier and just does a plain 'o' (opening a new line below the current line).

      Some digging through the help files led me to the 'imd', 'imc', and 'imi' options, as well as :lmap but I'm not sure how to make sense of it all. I'd like to use the Workman keyboard layout in all modes, rather than it switching back and forth.

      Also, this problem doesn't seem to crop up in terminal Vim, just MacVim.

      Any advice?

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ivan Brennan
      Actually, it seems *none* of the Control key commands are working, like the Control key isn t being recognized. -- -- You received this message from the
      Message 2 of 2 , Feb 6, 2014
      • 0 Attachment
        Actually, it seems *none* of the Control key commands are working, like the Control key isn't being recognized.

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.