Loading ...
Sorry, an error occurred while loading the content.

Utf-8 in terminal.app

Expand Messages
  • LuKreme
    I use vim in terminal.app all the time, but I cannot seem to get the right combination of settings to be able to enter UTF-8 text. If I am trying to enter ô I
    Message 1 of 4 , Nov 13, 2013
    • 0 Attachment
      I use vim in terminal.app all the time, but I cannot seem to get the right combination of settings to be able to enter UTF-8 text. If I am trying to enter “ I will get a å<93> or something. Similar to that instead.

      Terminal.app can display UTF-8 just fine, so I don't think it is terminal.app language setting that is the issue.

      (This is not using vim via the GUI)

      --
      Sign sign sign, everywhere a sign

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... http://vim.wikia.com/wiki/Working_with_Unicode might help you. Best regards, Tony. -- We don t do a new version to fix bugs. - Bill Gates The new
      Message 2 of 4 , Nov 13, 2013
      • 0 Attachment
        On Wednesday, November 13, 2013 9:15:33 AM UTC+1, LuKreme wrote:
        > I use vim in terminal.app all the time, but I cannot seem to get the right combination of settings to be able to enter UTF-8 text. If I am trying to enter “ I will get a å<93> or something. Similar to that instead.
        >
        >
        >
        > Terminal.app can display UTF-8 just fine, so I don't think it is terminal.app language setting that is the issue.
        >
        >
        >
        > (This is not using vim via the GUI)
        >
        >
        >
        > --
        >
        > Sign sign sign, everywhere a sign

        http://vim.wikia.com/wiki/Working_with_Unicode might help you.

        Best regards,
        Tony.
        --
        "We don't do a new version to fix bugs." - Bill Gates
        "The new version - it's not there to fix bugs." - Bill Gates
        -- Retranslated from Focus 43/1995, pp. 206-212

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Kazunobu Kuriyama
        ... In addition to the suggestion above, you might need to open the tab, Terminal- Preferences...- Settings- Profiles (Choose the setting in use)- Advanced,
        Message 3 of 4 , Nov 13, 2013
        • 0 Attachment
          On Nov 14, 2013, at 2:25 AM, Tony Mechelynck <antoine.mechelynck@...> wrote:

          > On Wednesday, November 13, 2013 9:15:33 AM UTC+1, LuKreme wrote:
          >> I use vim in terminal.app all the time, but I cannot seem to get the right combination of settings to be able to enter UTF-8 text. If I am trying to enter “ I will get a å<93> or something. Similar to that instead.
          >>
          >>
          >>
          >> Terminal.app can display UTF-8 just fine, so I don't think it is terminal.app language setting that is the issue.
          >>
          >>
          >>
          >> (This is not using vim via the GUI)
          >>
          >>
          >>
          >> --
          >>
          >> Sign sign sign, everywhere a sign
          >
          > http://vim.wikia.com/wiki/Working_with_Unicode might help you.
          >
          > Best regards,
          > Tony.
          > --
          > "We don't do a new version to fix bugs." - Bill Gates
          > "The new version - it's not there to fix bugs." - Bill Gates
          > -- Retranslated from Focus 43/1995, pp. 206-212

          In addition to the suggestion above, you might need to open the tab, Terminal->Preferences...->Settings->Profiles (Choose the setting in use)->Advanced, and see if there’s a check mark at “Escape non-ASCII input with Control-V” or not.

          If there’s a check mark there, it is likely to interfere with unicode input. So, removing that check mark might be helpful to get it right.

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • LuKreme
          ... Thank you, that was the problem (I already had set encoding=utf-8 and set fileencoding=utf-8 set in vimdc). Double-width characters show up oddly, but at
          Message 4 of 4 , Nov 13, 2013
          • 0 Attachment
            On 13 Nov 2013, at 15:24 , Kazunobu Kuriyama <kazunobu.kuriyama@...> wrote:

            > In addition to the suggestion above, you might need to open the tab, Terminal->Preferences...->Settings->Profiles (Choose the setting in use)->Advanced, and see if there’s a check mark at “Escape non-ASCII input with Control-V” or not.
            >
            > If there’s a check mark there, it is likely to interfere with unicode input. So, removing that check mark might be helpful to get it right.

            Thank you, that was the problem (I already had set encoding=utf-8 and set fileencoding=utf-8 set in vimdc).

            Double-width characters show up oddly, but at least they show up.

            --
            Rid yourself of doubt -- or should you? -George Carlin

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.