Loading ...
Sorry, an error occurred while loading the content.

Re: slime/lisp and vim

Expand Messages
  • Niklas Lindström
    Hello, It seems :python is not available in your version of Vim. Do you know which version you have installed? AFAIK, both the default /usr/bin/vim that comes
    Message 1 of 11 , Sep 30, 2013
    View Source
    • 0 Attachment
      Hello,

      It seems :python is not available in your version of Vim. Do you know which version you have installed?

      AFAIK, both the default /usr/bin/vim that comes with OS X and MacVim.app have Python compiled in by default.

      Cheers,
      Niklas



      On Thu, Sep 19, 2013 at 1:46 AM, jml <mirths.wirth@...> wrote:
      Hi there,

      I am trying to learn LISP from within VIM and saw that it might be possible.
      I downloaded slime for vim:

      Then I manually installed everything, but it doesn't seem to work.
      In the instruction set, it says that I need to have python enabled within vim, but when I type

      :python import sys; print(sys.version)

      from within VIM, it tells me
      "E319: Sorry, the command is not available in this version"

      Is there anything I can do to test further?
      I may have missed something more obvious in terms of slime's install...

      Any help would be appreciated.

      jml

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.