Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim Snapshot 71

Expand Messages
  • Mario Günterberg
    ... Hi, same problem here with the ML build. I had than compiled MacVim from sources and it works fine. (OS X 10.8.4) But, I ve installed Python 3.3.2 (OS X
    Message 1 of 14 , Sep 12, 2013
    • 0 Attachment
      Am 09.09.2013 um 13:57 schrieb Frank Hellenkamp <jonas@...>:
      > With the mountain lion build, I get the following error message when
      > trying to start macvim and no Windows are opening:
      > "ImportError: No module named site"
      >
      > With the old build, everything works fine.
      >
      > I am using pathogen btw. When I remove my .vim folder, vim seems to start.
      >
      > Did something change with python?

      Hi,

      same problem here with the ML build.

      I had than compiled MacVim from sources and it works fine. (OS X 10.8.4) But, I've installed Python 3.3.2 (OS X installer from python.org) a few weeks ago and I had to remove/comment out the changes in my .profile (path etc.). Maybe that's the problem.

      have fun
      Mario


      -----BEGIN GEEK CODE BLOCK-----
      Version: 3.1
      GCM/IT d(-) s+(++):+(++) a+ C+++(++++) UBLC+++(++++) P++ L+++(++++)
      E--- W+++ N++ o+ K- !w !O !M !V PS++ PE++ Y+ PGP+++ t 5 X++++ R+++
      tv b++++ DI++ D+++ G++ e h---- r+++ y+++
      ------END GEEK CODE BLOCK------
    • Kai Groner
      ... /System/Library/Frameworks/Python.framework/Versions/2.7/Python (compatibility version 2.7.0, current version 2.7.2) ...
      Message 2 of 14 , Sep 24, 2013
      • 0 Attachment
        I'm having this problem too. Comparing snapshot 70 with snapshot 71, I see the following:

        :; otool -L MacVim-snapshot-70/MacVim.app/Contents/MacOS/Vim | grep -i python
        /System/Library/Frameworks/Python.framework/Versions/2.7/Python (compatibility version 2.7.0, current version 2.7.2)
        :; otool -L MacVim-snapshot-71/MacVim.app/Contents/MacOS/Vim | grep -i python
        /System/Library/Frameworks/Python.framework/Versions/2.7/Python (compatibility version 2.7.0, current version 2.7.2)

        :; MacVim-snapshot-70/MacVim.app/Contents/MacOS/Vim --version | grep Linking:
        Linking: clang -L. -L. -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon -lncurses -liconv -framework Cocoa -fstack-protector -L/usr/local/lib -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python -framework Ruby
        :; MacVim-snapshot-71/MacVim.app/Contents/MacOS/Vim --version | grep Linking:
        Linking: clang -L. -fstack-protector -L. -fstack-protector -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon -lncurses -liconv -framework Cocoa -fstack-protector -L/usr/local/lib -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python -lruby-static -lobjc -L/Users/Douglas/lib

        :; strings MacVim-snapshot-70/MacVim.app/Contents/MacOS/Vim | grep /Python
        /System/Library/Frameworks/Python.framework/Versions/2.7
        :; strings MacVim-snapshot-71/MacVim.app/Contents/MacOS/Vim | grep /Python
        /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7

        :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-70/mvim --cmd 'python pass' --cmd q 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so
        :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-71/mvim --cmd 'python pass' --cmd q 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        ImportError: No module named site

        So, it looks like the system provided python framework is being selected, but the output from "strings" hints that something else is happening.

        Indeed, updating my homebrew python to 2.7.5 does get things moving, but it fails to load the io stdlib:

        :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-71/mvim --cmd 'python pass' 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/unicodedata.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_functools.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_collections.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/operator.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/itertools.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_heapq.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_hashlib.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/strop.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/time.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/select.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/fcntl.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_struct.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/binascii.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/cStringIO.so
        dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so
        dyld: unloaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so
        Error detected while processing /Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips.vim:
        line 257:
        Traceback (most recent call last):
        File "<string>", line 1, in <module>
        File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/__init__.py", line 15, in <module>
        from UltiSnips.text_objects import SnippetInstance
        File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/__init__.py", line 4, in <module>
        from ._snippet_instance import SnippetInstance
        File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/_snippet_instance.py", line 8, in <module>
        from UltiSnips.text_objects._parser import TOParser
        File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/_parser.py", line 11, in <module>
        from UltiSnips.text_objects._shell_code import ShellCode
        File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/_shell_code.py", line 8, in <module>
        import tempfile
        File "/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/tempfile.py", line 32, in <module>
        import io as _io
        File "/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/io.py", line 51, in <module>
        import _io
        ImportError: dlopen(/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so, 2): Symbol not found: __PyInt_AsInt
        Referenced from: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so
        Expected in: flat namespace
        in /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so


        By comparison, snapshot 70 gets further using the system python.

        :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-70/mvim --cmd 'python pass' 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/unicodedata.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_functools.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_collections.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/operator.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/itertools.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_bisect.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_heapq.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_hashlib.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/strop.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/time.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/select.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/fcntl.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_struct.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/binascii.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/cStringIO.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/math.so
        dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_random.so


        Sorry for the spam, let me know if there's a issue tracker you would prefer this be posted in.


        Kai


        On Monday, September 9, 2013 8:05:00 AM UTC-4, Douglas Drumond wrote:
        > I don't think so, I'll check at home.
        >
        > Androidから送信
        >
        > 2013/09/09 8:57 "Frank Hellenkamp" <jo...@...>:
        >
        > Hi,
        >
        >
        >
        > > 2013/9/6 Douglas Drumond <drumond...@...
        >
        > > <mailto:drumond...@...>>
        >
        > >
        >
        > >     ML release is up on https://github.com/eee19/macvim/releases
        >
        > >
        >
        > >     I'll upload a Lion release when I get back home.
        >
        > >
        >
        > >
        >
        > > And Lion release is up as well, at the same
        >
        > > address: https://github.com/eee19/macvim/releases/tag/snapshot-71
        >
        >
        >
        > With the mountain lion build, I get the following error message when
        >
        > trying to start macvim and no Windows are opening:
        >
        > "ImportError: No module named site"
        >
        >
        >
        > With the old build, everything works fine.
        >
        >
        >
        > I am using pathogen btw. When I remove my .vim folder, vim seems to start.
        >
        >
        >
        > Did something change with python?
        >
        >
        >
        >
        >
        > Best
        >
        >
        >
        > Frank
        >
        >
        >
        > --
        >
        > frank hellenkamp | interface designer
        >
        > solmsstraße 7 | 10961 berlin
        >
        >
        >
        > +49.30.49 78 20 70 | tel
        >
        > +49.176.32 13 88 89 | mbl
        >
        > +49.3212.100 35 22 | fax
        >
        > jo...@...
        >
        >
        >
        > http://depage.net | bureau
        >
        > http://depagecms.net | content management
        >
        > http://immerdasgleiche.de | read
        >
        > http://everydayisexactlythesame.net | see
        >
        > https://ideenkonserve.de | ideas
        >
        > https://twitter.com/depage_net | twitter

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Kai Groner
        This message is actually a follow up to my previous message which is waiting for moderator approval. I did a build according to the instructions in
        Message 3 of 14 , Sep 24, 2013
        • 0 Attachment
          This message is actually a follow up to my previous message which is waiting for moderator approval.

          I did a build according to the instructions in README_mac.txt which resulted in a similar binary (dyld header references /System/Library/Frameworks/Python.framework, but PYTHON_HOME is effectively /usr/local/Cellar/python/2.7.5). I was able to avoid this by removing /usr/local/bin from my PATH before running configure.


          Kai

          On Monday, September 9, 2013 8:05:00 AM UTC-4, Douglas Drumond wrote:
          > I don't think so, I'll check at home.
          >
          > Androidから送信
          >
          > 2013/09/09 8:57 "Frank Hellenkamp" <jo...@...>:
          >
          > Hi,
          >
          >
          >
          > > 2013/9/6 Douglas Drumond <drumond...@...
          >
          > > <mailto:drumond...@...>>
          >
          > >
          >
          > >     ML release is up on https://github.com/eee19/macvim/releases
          >
          > >
          >
          > >     I'll upload a Lion release when I get back home.
          >
          > >
          >
          > >
          >
          > > And Lion release is up as well, at the same
          >
          > > address: https://github.com/eee19/macvim/releases/tag/snapshot-71
          >
          >
          >
          > With the mountain lion build, I get the following error message when
          >
          > trying to start macvim and no Windows are opening:
          >
          > "ImportError: No module named site"
          >
          >
          >
          > With the old build, everything works fine.
          >
          >
          >
          > I am using pathogen btw. When I remove my .vim folder, vim seems to start.
          >
          >
          >
          > Did something change with python?
          >
          >
          >
          >
          >
          > Best
          >
          >
          >
          > Frank
          >
          >
          >
          > --
          >
          > frank hellenkamp | interface designer
          >
          > solmsstraße 7 | 10961 berlin
          >
          >
          >
          > +49.30.49 78 20 70 | tel
          >
          > +49.176.32 13 88 89 | mbl
          >
          > +49.3212.100 35 22 | fax
          >
          > jo...@...
          >
          >
          >
          > http://depage.net | bureau
          >
          > http://depagecms.net | content management
          >
          > http://immerdasgleiche.de | read
          >
          > http://everydayisexactlythesame.net | see
          >
          > https://ideenkonserve.de | ideas
          >
          > https://twitter.com/depage_net | twitter

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Douglas Drumond
          I ll test this again and upload a new binary, if necessary. -- Douglas Drumond *GDG Campinas ​ – **eee19.com*
          Message 4 of 14 , Sep 25, 2013
          • 0 Attachment
            I'll test this again and upload a new binary, if necessary.



            2013/9/24 Kai Groner <kai@...>
            I'm having this problem too.  Comparing snapshot 70 with snapshot 71, I see the following:

            :; otool -L MacVim-snapshot-70/MacVim.app/Contents/MacOS/Vim | grep -i python
                    /System/Library/Frameworks/Python.framework/Versions/2.7/Python (compatibility version 2.7.0, current version 2.7.2)
            :; otool -L MacVim-snapshot-71/MacVim.app/Contents/MacOS/Vim | grep -i python
                    /System/Library/Frameworks/Python.framework/Versions/2.7/Python (compatibility version 2.7.0, current version 2.7.2)

            :; MacVim-snapshot-70/MacVim.app/Contents/MacOS/Vim --version | grep Linking:
            Linking: clang   -L.    -L.     -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon       -lncurses  -liconv -framework Cocoa   -fstack-protector -L/usr/local/lib  -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python   -framework Ruby
            :; MacVim-snapshot-71/MacVim.app/Contents/MacOS/Vim --version | grep Linking:
            Linking: clang   -L. -fstack-protector -L. -fstack-protector  -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon       -lncurses  -liconv -framework Cocoa   -fstack-protector -L/usr/local/lib  -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python   -lruby-static -lobjc -L/Users/Douglas/lib

            :; strings MacVim-snapshot-70/MacVim.app/Contents/MacOS/Vim | grep /Python
            /System/Library/Frameworks/Python.framework/Versions/2.7
            :; strings MacVim-snapshot-71/MacVim.app/Contents/MacOS/Vim | grep /Python
            /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7

            :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-70/mvim --cmd 'python pass' --cmd q 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so
            :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-71/mvim --cmd 'python pass' --cmd q 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            ImportError: No module named site

            So, it looks like the system provided python framework is being selected, but the output from "strings" hints that something else is happening.

            Indeed, updating my homebrew python to 2.7.5 does get things moving, but it fails to load the io stdlib:

            :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-71/mvim --cmd 'python pass' 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/unicodedata.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_functools.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_collections.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/operator.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/itertools.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_heapq.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_hashlib.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/strop.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/time.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/select.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/fcntl.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_struct.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/binascii.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/cStringIO.so
            dyld: loaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so
            dyld: unloaded: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so
            Error detected while processing /Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips.vim:
            line  257:
            Traceback (most recent call last):
              File "<string>", line 1, in <module>
              File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/__init__.py", line 15, in <module>
                from UltiSnips.text_objects import SnippetInstance
              File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/__init__.py", line 4, in <module>
                from ._snippet_instance import SnippetInstance
              File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/_snippet_instance.py", line 8, in <module>
                from UltiSnips.text_objects._parser import TOParser
              File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/_parser.py", line 11, in <module>
                from UltiSnips.text_objects._shell_code import ShellCode
              File "/Users/kai/.vim/bundle/ultisnips/plugin/UltiSnips/text_objects/_shell_code.py", line 8, in <module>
                import tempfile
              File "/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/tempfile.py", line 32, in <module>
                import io as _io
              File "/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/io.py", line 51, in <module>
                import _io
            ImportError: dlopen(/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so, 2): Symbol not found: __PyInt_AsInt
              Referenced from: /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so
              Expected in: flat namespace
             in /usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_io.so


            By comparison, snapshot 70 gets further using the system python.

            :; DYLD_PRINT_LIBRARIES=1 MacVim-snapshot-70/mvim --cmd 'python pass' 2>&1 | sed '/^dyld:/ { /[Pp]ython/ ! d; }'
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/unicodedata.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_functools.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_collections.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/operator.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/itertools.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_bisect.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_heapq.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_hashlib.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/strop.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/time.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/select.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/fcntl.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_struct.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/binascii.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/cStringIO.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/math.so
            dyld: loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_random.so


            Sorry for the spam, let me know if there's a issue tracker you would prefer this be posted in.


            Kai


            On Monday, September 9, 2013 8:05:00 AM UTC-4, Douglas Drumond wrote:
            > I don't think so, I'll check at home.
            >
            > Androidから送信
            >
            > 2013/09/09 8:57 "Frank Hellenkamp" <jo...@...>:
            >
            > Hi,
            >
            >
            >
            > > 2013/9/6 Douglas Drumond <drumond...@...
            >
            > > <mailto:drumond...@...>>
            >
            > >
            >
            > >     ML release is up on https://github.com/eee19/macvim/releases
            >
            > >
            >
            > >     I'll upload a Lion release when I get back home.
            >
            > >
            >
            > >
            >
            > > And Lion release is up as well, at the same
            >
            > > address: https://github.com/eee19/macvim/releases/tag/snapshot-71
            >
            >
            >
            > With the mountain lion build, I get the following error message when
            >
            > trying to start macvim and no Windows are opening:
            >
            > "ImportError: No module named site"
            >
            >
            >
            > With the old build, everything works fine.
            >
            >
            >
            > I am using pathogen btw. When I remove my .vim folder, vim seems to start.
            >
            >
            >
            > Did something change with python?
            >
            >
            >
            >
            >
            > Best
            >
            >
            >
            > Frank
            >
            >
            >
            > --
            >
            > frank hellenkamp | interface designer
            >
            > solmsstraße 7 | 10961 berlin
            >
            >
            >
            > +49.30.49 78 20 70 | tel
            >
            > +49.176.32 13 88 89 | mbl
            >
            > +49.3212.100 35 22 | fax
            >
            > jo...@...
            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • björn
            ... I m seeing more and more reports that seem related to this issue, i.e. that the Mountain Lion build of snapshot 71 has picked up Python from Homebrew
            Message 5 of 14 , Oct 12, 2013
            • 0 Attachment
              On Wed, Sep 25, 2013 at 9:13 AM, Douglas Drumond wrote:
              > I'll test this again and upload a new binary, if necessary.

              I'm seeing more and more reports that seem related to this issue, i.e.
              that the Mountain Lion build of snapshot 71 has picked up Python from
              Homebrew instead of using the system provided Python.

              Douglas: can you try Kai's advice and remove /usr/local/bin from your
              PATH when building and then upload a new build? (Kai's previous post
              had some useful tips on how to see if Homebrew is interfering or not.)

              I've never had to do this myself as I don't have a custom Python
              version installed, but thanks Kai for investigating and pointing this
              out!

              Björn

              --
              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_mac" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Douglas Drumond
              I m with a brand new installation of mountain lion, I ll upload a new build in a few minutes. Androidから送信 ... -- -- You received this message from the
              Message 6 of 14 , Oct 12, 2013
              • 0 Attachment

                I'm with a brand new installation of mountain lion, I'll upload a new build in a few minutes.

                Androidから送信

                On Oct 12, 2013 5:57 AM, "björn" <bjorn.winckler@...> wrote:
                On Wed, Sep 25, 2013 at 9:13 AM, Douglas Drumond wrote:
                > I'll test this again and upload a new binary, if necessary.

                I'm seeing more and more reports that seem related to this issue, i.e.
                that the Mountain Lion build of snapshot 71 has picked up Python from
                Homebrew instead of using the system provided Python.

                Douglas: can you try Kai's advice and remove /usr/local/bin from your
                PATH when building and then upload a new build?  (Kai's previous post
                had some useful tips on how to see if Homebrew is interfering or not.)

                I've never had to do this myself as I don't have a custom Python
                version installed, but thanks Kai for investigating and pointing this
                out!

                Björn

                --
                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_mac" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.

                --
                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_mac" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Douglas Drumond
                Those having problems with python and MacVim on Mountain Lion, I uploaded a new binary to the usual location (
                Message 7 of 14 , Oct 12, 2013
                • 0 Attachment
                  Those having problems with python and MacVim on Mountain Lion, I uploaded a new binary to the usual location (https://github.com/eee19/macvim/releases/tag/snapshot-71).

                  I made sure there was nothing unusual in my $PATH and recompiled it.

                  My sincere apologies for disrupting your workflow, I'll make sure this never happens again.

                  Best regards,

                  --
                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                   
                  ---
                  You received this message because you are subscribed to the Google Groups "vim_mac" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • björn
                  ... Thanks Douglas! I ve been bitten by something similar in the past when I was running MacPorts so I know how easily these things can happen... Björn -- --
                  Message 8 of 14 , Oct 13, 2013
                  • 0 Attachment
                    On Sun, Oct 13, 2013 at 6:41 AM, Douglas Drumond wrote:
                    > Those having problems with python and MacVim on Mountain Lion, I uploaded a
                    > new binary to the usual location
                    > (https://github.com/eee19/macvim/releases/tag/snapshot-71).
                    >
                    > I made sure there was nothing unusual in my $PATH and recompiled it.
                    >
                    > My sincere apologies for disrupting your workflow, I'll make sure this never
                    > happens again.

                    Thanks Douglas!

                    I've been bitten by something similar in the past when I was running
                    MacPorts so I know how easily these things can happen...

                    Björn

                    --
                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_mac" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  Your message has been successfully submitted and would be delivered to recipients shortly.