Loading ...
Sorry, an error occurred while loading the content.

MacVim Solarized difficulty to set real background

Expand Messages
  • Alexandre L.-Piché
    Hello guys, I ve got some trouble configuring Vim. Here s my code in MYVIMRC concerning background, I look on several topic and I don t understand what s wrong
    Message 1 of 3 , Sep 3, 2013
    • 0 Attachment
      Hello guys,

      I've got some trouble configuring Vim. Here's my code in MYVIMRC concerning background, I look on several topic and I don't understand what's wrong with it. What's also strange is that I can set the good background trough the Solarized tools bar icon. Anyone have an idea of what's going wrong?
      Cheers,

      Alex


      set t_Co=256
      let g:solarized_termcolors=256 "default value is 16
      let g:solarized_contrast="high" "default value is normal
      let g:solarized_visibility="high" "default value is normal
      let g:solarized_background="dark"
      set go-=T
      set bg=dark
      if &background == "dark"
      hi normal guibg=black
      set transp=8
      endif
      set guioptions=T
      set background=dark
      colorscheme solarized

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Douglas Drumond
      2013/9/4 Alexandre L.-Piché ... I don t know why this happens, but I have successfully made transparency work setting it from
      Message 2 of 3 , Sep 3, 2013
      • 0 Attachment

        2013/9/4 Alexandre L.-Piché <alexandrelpiche@...>
        Anyone have an idea of what's going wrong?

        I don't know why this happens, but I have successfully made transparency work setting it from .gvimrc instead of .vimrc. See if that helps
        .


        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Alexandre L.-Piché
        ... I copy pasted my whole code in MYGVIMRC and now it s working... Thank you -- -- You received this message from the vim_mac maillist. Do not top-post!
        Message 3 of 3 , Sep 5, 2013
        • 0 Attachment
          On Wednesday, September 4, 2013 12:46:22 AM UTC-4, Douglas Drumond wrote:
          > 2013/9/4 Alexandre L.-Piché <alexand...@...>
          >
          >
          >
          > Anyone have an idea of what's going wrong?
          >
          > I don't know why this happens, but I have successfully made transparency work setting it from .gvimrc instead of .vimrc. See if that helps
          >
          >
          > .
          >
          >
          >
          >
          >
          >
          > --
          > Douglas Drumond
          >
          >
          > eee19.com
          > gplus.to/douglasdrumond
          >
          >
          > @douglasdrumond

          I copy pasted my whole code in MYGVIMRC and now it's working... Thank you

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.