Loading ...
Sorry, an error occurred while loading the content.

Re: Weird crashes (7.4-70)

Expand Messages
  • Goran Topic
    Update: You can forget about the test file; the crash happens if there is a line indented to 16 spaces, all the rest is irrelevant. So you could open a new
    Message 1 of 3 , Aug 22, 2013
    • 0 Attachment
      Update:

      You can forget about the test file; the crash happens if there is a line indented to 16 spaces, all the rest is irrelevant. So you could open a new Ruby file, and just insert 16 spaces to reproduce.

      Goran

      On Thursday, August 22, 2013 3:59:44 PM UTC+9, Goran Topic wrote:
      > Hello.
      >
      > I've run `brew update` yesterday, and got MacVim 7.4-70 installed with it. I've also switched from Vundle to NeoBundle, and installed a couple of new plugins (Shougo/vimproc, Shougo/unite.vim, tpope/vim-dispatch, tpope/vim-commentary), but I don't think it is relevant. I am not 100% sure though, so I thought to mention it.
      >
      > Today I experienced a weird crash situation. MacVim started crashing on one of my Ruby files. I tried to find a minimal example, which I'm attaching, and also pasting here:
      >
      > ------------------
      > x =
      > y(
      > z
      > )
      > ------------------
      >
      > $ mvim test.rb
      > Vim: Caught deadly signal SEGV
      > Vim: Finished.
      > (in further text: crash)
      >
      > $ rm ~/.vimrc # my only vim rc file
      > $ mvim test.rb
      > (crash)
      >
      > $ mvim -u NORC test.rb
      > (no crash)
      >
      > $ vim test.rb # macvim/7.4-70/bin/vim, not system vim
      > (no crash)
      >
      > $ cp test.rb test.txt
      > $ mvim test.txt
      > (no crash)
      >
      > If I remove the indentation from the line 3 (`z`) from 16 spaces to 15 (using another editor or console vim), and then
      >
      > $ mvim test.rb
      > (no crash)
      > :3<CR>i<space>
      > (crash)
      >
      > So...
      > - it happens only when `-g` is in effect
      > - it happens when 'ft=ruby'
      > - it happens on very specific syntax
      > - it happens with no .vimrc, but not when skipping rc files
      >
      > Can anyone else confirm this behaviour, or is it just me?
      >
      > Goran

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Sounds like the problem that is fixed by patch 7.4.003 -- Two percent of zero is almost nothing. /// Bram Moolenaar -- Bram@Moolenaar.net --
      Message 2 of 3 , Aug 23, 2013
      • 0 Attachment
        Goran Topic wrote:

        > Update:
        >
        > You can forget about the test file; the crash happens if there is a
        > line indented to 16 spaces, all the rest is irrelevant. So you could
        > open a new Ruby file, and just insert 16 spaces to reproduce.

        Sounds like the problem that is fixed by patch 7.4.003


        --
        Two percent of zero is almost nothing.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.