Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim forces last pattern search using vim flags

Expand Messages
  • anilg
    ... Thanks Björn, that s great - feels like a lot of leads there - I ll go that route. -- -- You received this message from the vim_mac maillist. Do not
    Message 1 of 7 , Aug 20, 2013
    • 0 Attachment
      > On Tue, Aug 20, 2013 at 8:27 AM, anilg wrote:
      > > $ ps -ax | grep vim
      > > /Applications/MacVim.app/Contents/MacOS/MacVim -psn_0_426088
      > > /Applications/MacVim.app/Contents/MacOS/Vim -g -f +/ -p /path/to/file/example.txt
      >
      > I tried to find stable MacVim 7.3 but the website has PHP errors.
      > I got snapshot 70 of 7.4 for OS X 10.8 from Github (I have 10.8.3) but it doesn't respect my ~/.vimrc?
      > I still have MacVim-7_3-66.tbz but I seem to remember there were problems so I didn't use it.
      > I still have MacVim-7_3-53.tbz which is what I've got currently.
      > I might try to re-install that again.

      On Tuesday, 20 August 2013 17:46:18 UTC+10, björn wrote:
      > You should be running snapshot 70 -- if you have problems with .vimrc then start a new thread and ask for help, but it should work.  Snap 70 fixes the problem of 53 where using "+" to open Spotlight searches caused a warning message (but the search term will still be highlighted if there is a match).
      > By the way, everything indicates that you are running some sort of program (something like a SIMBL plugin perhaps?) that causes Spotlight searches to be included in the "open" event that is sent when you open files from Finder.  Normally, this only happens when you open a file by typing in the Spotlight search bar and opening a file (in which case MacVim highlights the search term) -- this should not happen when you double click a file in Finder (and indeed, it does not happen on my machine, for example).  Hope that helps you track down the cause.

      Thanks Björn, that's great - feels like a lot of leads there - I'll go that route.

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.