Loading ...
Sorry, an error occurred while loading the content.
 

Re: Set display font to large

Expand Messages
  • Chris Patti
    Hi Marek, it s not noise! :) I had the same problem myself, and, menus aside, you can also configure ... $ more .gvimrc [16:34:19] set ts=4 set sw=4 set sts=4
    Message 1 of 7 , Jul 30, 2013
      Hi Marek, it's not noise! :)

      I had the same problem myself, and, menus aside, you can also configure things with your dotfiles.  Here's mine for example:
      ----
      $ more .gvimrc                                                       [16:34:19]
      set ts=4
      set sw=4
      set sts=4
      set expandtab
      set guifont=Menlo\ Regular:h25
      colorscheme koehler




      On Tue, Jul 30, 2013 at 10:07 AM, Marek Stepanek <mark_step@...> wrote:


      Sorry for this noise. I discovered the answer myself. Menu > Edit > Font
      > Bigger


      Please disregard this question.


      Marek

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.





      --
      Christopher Patti - Geek At Large | GTalk: cpatti@... | AIM: chrisfeohpatti | P: (260) 54PATTI
      "Technology challenges art, art inspires technology." - John Lasseter, Pixar

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Marek Stepanek
      ... Wow this is impressing! Your colorscheme koehler is really interesting, but I commented it out :-) too exhausting for my eyes! And the ts and sw ... I
      Message 2 of 7 , Jul 30, 2013
        On 7/30/13 10:48 PM, Chris Patti wrote:
        > Hi Marek, it's not noise! :)
        >
        > I had the same problem myself, and, menus aside, you can also configure
        > things with your dotfiles. Here's mine for example:
        > ----
        > $ more .gvimrc
        > [16:34:19]
        > set ts=4
        > set sw=4
        > set sts=4
        > set expandtab
        > set guifont=Menlo\ Regular:h25
        > colorscheme koehler
        >
        >
        >
        >


        Wow this is impressing! Your colorscheme koehler is really interesting,
        but I commented it out :-) too exhausting for my eyes! And the "ts" and
        "sw" ... I suppose to understand, I have to make :help ts ... I will
        look into it tomorrow.

        Thank you for this nice welcome Chris


        marek

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Kyle Lippincott
        To elaborate a bit on setting the font in a way that your machine will accept (different machines take different font specifications), I ve found ... the font
        Message 3 of 7 , Jul 30, 2013
          To elaborate a bit on setting the font in a way that your machine will accept (different machines take different font specifications), I've found the easiest method to be:

          :set guifont=*  (this opens up a font dialog box on most systems; choose the font you want, and then close it)
          :set guifont?  (with the question mark!  This tells you what guifont actually got set to)

          Then put it in your ~/.gvimrc:
          set guifont=<whatever output from ':set guifont?' was>   (without the <>'s :))


          On Tue, Jul 30, 2013 at 2:33 PM, Marek Stepanek <mark_step@...> wrote:
          On 7/30/13 10:48 PM, Chris Patti wrote:
          > Hi Marek, it's not noise! :)
          >
          > I had the same problem myself, and, menus aside, you can also configure
          > things with your dotfiles.  Here's mine for example:
          > ----
          > $ more .gvimrc
          > [16:34:19]
          > set ts=4
          > set sw=4
          > set sts=4
          > set expandtab
          > set guifont=Menlo\ Regular:h25
          > colorscheme koehler
          >
          >
          >
          >


          Wow this is impressing! Your colorscheme koehler is really interesting,
          but I commented it out :-) too exhausting for my eyes! And the "ts" and
          "sw" ... I suppose to understand, I have to make :help ts ... I will
          look into it tomorrow.

          Thank you for this nice welcome Chris


          marek

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.



          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Marek Stepanek
          ... Thx Kyle! ... I tried this command, but got the answer: guifont= nothing else and I was confused of course. Now I understand: if you have not put a
          Message 4 of 7 , Jul 31, 2013
            On 7/31/13 12:07 AM, Kyle Lippincott wrote:
            > To elaborate a bit on setting the font in a way that your machine will
            > accept (different machines take different font specifications), I've
            > found the easiest method to be:
            >
            > :set guifont=* (this opens up a font dialog box on most systems; choose
            > the font you want, and then close it)
            > :set guifont? (with the question mark! This tells you what guifont
            > actually got set to)
            >
            > Then put it in your ~/.gvimrc:
            > set guifont=<whatever output from ':set guifont?' was> (without the
            > <>'s :))
            >

            Thx Kyle!


            > :set guifont?

            I tried this command, but got the answer: "guifont=" nothing else and I
            was confused of course. Now I understand: if you have not put a
            different setting, you will only get an empty answer. But how to get the
            default settings of MacVim? I would like to keep the default font and
            only change the size. And what is the ":set guifont" for the size only?



            Thanks for your patience

            marek

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Chris Patti
            Apologies Marek the ts,sw,sts and expandtab settings all tell Vim how to handle tabs. See the superlative Vimcast on working with tabs for more information.
            Message 5 of 7 , Jul 31, 2013
              Apologies Marek the ts,sw,sts and expandtab settings all tell Vim how to handle tabs.

              See the superlative Vimcast on "working with tabs" for more information.

              This site in general is a treasure trove of help for new Vimmers :)


              -Chris



              On Tue, Jul 30, 2013 at 5:33 PM, Marek Stepanek <mark_step@...> wrote:
              On 7/30/13 10:48 PM, Chris Patti wrote:
              > Hi Marek, it's not noise! :)
              >
              > I had the same problem myself, and, menus aside, you can also configure
              > things with your dotfiles.  Here's mine for example:
              > ----
              > $ more .gvimrc
              > [16:34:19]
              > set ts=4
              > set sw=4
              > set sts=4
              > set expandtab
              > set guifont=Menlo\ Regular:h25
              > colorscheme koehler
              >
              >
              >
              >


              Wow this is impressing! Your colorscheme koehler is really interesting,
              but I commented it out :-) too exhausting for my eyes! And the "ts" and
              "sw" ... I suppose to understand, I have to make :help ts ... I will
              look into it tomorrow.

              Thank you for this nice welcome Chris


              marek

              --
              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_mac" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.





              --
              Christopher Patti - Geek At Large | GTalk: cpatti@... | AIM: chrisfeohpatti | P: (260) 54PATTI
              "Technology challenges art, art inspires technology." - John Lasseter, Pixar

              --
              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_mac" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               
            Your message has been successfully submitted and would be delivered to recipients shortly.