Loading ...
Sorry, an error occurred while loading the content.

Re: Vim 7.4a ready for beta testing

Expand Messages
  • björn
    ... I have tried very hard to avoid these types of display bugs, but unfortunately it is unavoidable without some form of double buffering which I have not
    Message 1 of 11 , Jul 8, 2013
    • 0 Attachment
      On Sun, Jul 7, 2013 at 10:39 PM, Douglas Drumond wrote:

      On Sun, Jul 7, 2013 at 1:13 PM, peiman khosravi wrote:
      >
      > Also, I tried to resize the window by dragging the right edge and this happened (attached).
      >

      I was not able to reproduce fullscreen issue here, but I could see the glitch from screenshot, although minor (parts of the window got blurry during resizing, but got back to normal when resizing stopped). Disabling core renderer in Preferences → Advanced and reopening the window made the problem go away. I have no clue on how to solve it (Björn, can you give me some pointers? [1]), I'll see what I can do.

      I have tried very hard to avoid these types of display bugs, but unfortunately it is unavoidable without some form of double buffering which I have not (yet) implemented for the Core Text renderer due to speed (and memory) concerns.  My current advice is - anybody who can't live with it should disable the Core Text renderer (but the speed of the default renderer may put you off).

      As for not being able to enter full screen: I do not have access to a Lion machine to try on.  But to rule out problems with Douglas' build, please try running the binary I built for 10.6.  On second thought - it does not support Lion-native full screen, so that may be somewhat pointless.  Maybe try disabling native full-screen in the prefs and see if that works.

      Björn 

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Douglas Drumond
      ... Core Text renderer (but the speed of the default renderer may put you off). Even on Snow Leopard build there are some glitches here, but nothing that makes
      Message 2 of 11 , Jul 8, 2013
      • 0 Attachment

        On Mon, Jul 8, 2013 at 4:42 PM, björn <bjorn.winckler@...> wrote:
        >
        > My current advice is - anybody who can't live with it should disable the Core Text renderer (but the speed of the default renderer may put you off).

         
        Even on Snow Leopard build there are some glitches here, but nothing that makes MacVim unusable (it's just on resizing). But with Core Renderer enabled it's unusable for Japanese text (Japanese characters are larger, so they pile up, but with CR disabled it does proper spacing). Since I use it for Japanese just once in a while, I left it with CR enabled for day to day programming.

        > As for not being able to enter full screen: I do not have access to a Lion machine to try on.  But to rule out problems with Douglas' build, please try running the binary I built for 10.6.  On second thought - it does not support Lion-native full screen, so that may be somewhat pointless.  Maybe try disabling native full-screen in the prefs and see if that works.


        I didn't have the fullscreen issue, so I couldn't test that.


        --
        Douglas Drumond

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • björn
        On Mon, Jul 8, 2013 at 10:26 PM, Douglas Drumond ... This is news to me. How can I reproduce this? Björn -- -- You received this message from the vim_mac
        Message 3 of 11 , Jul 9, 2013
        • 0 Attachment
          On Mon, Jul 8, 2013 at 10:26 PM, Douglas Drumond <drumond.douglas@...> wrote:

          On Mon, Jul 8, 2013 at 4:42 PM, björn <bjorn.winckler@...> wrote:
          >
          > My current advice is - anybody who can't live with it should disable the Core Text renderer (but the speed of the default renderer may put you off).

           
          Even on Snow Leopard build there are some glitches here, but nothing that makes MacVim unusable (it's just on resizing). But with Core Renderer enabled it's unusable for Japanese text (Japanese characters are larger, so they pile up, but with CR disabled it does proper spacing). Since I use it for Japanese just once in a while, I left it with CR enabled for day to day programming.

          This is news to me.  How can I reproduce this?

          Björn

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Douglas Drumond
          ... that makes MacVim unusable (it s just on resizing). But with Core Renderer enabled it s unusable for Japanese text (Japanese characters are larger, so they
          Message 4 of 11 , Jul 9, 2013
          • 0 Attachment

            On Tue, Jul 9, 2013 at 2:28 PM, björn <bjorn.winckler@...> wrote:
            >>
            >> Even on Snow Leopard build there are some glitches here, but nothing that makes MacVim unusable (it's just on resizing). But with Core Renderer enabled it's unusable for Japanese text (Japanese characters are larger, so they pile up, but with CR disabled it does proper spacing). Since I use it for Japanese just once in a while, I left it with CR enabled for day to day programming.
            >
            >
            > This is news to me.  How can I reproduce this?


            Just paste (or type) any Japanese text, such as おはようございます, and it should become like the screenshot attached (wrong.png). The last character is fine, it's where the cursor is. If I navigate over the characters, each one becomes its natural size (double size) until it finally reaches the way it's in the other screenshot (right.png). Without Core Renderer, it's already like right.png.

            To be sure it's not some plugin, I started with mvim -u NONE.

            I downloaded snapshot 66 to test, it's fine for Japanese text, even with Core Renderer enabled.

            --
            Douglas Drumond

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          Your message has been successfully submitted and would be delivered to recipients shortly.