Loading ...
Sorry, an error occurred while loading the content.

compiling huge + lua but no lua...

Expand Messages
  • Chris Lott
    I m trying to compile MacVim with Lua support on OS X 10.8.4 -- I have grabbed the latest code from: https://github.com/b4winckler/macvim Lua and Cscope are
    Message 1 of 3 , Jun 24, 2013
    • 0 Attachment
      I'm trying to compile MacVim with Lua support on OS X 10.8.4 -- I have
      grabbed the latest code from: https://github.com/b4winckler/macvim

      Lua and Cscope are installed, which I understand are necessary

      But when I compile using the configure:

      ./configure --with-features=huge --with-lua-prefix=/usr/local/bin/lua
      --enable-luainterp=dynamic

      Everything compiles fine, but :version still shows -lua

      Suggestions?

      c
      --
      Chris Lott <chris@...>

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • björn
      ... I would guess that dynamic is not supported, try --enable-luainterp instead (I cannot check as I don t have Lua installed). Björn -- -- You received
      Message 2 of 3 , Jun 24, 2013
      • 0 Attachment
        On Mon, Jun 24, 2013 at 9:00 PM, Chris Lott wrote:
        > I'm trying to compile MacVim with Lua support on OS X 10.8.4 -- I have
        > grabbed the latest code from: https://github.com/b4winckler/macvim
        >
        > Lua and Cscope are installed, which I understand are necessary
        >
        > But when I compile using the configure:
        >
        > ./configure --with-features=huge --with-lua-prefix=/usr/local/bin/lua
        > --enable-luainterp=dynamic
        >
        > Everything compiles fine, but :version still shows -lua
        >
        > Suggestions?

        I would guess that "dynamic" is not supported, try
        "--enable-luainterp" instead (I cannot check as I don't have Lua
        installed).

        Björn

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tony Mechelynck
        ... Dynamic interpreter interfaces are mostly for Windows. For Unix-like platforms (including Linux and, I suppose, Mac OS X) the static interfaces are
        Message 3 of 3 , Jun 25, 2013
        • 0 Attachment
          On Monday, June 24, 2013 9:00:17 PM UTC+2, Chris Lott wrote:
          > I'm trying to compile MacVim with Lua support on OS X 10.8.4 -- I have
          >
          > grabbed the latest code from: https://github.com/b4winckler/macvim
          >
          >
          >
          > Lua and Cscope are installed, which I understand are necessary
          >
          >
          >
          > But when I compile using the configure:
          >
          >
          >
          > ./configure --with-features=huge --with-lua-prefix=/usr/local/bin/lua
          >
          > --enable-luainterp=dynamic
          >
          >
          >
          > Everything compiles fine, but :version still shows -lua
          >
          >
          >
          > Suggestions?
          >
          >
          >
          > c
          >
          > --
          >
          > Chris Lott <chris@...>

          "Dynamic" interpreter interfaces are mostly for Windows. For Unix-like platforms (including Linux and, I suppose, Mac OS X) the "static" interfaces are used. I set the following environment variables when compiling Vim on Linux:

          #!/bin/bash
          export CONF_OPT_GUI='--enable-gnome-check'
          export CONF_OPT_LUA='--enable-luainterp'
          export CONF_OPT_PERL='--enable-perlinterp'
          export CONF_OPT_PYTHON='--enable-pythoninterp'
          export CONF_OPT_TCL='--enable-tclinterp'
          export CONF_OPT_RUBY='--enable-rubyinterp'
          export CONF_OPT_MZSCHEME='--disable-mzschemeinterp'
          export CONF_OPT_CSCOPE='--enable-cscope'
          export CONF_OPT_MULTIBYTE='--enable-multibyte'
          export CONF_OPT_FEAT='--with-features=huge'
          export CONF_OPT_COMPBY='"--with-compiledby=antoine.mechelynck@..."'

          Beware that the above file must be "sourced", not "run", so these environment settings persist when the next bash command (e.g. "make") is run. And of course you will want to change at least the last line (and possibly some other ones too, depending on the compile-time options you prefer).

          See also:
          http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
          http://users.skynet.be/antoine.mechelynck/vim/compunix.htm

          Best regards,
          Tony.
          --
          LARGE MAN: Who's that then?
          CART DRIVER: (Grudgingly) I dunno, Must be a king.
          LARGE MAN: Why?
          CART DRIVER: He hasn't got shit all over him.
          "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.