Loading ...
Sorry, an error occurred while loading the content.

Re: Strange error in 7.3.1148 on Tiger PPC

Expand Messages
  • björn
    ... This is caused by a mismatch between the Python headers you compile against and the Python library you link against. I only use the system installed
    Message 1 of 2 , Jun 18 12:28 PM
    • 0 Attachment
      On Sun, Jun 9, 2013 at 7:17 AM, wrote:
      > On Tiger PPC, there is a new error in 7.3.1148 that was not in 7.3.1020 or earlier. To reproduce, clone a fresh repo and build with --enable-pythoninterp. Open a MacVim window and do
      > :py print "hello"
      >
      > I see the following error:
      >
      > sys:1: RuntimeWarning: Python C API version mismatch for module vim: This Python has API version 1013, module vim has version 1012.
      >
      > I have MacVim linked against Python 2.7.5, installed into /library/frameworks. Linking to a Python located there has always worked fine until now.

      This is caused by a mismatch between the Python headers you compile
      against and the Python library you link against. I only use the
      system installed Python so I can't help you with this.

      Björn

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.