Loading ...
Sorry, an error occurred while loading the content.

langmap and remappings

Expand Messages
  • EGDmitry
    Hello folks, I am trying to understand how langmap interacts with existing mappings. Consider this case: I use the suggested cyrillic langmap like this: set
    Message 1 of 3 , Jun 17, 2013
    View Source
    • 0 Attachment
      Hello folks,

      I am trying to understand how langmap interacts with existing mappings. Consider this case: I use the suggested cyrillic langmap like this:

      set langmap=ФИСВУАПРШОЛДЬТЩЗЙКЫЕГМЦЧНЯ;ABCDEFGHIJKLMNOPQRSTUVWXYZ,фисвуапршолдьтщзйкыегмцчня;abcdefghijklmnopqrstuvwxyz

      and I also have mappings:

      nnoremap j gj
      nnoremap k gk

      the problem is that when I use cyrillic equivalents of 'j' and 'k' I get an old behavior, it looks like my bindings don't get applied. Is this expected or do I understand something wrong about how it works?

      Thanks a lot,
      Dima

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • björn
      ... I think you should try posting this to the vim_use Google group. It sounds like a general Vim problem and not specific to Vim on the Mac. Björn -- -- You
      Message 2 of 3 , Jun 18, 2013
      View Source
      • 0 Attachment
        On Tue, Jun 18, 2013 at 6:15 AM, EGDmitry wrote:
        > Hello folks,
        >
        > I am trying to understand how langmap interacts with existing mappings. Consider this case: I use the suggested cyrillic langmap like this:
        >
        > set langmap=ФИСВУАПРШОЛДЬТЩЗЙКЫЕГМЦЧНЯ;ABCDEFGHIJKLMNOPQRSTUVWXYZ,фисвуапршолдьтщзйкыегмцчня;abcdefghijklmnopqrstuvwxyz
        >
        > and I also have mappings:
        >
        > nnoremap j gj
        > nnoremap k gk
        >
        > the problem is that when I use cyrillic equivalents of 'j' and 'k' I get an old behavior, it looks like my bindings don't get applied. Is this expected or do I understand something wrong about how it works?

        I think you should try posting this to the vim_use Google group. It
        sounds like a general Vim problem and not specific to Vim on the Mac.

        Björn

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • EGDmitry
        That s a good idea, thanks. I just remembered — there was also a weird bug in MacVim so that when Dvorak langmap was applied, a lot of macvim shortcuts like
        Message 3 of 3 , Jun 18, 2013
        View Source
        • 0 Attachment
          That's a good idea, thanks. I just remembered — there was also a weird bug in MacVim so that when Dvorak langmap was applied, a lot of macvim shortcuts like cmd+s stopped working. But I think that one was closed as the one not to be fixed.

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.