Loading ...
Sorry, an error occurred while loading the content.

pasting text: bug?

Expand Messages
  • peiman khosravi
    This behaviour is not consistent but it happens often. When editing something like this: test - 5 May 2013 I copy a line, delete the text in
    Message 1 of 3 , Jun 9, 2013
    View Source
    • 0 Attachment
      This behaviour is not consistent but it happens often. 

      When editing something like this:

      <title> test - 5 May 2013</title>

      I copy a line, delete the text in between the title tag and paste the copied line there instead. The result is sometime normal, but at other times the new text is pasted before the <title> tag, rather than in between the tags. Is this normal?

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • björn
      ... If you select a line with a newline character, then Vim will paste *above* the cursor. If there is no newline character in the selection then it pastes
      Message 2 of 3 , Jun 9, 2013
      View Source
      • 0 Attachment
        On Sun, Jun 9, 2013 at 1:22 PM, peiman khosravi wrote:
        > This behaviour is not consistent but it happens often.
        >
        > When editing something like this:
        >
        > <title> test - 5 May 2013</title>
        >
        > I copy a line, delete the text in between the title tag and paste the copied
        > line there instead. The result is sometime normal, but at other times the
        > new text is pasted before the <title> tag, rather than in between the tags.
        > Is this normal?

        If you select a line with a newline character, then Vim will paste
        *above* the cursor. If there is no newline character in the selection
        then it pastes *at* the cursor.

        It is a "feature", not a bug, I'm afraid.

        Björn

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • peiman khosravi
        OK, that makes a lot of sense now. Thanks for clarifying. Best, Peiman *www.peimankhosravi.co.uk* || Subscribe to RSS
        Message 3 of 3 , Jun 9, 2013
        View Source
        • 0 Attachment
          OK, that makes a lot of sense now. Thanks for clarifying. 

          Best,
          Peiman






          www.peimankhosravi.co.uk || Subscribe to RSS Feed

          To receive emails about upcoming concerts visit this page & enter your email address in the 'follow' section.



          On 9 June 2013 15:34, björn <bjorn.winckler@...> wrote:
          On Sun, Jun 9, 2013 at 1:22 PM, peiman khosravi wrote:
          > This behaviour is not consistent but it happens often.
          >
          > When editing something like this:
          >
          > <title> test - 5 May 2013</title>
          >
          > I copy a line, delete the text in between the title tag and paste the copied
          > line there instead. The result is sometime normal, but at other times the
          > new text is pasted before the <title> tag, rather than in between the tags.
          > Is this normal?

          If you select a line with a newline character, then Vim will paste
          *above* the cursor.  If there is no newline character in the selection
          then it pastes *at* the cursor.

          It is a "feature", not a bug, I'm afraid.

          Björn

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.



          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        Your message has been successfully submitted and would be delivered to recipients shortly.