Loading ...
Sorry, an error occurred while loading the content.

macvim map! doesn't work. :(

Expand Messages
  • hieonn@...
    Hi, experts. I ve just installed (dragged the MacVim.app onto Applications folder) the MacVim. I can t use a certain key combination such as map! () () i
    Message 1 of 4 , Jun 7, 2013
    • 0 Attachment
      Hi, experts.

      I've just installed (dragged the MacVim.app onto Applications folder) the MacVim. I can't use a certain key combination such as "map! () ()<Esc>i" which works for doing auto-closing, other key mappings work well except the mapping in ~/.gvimrc. whereas the combination works very well in windows gvim and Ubuntu vim.

      I've tried changing map! () ()<Esc>i into map! () ()<C-c>i to check out whether <Esc> doesn't work in MacVim, it didn't work though.

      For your information, I've checked
      :map! commands returns map! () ()<Esc>i exactly, but "verbose map" returns nothing.

      So, I've tried to find other way to use auto-closing functionality, I could find autoclose.vim in vim.org. I had put the plug-in into ~/.vim/plugin/. even plugin didn't work at all.

      I can't find any other things I'm supposed to do any more. Please help me! experts!

      hieonn.

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • hieonn@...
      Addition, verbose map returns ! () () i as well. still doesn t work. Any help would be appreciated. Thanks in advance! -- -- You received this message
      Message 2 of 4 , Jun 7, 2013
      • 0 Attachment
        Addition,

        "verbose map" returns ! () ()<Esc>i as well. still doesn't work.
        Any help would be appreciated.

        Thanks in advance!

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • björn
        ... I just checked and the map you mention works fine for me on 7.3.967. Try starting from Terminal with /Applications/MacVim.app/Contents/MacOS/Vim -u NONE -U
        Message 3 of 4 , Jun 8, 2013
        • 0 Attachment
          On Fri, Jun 7, 2013 at 8:09 PM, wrote:
          >
          > I've just installed (dragged the MacVim.app onto Applications folder) the MacVim. I can't use a certain key combination such as "map! () ()<Esc>i" which works for doing auto-closing, other key mappings work well except the mapping in ~/.gvimrc. whereas the combination works very well in windows gvim and Ubuntu vim.

          I just checked and the map you mention works fine for me on 7.3.967.

          Try starting from Terminal with

          /Applications/MacVim.app/Contents/MacOS/Vim -u NONE -U NONE -g

          Then enter your map manually and see if that works. If it does, then
          you have a plugin or [g]vimrc setting that is interfering.

          Other things I can think of is that you may be using a keyboard layout
          that causes problems. If you're not using an English layout, try US
          English and see if that works.

          Björn

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • hieonn@...
          Dear, Björn. The problem had come from the setting duplications. I ve figured out what had been invoking the problem actually by your big inspiration. The
          Message 4 of 4 , Jun 8, 2013
          • 0 Attachment
            Dear, Björn.

            The problem had come from the setting duplications. I've figured out what had been invoking the problem actually by your big inspiration. The detail is there were two same settings in .vimrc and .gvimrc and those were interfering each other. Now everything works well after eliminating all duplicated settings in both files. The actual thing I've done is having removed .gvimrc from home directory.

            Thank you for your big help and wish that this thread would help other people who may be suffered from similar phenomenon. Now I can use Vim on Mac freely.

            Cheers vim!

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.