Loading ...
Sorry, an error occurred while loading the content.

MacVim and Syntastic

Expand Messages
  • Blake Sweeney
    Hi, I m getting some strange behavior with MacVim and Syntastic. When Syntastic finds an error it puts a mark in the sign column, however, once I fix the error
    Message 1 of 4 , Jun 7, 2013
    • 0 Attachment
      Hi,

      I'm getting some strange behavior with MacVim and Syntastic. When Syntastic
      finds an error it puts a mark in the sign column, however, once I fix the error
      the mark in the sign column is not removed. I've tried this in just vim and I
      don't get this behavior with the same vimrc. My MacVim is:

      > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jun 4 2013 10:01:53)
      > MacOS X (unix) version
      > Included patches: 1-754
      > Compiled by Homebrew
      > Huge version with MacVim GUI. Features included (+) or not (-):

      While my normal vim is:

      > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr 9 2013 13:30:35)
      > MacOS X (unix) version
      > Included patches: 1-884
      > Compiled by bsweene@...
      > Huge version without GUI. Features included (+) or not (-):

      Has anyone else had this problem?


      Thanks,
      Blake

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • björn
      ... It sounds a bit like it could be a bug in MacVim s implementation of the signs feature, but I don t ever use this myself so haven t noticed any problems.
      Message 2 of 4 , Jun 18, 2013
      • 0 Attachment
        On Fri, Jun 7, 2013 at 2:26 PM, Blake Sweeney wrote:
        >
        > I'm getting some strange behavior with MacVim and Syntastic. When Syntastic
        > finds an error it puts a mark in the sign column, however, once I fix the error
        > the mark in the sign column is not removed. I've tried this in just vim and I
        > don't get this behavior with the same vimrc. My MacVim is:
        >
        >> VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jun 4 2013 10:01:53)
        >> MacOS X (unix) version
        >> Included patches: 1-754
        >> Compiled by Homebrew
        >> Huge version with MacVim GUI. Features included (+) or not (-):
        >
        > While my normal vim is:
        >
        >> VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr 9 2013 13:30:35)
        >> MacOS X (unix) version
        >> Included patches: 1-884
        >> Compiled by bsweene@...
        >> Huge version without GUI. Features included (+) or not (-):
        >
        > Has anyone else had this problem?

        It sounds a bit like it could be a bug in MacVim's implementation of
        the signs feature, but I don't ever use this myself so haven't noticed
        any problems.

        Can you create a minimal set of step-by-step instructions on how to
        reproduce (preferably using only Syntastic and Vim)? Attach a file if
        necessary.

        Thanks,
        Björn

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Blake Sweeney
        ... The vimrc below causes the problem for me: Bad setup. filetype off set rtp+=~/.vim/bundle/vundle/ call vundle#rc() Bundle gmarik/vundle Bundle
        Message 3 of 4 , Jun 21, 2013
        • 0 Attachment
          On Tue, Jun 18, 2013 at 09:33:28PM +0200, björn wrote:
          > It sounds a bit like it could be a bug in MacVim's implementation of
          > the signs feature, but I don't ever use this myself so haven't noticed
          > any problems.
          >
          > Can you create a minimal set of step-by-step instructions on how to
          > reproduce (preferably using only Syntastic and Vim)? Attach a file if
          > necessary.

          The vimrc below causes the problem for me:

          " Bad setup.
          filetype off

          set rtp+=~/.vim/bundle/vundle/

          call vundle#rc()

          Bundle 'gmarik/vundle'
          Bundle 'scrooloose/syntastic'

          " Comment out below to remove problem with signs.
          let g:syntastic_auto_loc_list=1

          In addition, syntastic has an option to set the sign used and this doesn't seem
          to work in this case either. What happens is the sign I set will briefly appear
          and then it is replaced by the default one from syntastic. This can be
          demostrated by adding the follow line:

          let g:syntastic_warning_symbol='⚠'

          As the comment indicates commenting out the 'let g:syntastic_auto_loc_list=1'
          line hides all the problems.


          Thanks,
          Blake

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • björn
          ... Thanks for the info. However, using your .vimrc (minus the vundle stuff, that surely cannot be required to reproduce?) does not do anything -- you ll have
          Message 4 of 4 , Jun 23, 2013
          • 0 Attachment
            On Fri, Jun 21, 2013 at 8:52 PM, Blake Sweeney wrote:
            > On Tue, Jun 18, 2013 at 09:33:28PM +0200, björn wrote:
            >> It sounds a bit like it could be a bug in MacVim's implementation of
            >> the signs feature, but I don't ever use this myself so haven't noticed
            >> any problems.
            >>
            >> Can you create a minimal set of step-by-step instructions on how to
            >> reproduce (preferably using only Syntastic and Vim)? Attach a file if
            >> necessary.
            >
            > The vimrc below causes the problem for me:
            >
            > " Bad setup.
            > filetype off
            >
            > set rtp+=~/.vim/bundle/vundle/
            >
            > call vundle#rc()
            >
            > Bundle 'gmarik/vundle'
            > Bundle 'scrooloose/syntastic'
            >
            > " Comment out below to remove problem with signs.
            > let g:syntastic_auto_loc_list=1
            >
            > In addition, syntastic has an option to set the sign used and this doesn't seem
            > to work in this case either. What happens is the sign I set will briefly appear
            > and then it is replaced by the default one from syntastic. This can be
            > demostrated by adding the follow line:
            >
            > let g:syntastic_warning_symbol='⚠'
            >
            > As the comment indicates commenting out the 'let g:syntastic_auto_loc_list=1'
            > line hides all the problems.

            Thanks for the info. However, using your .vimrc (minus the vundle
            stuff, that surely cannot be required to reproduce?) does not do
            anything -- you'll have to provide me with a file that causes
            syntastic to show a mark (and please make sure there are no
            dependencies on external programs such as compilers which are not
            shipped with Xcode).

            This is starting to sound like a plugin problem (based on the fact
            that the problem goes away when you remove the "let g:synt..." line),
            but if you provide *all* steps needed to reproduce I'll still try to
            take a look. Have you reported it to the plugin authors? They may be
            better able to help.

            Björn

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.