Loading ...
Sorry, an error occurred while loading the content.

Re: Stupid "magical" fix

Expand Messages
  • Eric Weir
    ... Well, I ve answered my own question, and it seems to have nothing to do with the synchronizing of the .vim folders on the macbook and the tablet. After
    Message 1 of 10 , May 13, 2013
    • 0 Attachment
      On May 13, 2013, at 11:41 AM, Eric Weir wrote:

      > If anyone has a clue why---or more importantly, why I started getting "swap exists" messages for swap files in '/var/tmp/', why macvim asked me if I wanted to create a file on an android path, why I stopped getting macvim and started getting gvim, why after restoring an older backup .vim folder I got macvim back, why after I got macvim back I still didn't have my key mappings---I would really be interested. I really would like to understand.

      Well, I've answered my own question, and it seems to have nothing to do with the synchronizing of the .vim folders on the macbook and the tablet.

      After restoring the .vim folder and the .vimrc from six weeks ago, I decided to see which one had given me back my keymappings. It was the .vimrc. So I decided to see if I could see what it was about the .vimrc that had done the trick. I compared the older .vimrc with the one previously in use.

      There was a *one character* difference. Somehow the initial 'i' got lopped off the insert mode remapping of jj to <esc>. I did it, of course. I have no idea how or when, but it had to be me.

      I don't know what I look like, but I'm feeling a little sheepish after all the "sturm and drang" of the last few days.

      ------------------------------------------------------------------------------------------
      Eric Weir
      Decatur, GA
      eeweir@...

      "Style is truth."

      - Ray Bradbury

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.