Loading ...
Sorry, an error occurred while loading the content.

Issue with COLORFGBG env variable

Expand Messages
  • mescalinum@...
    There is this issue with the COLORFGBG environment variable: when it is set[1], for example, in my case, COLORFGBG= 7;0 , the colorscheme in MacVim (mvim) is
    Message 1 of 2 , Mar 14, 2013
    View Source
    • 0 Attachment
      There is this issue with the COLORFGBG environment variable:
      when it is set[1], for example, in my case, COLORFGBG="7;0", the colorscheme in MacVim (mvim) is messed up, apparently because the vim background setting is overridden.

      In order to fix this thing, I have to interactively change the colorscheme TWICE. (note that it doesn't work just putting two consecutive 'colorscheme default' in vimrc or just overriding the background var in vimrc (or both).

      [1]: this usecase happens in practice when using iTerm2 instead of Terminal.app. In iTerm2, COLORFGBG is set in order to inform vim about the background.
      But it seems to mess things up for mvim.
      Check also this bugreport http://code.google.com/p/iterm2/issues/detail?id=2345 I think now it's clear it's not a iTerm2 issue, since the root cause has been isolated to be the setting of the COLORFGBG env var.

      I think it is possible to reproduce this thing by just launching mvim in iTerm2, or COLORFGBG=7;0 mvim in any terminal (didn't check).

      software version:
      OSX 10.7.5
      iTerm 1.0.0.20130122
      MacVim 66

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • björn
      I can t reproduce with iTerm2 1.0.0.20130302 on OS X 10.6.8 with MacVim snapshot 66. Is it perhaps related to a specific colorscheme? Which one are you using?
      Message 2 of 2 , Mar 16, 2013
      View Source
      • 0 Attachment
        I can't reproduce with iTerm2 1.0.0.20130302 on OS X 10.6.8 with
        MacVim snapshot 66. Is it perhaps related to a specific colorscheme?
        Which one are you using? I'm using "desert" and started with

        COLORFGBG="7;0" mvim

        since that variable is unset by default on my computer.

        Björn

        On Thu, Mar 14, 2013 at 10:09 PM, <mescalinum@...> wrote:
        > There is this issue with the COLORFGBG environment variable:
        > when it is set[1], for example, in my case, COLORFGBG="7;0", the colorscheme in MacVim (mvim) is messed up, apparently because the vim background setting is overridden.
        >
        > In order to fix this thing, I have to interactively change the colorscheme TWICE. (note that it doesn't work just putting two consecutive 'colorscheme default' in vimrc or just overriding the background var in vimrc (or both).
        >
        > [1]: this usecase happens in practice when using iTerm2 instead of Terminal.app. In iTerm2, COLORFGBG is set in order to inform vim about the background.
        > But it seems to mess things up for mvim.
        > Check also this bugreport http://code.google.com/p/iterm2/issues/detail?id=2345 I think now it's clear it's not a iTerm2 issue, since the root cause has been isolated to be the setting of the COLORFGBG env var.
        >
        > I think it is possible to reproduce this thing by just launching mvim in iTerm2, or COLORFGBG=7;0 mvim in any terminal (didn't check).
        >
        > software version:
        > OSX 10.7.5
        > iTerm 1.0.0.20130122
        > MacVim 66
        >
        > --
        > --
        > You received this message from the "vim_mac" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php
        >
        > ---
        > You received this message because you are subscribed to the Google Groups "vim_mac" group.
        > To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        > For more options, visit https://groups.google.com/groups/opt_out.
        >
        >

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.