Loading ...
Sorry, an error occurred while loading the content.

Macvim slow with "set list" and Unicode listchars

Expand Messages
  • Kevin Burke
    Hi, I ve been investigating a problem with Unicode listchars. My .vimrc looks like: show line endings set list set listchars=tab:▸ ,eol:¬ When I open a
    Message 1 of 5 , Mar 13, 2013
    • 0 Attachment
      Hi,
      I've been investigating a problem with Unicode listchars.

      My .vimrc looks like:

      "" show line endings
      set list
      set listchars=tab:▸\ ,eol:¬

      When I open a file containing many tab characters, Macvim is extremely slow to scroll - holding down "j" yields a key repeat rate of about once per second.

      If I turn off list:

      set nolist

      Or, use a different tab listchar:

      set listchars=tab:+\ ,eol

      Scrolling suddenly becomes very fast.

      Here is information about my version:

      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 4 2013 10:46:00)
      MacOS X (unix) version
      Included patches: 1-754
      Compiled by kevin@...
      Huge version with MacVim GUI. Features included (+) or not (-):
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +conceal +cryptv -cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags +eval
      +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork() +fullscreen -gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname +mouse
      +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg +odbeditor +path_extra +perl +persistent_undo +postscript +printer +profile +python -python3 +quickfix
      +reltime +rightleft +ruby +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title +toolbar +transparency +user_commands +vertsplit +virtualedit
      +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset +xim -xsmp -xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/Applications/MacVim.app/Contents/Resources/vim"
      Compilation: clang -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MACVIM -Wall -Wno-unknown-pragmas -pipe -DMACOS_X_UNIX -no-cpp-precomp -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/System/Library/Frameworks/Tcl.framework/Headers -D_REENTRANT=1 -D_THREAD_SAFE=1 -D
      _DARWIN_C_SOURCE=1
      Linking: clang -L. -L. -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon -lncurses -liconv -framework Cocoa -fstack-protector -L/usr/local/lib -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python
      -F/System/Library/Frameworks -framework Tcl -framework CoreFoundation -framework Ruby

      I am running on Mountain Lion. Let me know if I can do anything to help debug this issue further.

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • björn
      I tried creating a simple file with tabs in it but did not experience the slowness you mention. Can you please send me a file where the problem occurs for you
      Message 2 of 5 , Mar 14, 2013
      • 0 Attachment
        I tried creating a simple file with tabs in it but did not experience
        the slowness you mention. Can you please send me a file where the
        problem occurs for you so that I have something to test with?

        Thanks,
        Björn

        On Wed, Mar 13, 2013 at 11:16 PM, Kevin Burke <kevin@...> wrote:
        > Hi,
        > I've been investigating a problem with Unicode listchars.
        >
        > My .vimrc looks like:
        >
        > "" show line endings
        > set list
        > set listchars=tab:▸\ ,eol:¬
        >
        > When I open a file containing many tab characters, Macvim is extremely slow to scroll - holding down "j" yields a key repeat rate of about once per second.
        >
        > If I turn off list:
        >
        > set nolist
        >
        > Or, use a different tab listchar:
        >
        > set listchars=tab:+\ ,eol
        >
        > Scrolling suddenly becomes very fast.
        >
        > Here is information about my version:
        >
        > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 4 2013 10:46:00)
        > MacOS X (unix) version
        > Included patches: 1-754
        > Compiled by kevin@...
        > Huge version with MacVim GUI. Features included (+) or not (-):
        > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +conceal +cryptv -cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags +eval
        > +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork() +fullscreen -gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname +mouse
        > +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg +odbeditor +path_extra +perl +persistent_undo +postscript +printer +profile +python -python3 +quickfix
        > +reltime +rightleft +ruby +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title +toolbar +transparency +user_commands +vertsplit +virtualedit
        > +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset +xim -xsmp -xterm_clipboard -xterm_save
        > system vimrc file: "$VIM/vimrc"
        > user vimrc file: "$HOME/.vimrc"
        > user exrc file: "$HOME/.exrc"
        > system gvimrc file: "$VIM/gvimrc"
        > user gvimrc file: "$HOME/.gvimrc"
        > system menu file: "$VIMRUNTIME/menu.vim"
        > fall-back for $VIM: "/Applications/MacVim.app/Contents/Resources/vim"
        > Compilation: clang -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MACVIM -Wall -Wno-unknown-pragmas -pipe -DMACOS_X_UNIX -no-cpp-precomp -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/System/Library/Frameworks/Tcl.framework/Headers -D_REENTRANT=1 -D_THREAD_SAFE=1 -D
        > _DARWIN_C_SOURCE=1
        > Linking: clang -L. -L. -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon -lncurses -liconv -framework Cocoa -fstack-protector -L/usr/local/lib -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python
        > -F/System/Library/Frameworks -framework Tcl -framework CoreFoundation -framework Ruby
        >
        > I am running on Mountain Lion. Let me know if I can do anything to help debug this issue further.
        >
        > --
        > --
        > You received this message from the "vim_mac" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php
        >
        > ---
        > You received this message because you are subscribed to the Google Groups "vim_mac" group.
        > To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        > For more options, visit https://groups.google.com/groups/opt_out.
        >
        >

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • François-Pierre Bouchard
        I had the same issue with a couple of fonts (Consolas, Source Code Pro) and I got rid of the issue by disabling the Core Text Renderer in the Advanced
        Message 3 of 5 , May 29, 2013
        • 0 Attachment
          I had the same issue with a couple of fonts (Consolas, Source Code Pro) and I got rid of the issue by disabling the Core Text Renderer in the Advanced preferences.

          On Wednesday, March 13, 2013 6:16:13 PM UTC-4, Kevin Burke wrote:
          > Hi,
          >
          > I've been investigating a problem with Unicode listchars.
          >
          >
          >
          > My .vimrc looks like:
          >
          >
          >
          > "" show line endings
          >
          > set list
          >
          > set listchars=tab:▸\ ,eol:¬
          >
          >
          >
          > When I open a file containing many tab characters, Macvim is extremely slow to scroll - holding down "j" yields a key repeat rate of about once per second.
          >
          >
          >
          > If I turn off list:
          >
          >
          >
          > set nolist
          >
          >
          >
          > Or, use a different tab listchar:
          >
          >
          >
          > set listchars=tab:+\ ,eol
          >
          >
          >
          > Scrolling suddenly becomes very fast.
          >
          >
          >
          > Here is information about my version:
          >
          >
          >
          > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 4 2013 10:46:00)
          >
          > MacOS X (unix) version
          >
          > Included patches: 1-754
          >
          > Compiled by kevin@...
          >
          > Huge version with MacVim GUI. Features included (+) or not (-):
          >
          > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +conceal +cryptv -cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags +eval
          >
          > +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork() +fullscreen -gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname +mouse
          >
          > +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg +odbeditor +path_extra +perl +persistent_undo +postscript +printer +profile +python -python3 +quickfix
          >
          > +reltime +rightleft +ruby +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title +toolbar +transparency +user_commands +vertsplit +virtualedit
          >
          > +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset +xim -xsmp -xterm_clipboard -xterm_save
          >
          > system vimrc file: "$VIM/vimrc"
          >
          > user vimrc file: "$HOME/.vimrc"
          >
          > user exrc file: "$HOME/.exrc"
          >
          > system gvimrc file: "$VIM/gvimrc"
          >
          > user gvimrc file: "$HOME/.gvimrc"
          >
          > system menu file: "$VIMRUNTIME/menu.vim"
          >
          > fall-back for $VIM: "/Applications/MacVim.app/Contents/Resources/vim"
          >
          > Compilation: clang -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MACVIM -Wall -Wno-unknown-pragmas -pipe -DMACOS_X_UNIX -no-cpp-precomp -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/System/Library/Frameworks/Tcl.framework/Headers -D_REENTRANT=1 -D_THREAD_SAFE=1 -D
          >
          > _DARWIN_C_SOURCE=1
          >
          > Linking: clang -L. -L. -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon -lncurses -liconv -framework Cocoa -fstack-protector -L/usr/local/lib -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python
          >
          > -F/System/Library/Frameworks -framework Tcl -framework CoreFoundation -framework Ruby
          >
          >
          >
          > I am running on Mountain Lion. Let me know if I can do anything to help debug this issue further.

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Yuma Antoine Decaux
          Hi all, For those working on the project, i wanted to know where i could start figuring out how to make vimac accessible. Considering it s a coco application,
          Message 4 of 5 , May 29, 2013
          • 0 Attachment
            Hi all,

            For those working on the project, i wanted to know where i could start figuring out how to make vimac accessible. Considering it's a coco application, can i assume that some of the interface can be using apple's appkit framework, or any other apple framework for that matter?


            Any pointers to how i can contribute greatly appreciated.

            Best regards,

            Yuma 







            "Light has no value without darkness"
            Mob: +61 (0)410732547
            Skype: Shainobi1

            This message is protected by article 4-210 of a certain book of laws but you don't have to worry about privacy issues if you are the intended recipient. However, if any freakish circumstance such as ip sniffing, honey pot open relay servers or an honest mistake caused a transmission error, please advise the sender and throw your laptop into a bubble bath to avoid all illicit data retention.

            On 29/05/2013, at 11:11 PM, François-Pierre Bouchard <fpbouchard@...> wrote:

            I had the same issue with a couple of fonts (Consolas, Source Code Pro) and I got rid of the issue by disabling the Core Text Renderer in the Advanced preferences.

            On Wednesday, March 13, 2013 6:16:13 PM UTC-4, Kevin Burke wrote:
            Hi,

            I've been investigating a problem with Unicode listchars.



            My .vimrc looks like:



            "" show line endings

            set list

            set listchars=tab:▸\ ,eol:¬



            When I open a file containing many tab characters, Macvim is extremely slow to scroll - holding down "j" yields a key repeat rate of about once per second.



            If I turn off list:



            set nolist



            Or, use a different tab listchar:



            set listchars=tab:+\ ,eol



            Scrolling suddenly becomes very fast.



            Here is information about my version:



            VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar  4 2013 10:46:00)

            MacOS X (unix) version

            Included patches: 1-754

            Compiled by kevin@...

            Huge version with MacVim GUI.  Features included (+) or not (-):

            +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +conceal +cryptv -cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags +eval

            +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork() +fullscreen -gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname +mouse

            +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg +odbeditor +path_extra +perl +persistent_undo +postscript +printer +profile +python -python3 +quickfix

            +reltime +rightleft +ruby +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title +toolbar +transparency +user_commands +vertsplit +virtualedit

            +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset +xim -xsmp -xterm_clipboard -xterm_save

              system vimrc file: "$VIM/vimrc"

                user vimrc file: "$HOME/.vimrc"

                 user exrc file: "$HOME/.exrc"

             system gvimrc file: "$VIM/gvimrc"

               user gvimrc file: "$HOME/.gvimrc"

               system menu file: "$VIMRUNTIME/menu.vim"

             fall-back for $VIM: "/Applications/MacVim.app/Contents/Resources/vim"

            Compilation: clang -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MACVIM -Wall -Wno-unknown-pragmas -pipe  -DMACOS_X_UNIX -no-cpp-precomp  -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1     -I/System/Library/Frameworks/Tcl.framework/Headers  -D_REENTRANT=1  -D_THREAD_SAFE=1  -D

            _DARWIN_C_SOURCE=1

            Linking: clang   -L.   -L.        -L/usr/local/lib -o Vim -framework Cocoa -framework Carbon      -lncurses -liconv -framework Cocoa    -fstack-protector -L/usr/local/lib  -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm -lutil -lc -framework Python

             -F/System/Library/Frameworks -framework Tcl -framework CoreFoundation -framework Ruby



            I am running on Mountain Lion. Let me know if I can do anything to help debug this issue further.

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.



            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • björn
            ... I have pushed a fix for this now. It was caused by a font lookup API call which for some reason is super-slow on Mountain Lion whereas on Snow Leopard it
            Message 5 of 5 , Jun 9, 2013
            • 0 Attachment
              On Wed, Mar 13, 2013 at 11:16 PM, Kevin Burke wrote:
              > I've been investigating a problem with Unicode listchars.
              >
              > My .vimrc looks like:
              >
              > "" show line endings
              > set list
              > set listchars=tab:▸\ ,eol:¬
              >
              > When I open a file containing many tab characters, Macvim is extremely slow to scroll - holding down "j" yields a key repeat rate of about once per second.
              >
              > If I turn off list:
              >
              > set nolist
              >
              > Or, use a different tab listchar:
              >
              > set listchars=tab:+\ ,eol
              >
              > Scrolling suddenly becomes very fast.

              I have pushed a fix for this now. It was caused by a font lookup API
              call which for some reason is super-slow on Mountain Lion whereas on
              Snow Leopard it was fast. (That is also why I couldn't reproduce to
              begin with.)

              Björn

              --
              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_mac" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.