Loading ...
Sorry, an error occurred while loading the content.

Re: Ctrl-C to abort during MacVim launch

Expand Messages
  • Phil Dobbin
    ... A wild guess off the top of my head: MacVim, not primarily being a terminal bound program, will not recognise the SIGHUP from Ctrl- c in relation to a
    Message 1 of 2 , Mar 10, 2013
    • 0 Attachment
      On 10/03/2013 13:16, patrick.kristiansen@... wrote:

      > Hi
      >
      > I have installed a plugin called vim-foreplay [1] for Clojure
      > development. When I edit a .clj file, vim-foreplay tries to spin up
      > a Java Virtual Machine (JVM), which usually takes a while. If I use
      > terminal Vim, I can press Ctrl-C to abort spinning up the JVM, but it
      > doesn't seem to work when I try to edit the file with MacVim.
      >
      > As far as I can tell, I haven't done anything in .gvimrc [2], that
      > should change the behavior of Ctrl-C.
      >
      > Can anyone enlighten me?

      A wild guess off the top of my head: MacVim, not primarily being a
      terminal bound program, will not recognise the SIGHUP from Ctrl-
      c in relation to a process called externally.

      You'd probably have better luck sending Cmd-full-stop. But I haven't
      tried it. Major caveat to my thoughts: I almost exclusively use console
      vim, so apologies if I'm miles out here.

      Cheers,

      Phil...


      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.