Loading ...
Sorry, an error occurred while loading the content.

disabling arrow keys

Expand Messages
  • Chris Lott
    Can anyone help me completely disable arrow keys in any mode in MacVim? No matter what I do the arrow keys still move between windows in normal mode, for
    Message 1 of 2 , Feb 27, 2013
    • 0 Attachment
      Can anyone help me completely disable arrow keys in any mode in
      MacVim? No matter what I do the arrow keys still move between windows
      in normal mode, for instance.

      c
      --
      Chris Lott <chris@...>

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Chris Schneider
      Arrow keys moving between windows is weird. Take a look at your mappings. I bet you have something there already. To disable them, a global map should do it:
      Message 2 of 2 , Feb 27, 2013
      • 0 Attachment
        Arrow keys moving between windows is weird. Take a look at your mappings.  I bet you have something there already.

        To disable them, a global map should do it:

        map <left> <nop>
        imap <left> <nop> 

        Map covers normal, visual and "operator pending" modes.  Then do insert mode and that's most of what you'd need to turn off.  Repeat for each arrow.


        On Wed, Feb 27, 2013 at 10:59 AM, Chris Lott <chris@...> wrote:
        Can anyone help me completely disable arrow keys in any mode in
        MacVim? No matter what I do the arrow keys still move between windows
        in normal mode, for instance.

        c
        --
        Chris Lott <chris@...>

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.



        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      Your message has been successfully submitted and would be delivered to recipients shortly.