Loading ...
Sorry, an error occurred while loading the content.

Re: block insertion not working

Expand Messages
  • Barrie Stott
    ... It was my pleasure. No reply needed. Barrie. -- -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text
    Message 1 of 7 , Feb 22, 2013
    View Source
    • 0 Attachment
      On 22 Feb 2013, at 16:14, WenMin Tu wrote:

      > 在 2013年2月22日星期五UTC+8下午11时59分55秒,Barrie写道:
      >> On 22 Feb 2013, at 09:31, WenMin Tu wrote:
      >>
      >>
      >>
      >>> using visual block mode to select few lines(I tried CTRL+v, v, V, CTRL+q), and I tried to using "i" to insert some chars in front of every selected line, but turns out it is not even respond to the command "i". but it does respond to "d" which will delete the selected parts.
      >>
      >>
      >>
      >> In Normal mode type ctrl-v to get visual block mode. Type characters to move the cursor to get to the end of the Visual-Block and the whole block should be highlighted. Suppose we want to add ABC at the beginning of each line of the block. Type IABC and ABC will appear at the beginning of the first line of the block; the highlighting will disappear after typing the A. Type Esc to finish the insertion and ABC will appear at the beginning of each line of the block; at least that is what happened on my machine using Snow Leopard.
      >>
      >>
      >>
      >> Typing ':h visual.txt' in MacVim gives a whole chapter about Visual stuff and ':h blockwise-operators' is the main section for the current exercise with the warning: {not available when compiled without the +visualextra feature}
      >>
      >>
      >>
      >> Barrie.
      >
      > oh mama mia. a huge thank u to u, buddy.
      > it works. It just works for the CTRL+v and I(capital).
      > didn't what got on me, I used to remember that it should working in every situation as long as I selected few lines(v or V or CTRL+v), I mean it should working as long as I'm in visual mode.
      > ok, turns out it didn't. thank u again

      It was my pleasure. No reply needed.

      Barrie.

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.