Loading ...
Sorry, an error occurred while loading the content.

Re: What have I done! Vim Caps first word in new lin.

Expand Messages
  • björn
    Hi David, Usually when things like this happen the cause is a plugin (although that does not explain why it happens in bash). Moving your customizations out
    Message 1 of 5 , Feb 19, 2013
    • 0 Attachment
      Hi David,

      Usually when things like this happen the cause is a plugin (although
      that does not explain why it happens in bash). Moving your
      customizations out of the way, as described in the first step of [1],
      will help you determine if that is the case.

      Otherwise all I can suggest is that you try asking on vim_use as it
      has more people reading (and helping) with these types of problems.

      Good luck,
      Björn

      [1] https://github.com/b4winckler/macvim/wiki/Troubleshooting

      On Mon, Feb 18, 2013 at 5:38 AM, David Gillooly
      <david.gillooly@...> wrote:
      > Somehow I have gotten MacVim to capitalize the first word in a new line.I dont want this!
      >
      > I may have played around with some bash script too as iin bash I get the same thing happening.
      >
      > Any ideas.
      >
      > --
      > --
      > You received this message from the "vim_mac" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php
      >
      > ---
      > You received this message because you are subscribed to the Google Groups "vim_mac" group.
      > To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      > For more options, visit https://groups.google.com/groups/opt_out.
      >
      >

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • David Gillooly
      ... Thanks for the suggestion (s). I will do the other post too. Yes it is strange that the same action shows upo in the mac terminal. When I type in MacVim I
      Message 2 of 5 , Feb 19, 2013
      • 0 Attachment
        On Sunday, February 17, 2013 8:38:05 PM UTC-8, David Gillooly wrote:
        > Somehow I have gotten MacVim to capitalize the first word in a new line.I dont want this!
        >
        > I may have played around with some bash script too as iin bash I get the same thing happening.
        >
        > Any ideas.

        Thanks for the suggestion (s). I will do the other post too.

        Yes it is strange that the same action shows upo in the mac terminal.

        When I type in MacVim I see the EDIT pull down menu name flash for a brief second so something is going on.

        Thanks..Dave

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • David Gillooly
        ... Some additional information: I did try this. Issued :set compatible ... No idea where this coming from when the first character is capitalized. -- -- You
        Message 3 of 5 , Feb 19, 2013
        • 0 Attachment
          On Tuesday, February 19, 2013 5:34:27 PM UTC-8, David Gillooly wrote:
          > On Sunday, February 17, 2013 8:38:05 PM UTC-8, David Gillooly wrote:
          > > Somehow I have gotten MacVim to capitalize the first word in a new line.I dont want this!
          > >
          > > I may have played around with some bash script too as iin bash I get the same thing happening.
          > >
          > > Any ideas.
          >
          > Thanks for the suggestion (s). I will do the other post too.
          >
          > Yes it is strange that the same action shows upo in the mac terminal.
          >
          > When I type in MacVim I see the EDIT pull down menu name flash for a brief second so something is going on.
          >
          > Thanks..Dave

          Some additional information:

          I did try this.

          Issued :set compatible

          Now I see in the lower staus line that this is done:
          :call paste#Paste()

          No idea where this coming from when the first character is capitalized.

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • David Gillooly
          Your suggestion paid off! A week ago I changed my setting preference on Text Expander to capitalize sentences! I had forgotten about this change. ... -- -- You
          Message 4 of 5 , Feb 19, 2013
          • 0 Attachment
            Your suggestion paid off!

            A week ago I changed my setting preference on Text Expander to capitalize sentences!
            I had forgotten about this change.



            On Tuesday, February 19, 2013 12:00:46 PM UTC-8, björn wrote:
            > Hi David,
            >
            >
            >
            > Usually when things like this happen the cause is a plugin (although
            >
            > that does not explain why it happens in bash). Moving your
            >
            > customizations out of the way, as described in the first step of [1],
            >
            > will help you determine if that is the case.
            >
            >
            >
            > Otherwise all I can suggest is that you try asking on vim_use as it
            >
            > has more people reading (and helping) with these types of problems.
            >
            >
            >
            > Good luck,
            >
            > Björn
            >
            >
            >
            > [1] https://github.com/b4winckler/macvim/wiki/Troubleshooting
            >
            >
            >
            > On Mon, Feb 18, 2013 at 5:38 AM, David Gillooly
            >
            > <david.gillooly@...> wrote:
            >
            > > Somehow I have gotten MacVim to capitalize the first word in a new line.I dont want this!
            >
            > >
            >
            > > I may have played around with some bash script too as iin bash I get the same thing happening.
            >
            > >
            >
            > > Any ideas.
            >
            > >
            >
            > > --
            >
            > > --
            >
            > > You received this message from the "vim_mac" maillist.
            >
            > > Do not top-post! Type your reply below the text you are replying to.
            >
            > > For more information, visit http://www.vim.org/maillist.php
            >
            > >
            >
            > > ---
            >
            > > You received this message because you are subscribed to the Google Groups "vim_mac" group.
            >
            > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            >
            > > For more options, visit https://groups.google.com/groups/opt_out.
            >
            > >
            >
            > >

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.