Loading ...
Sorry, an error occurred while loading the content.

MacVim doesn't open windows anymore

Expand Messages
  • Niels Kobschätzki
    Hi, I have suddenly a very strange problem: I start MacVim and no window gets opened. Pushing cmd+n or using the menu for that doesn t work either. Using the
    Message 1 of 5 , Feb 11, 2013
    • 0 Attachment
      Hi,

      I have suddenly a very strange problem: I start MacVim and no window
      gets opened. Pushing cmd+n or using the menu for that doesn't work
      either. Using the Finder and telling to open a file with MacVim will
      open MacVim but not the window with the file. In ActivityMonitor I can
      only find a MacVim-process but no vim-process.
      Each time I open MacVim in console.app I see the following error:
      11.02.13 21:18:51,000 kernel[0]: MacVim (map: 0xffffff800eb78a48)
      triggered DYLD shared region unnest for map: 0xffffff800eb78a48, region
      0x7fff8f000000->0x7fff8f200000. While not abnormal for debuggers, this
      increases system memory footprint until the target exits.

      Pushing cmd+n doesn't bring up any error in Console.app

      The only thing I remember doing recently is updating my homebrew-stuff
      and removing XCode and installing the XCode command line-utilities.
      I tried deleting my .vim-folder, my .vimrc and my .gvimrc and nothing
      worked.

      Starting vim in terminal works fine. Starting the vim in the
      MacVim.app-bundle works as well. Starting the MacVim-binary from the
      command line opens MacVim, also with no window and there is no error
      message.

      Creating a new account and starting MacVim there works fine.

      Mac OS 10.8.2, MacVim Snapshot 66.

      Niels

      --
      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_mac" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bee
      On Feb 11, 12:30 pm, Niels Kobschätzki ... quit macvim if it is running move: ~/Library/Preferences/org.vim.MacVim.plist to the
      Message 2 of 5 , Feb 11, 2013
      • 0 Attachment
        On Feb 11, 12:30 pm, "Niels Kobschätzki" <ni...@...>
        wrote:
        > Hi,
        >
        > I have suddenly a very strange problem: I start MacVim and no window
        > gets opened. Pushing cmd+n or using the menu for that doesn't work
        > either. Using the Finder and telling to open a file with MacVim will
        > open MacVim but not the window with the file. In ActivityMonitor I can
        > only find a MacVim-process but no vim-process.
        > Each time I open MacVim in console.app I see the following error:
        > 11.02.13 21:18:51,000 kernel[0]: MacVim (map: 0xffffff800eb78a48)
        > triggered DYLD shared region unnest for map: 0xffffff800eb78a48, region
        > 0x7fff8f000000->0x7fff8f200000. While not abnormal for debuggers, this
        > increases system memory footprint until the target exits.
        >
        > Pushing cmd+n doesn't bring up any error in Console.app
        >
        > The only thing I remember doing recently is updating my homebrew-stuff
        > and removing XCode and installing the XCode command line-utilities.
        > I tried deleting my .vim-folder, my .vimrc and my .gvimrc and nothing
        > worked.
        >
        > Starting vim in terminal works fine. Starting the vim in the
        > MacVim.app-bundle works as well. Starting the MacVim-binary from the
        > command line opens MacVim, also with no window and there is no error
        > message.
        >
        > Creating a new account and starting MacVim there works fine.
        >
        > Mac OS 10.8.2, MacVim Snapshot 66.
        >
        > Niels

        quit macvim if it is running

        move:

        ~/Library/Preferences/org.vim.MacVim.plist

        to the desktop
        and restart macvim
        if that works
        the preferences were corrupt
        then delete the old org.vim.MacVim.plist
        a new one will have been created

        bill

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Niels Kobschätzki
        ... [snip remove MacVim-preference-files from ~/Library/Preferences] Nope, that s not it. Still not working. Thanks, Niels -- -- You received this message from
        Message 3 of 5 , Feb 11, 2013
        • 0 Attachment
          On 11 Feb 2013, at 22:23, Bee wrote:

          > On Feb 11, 12:30 pm, "Niels Kobschätzki" <ni...@...>
          > wrote:
          >> Hi,
          >>
          >> I have suddenly a very strange problem: I start MacVim and no window
          >> gets opened. Pushing cmd+n or using the menu for that doesn't work
          >> either. Using the Finder and telling to open a file with MacVim will
          >> open MacVim but not the window with the file. In ActivityMonitor I can
          >> only find a MacVim-process but no vim-process.
          >> Each time I open MacVim in console.app I see the following error:
          >> 11.02.13 21:18:51,000 kernel[0]: MacVim (map: 0xffffff800eb78a48)
          >> triggered DYLD shared region unnest for map: 0xffffff800eb78a48, region
          >> 0x7fff8f000000->0x7fff8f200000. While not abnormal for debuggers, this
          >> increases system memory footprint until the target exits.
          >>
          >> Pushing cmd+n doesn't bring up any error in Console.app
          >>
          >> The only thing I remember doing recently is updating my homebrew-stuff
          >> and removing XCode and installing the XCode command line-utilities.
          >> I tried deleting my .vim-folder, my .vimrc and my .gvimrc and nothing
          >> worked.
          >>
          >> Starting vim in terminal works fine. Starting the vim in the
          >> MacVim.app-bundle works as well. Starting the MacVim-binary from the
          >> command line opens MacVim, also with no window and there is no error
          >> message.
          >>
          >> Creating a new account and starting MacVim there works fine.
          >>
          >> Mac OS 10.8.2, MacVim Snapshot 66.
          >>
          >> Niels
          >
          > quit macvim if it is running

          [snip remove MacVim-preference-files from ~/Library/Preferences]

          Nope, that's not it. Still not working.

          Thanks,

          Niels

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Niels Kobschätzki
          ...
          Message 4 of 5 , Feb 12, 2013
          • 0 Attachment
            On 11 Feb 2013, at 21:30, Niels Kobschätzki wrote:

            > Hi,

            <MacVim doesn't open windows anymore; no vim-process running>

            After using Onyx and all cleaned all caches, rebuilding launchd-database
            - essentially checking everything in the Automation-tab, MacVim works
            now again :)

            Niels

            --
            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_mac" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • björn
            Very interesting to hear that you managed to work around this issue. I ve added your comment at https://code.google.com/p/macvim/issues/detail?id=363 Björn On
            Message 5 of 5 , Feb 12, 2013
            • 0 Attachment
              Very interesting to hear that you managed to work around this issue.
              I've added your comment at

              https://code.google.com/p/macvim/issues/detail?id=363

              Björn


              On Tue, Feb 12, 2013 at 8:51 PM, Niels Kobschätzki
              <niels@...> wrote:
              > On 11 Feb 2013, at 21:30, Niels Kobschätzki wrote:
              >
              >> Hi,
              >
              >
              > <MacVim doesn't open windows anymore; no vim-process running>
              >
              > After using Onyx and all cleaned all caches, rebuilding launchd-database -
              > essentially checking everything in the Automation-tab, MacVim works now
              > again :)
              >
              >
              > Niels
              >
              > --
              > --
              > You received this message from the "vim_mac" maillist.
              > Do not top-post! Type your reply below the text you are replying to.
              > For more information, visit http://www.vim.org/maillist.php
              >
              > --- You received this message because you are subscribed to the Google
              > Groups "vim_mac" group.
              > To unsubscribe from this group and stop receiving emails from it, send an
              > email to vim_mac+unsubscribe@....
              > For more options, visit https://groups.google.com/groups/opt_out.
              >
              >

              --
              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_mac" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.