Loading ...
Sorry, an error occurred while loading the content.

Trouble with the Core Text renderer in (non native) full-screen

Expand Messages
  • Alexander Günther
    Hi everybody, I have a rendering problem in my MacVim: Steps: 1. I start MacVim. 2. I switch into the fullscreen mode. 3. I open a file. 4. I split the view
    Message 1 of 2 , Jan 23, 2013
    • 0 Attachment
      Hi everybody,

      I have a rendering problem in my MacVim:

      Steps:
      1. I start MacVim.
      2. I switch into the fullscreen mode.
      3. I open a file.
      4. I split the view vertical (:vs) and horizontal (:sp).
      5. I click on the a border between two views an drag it up or down to resize them.

      Result:
      The views get resized as expected.
      But the most of the screen turns black. (Executing :redraw! fixes it until I resize them again.)
      I attached a before and after screenshots.

      The problem ist that same behavior appears in other situations e.g. using the CtrlP plugin.

      Environment:
      I use the MacVim snapshot 66 on OS X 10.8.2 (with an intel graphic card).
      I reproduced the behaviour without my .vimrc, .gvimrc and .vim folder to make sure it's not a plugins fault.
      It happens when I use the MacVim in full-screen mode.
      Avanced settings:
      [x] Use Core Text renderer
      [ ] Enable Quickstart
      [x] Draw marked text inline
      [ ] Preffer native full-screen support

      Do someone experience similar problems or has ideas how I can fix it?

      Cheers, Alex

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      This is a problem with the Core Text renderer which can be worked around by disabling it in the advance preferences. The good news is that I know how to fix
      Message 2 of 2 , Feb 2, 2013
      • 0 Attachment
        This is a problem with the Core Text renderer which can be worked
        around by disabling it in the advance preferences.

        The good news is that I know how to fix this problem. The bad news is
        that it is a major undertaking and I have no idea when I'll have the
        time it will take. :-(

        Björn

        On Wed, Jan 23, 2013 at 2:49 PM, Alexander Günther
        <alex.guenther@...> wrote:
        > Hi everybody,
        >
        > I have a rendering problem in my MacVim:
        >
        > Steps:
        > 1. I start MacVim.
        > 2. I switch into the fullscreen mode.
        > 3. I open a file.
        > 4. I split the view vertical (:vs) and horizontal (:sp).
        > 5. I click on the a border between two views an drag it up or down to resize them.
        >
        > Result:
        > The views get resized as expected.
        > But the most of the screen turns black. (Executing :redraw! fixes it until I resize them again.)
        > I attached a before and after screenshots.
        >
        > The problem ist that same behavior appears in other situations e.g. using the CtrlP plugin.
        >
        > Environment:
        > I use the MacVim snapshot 66 on OS X 10.8.2 (with an intel graphic card).
        > I reproduced the behaviour without my .vimrc, .gvimrc and .vim folder to make sure it's not a plugins fault.
        > It happens when I use the MacVim in full-screen mode.
        > Avanced settings:
        > [x] Use Core Text renderer
        > [ ] Enable Quickstart
        > [x] Draw marked text inline
        > [ ] Preffer native full-screen support
        >
        > Do someone experience similar problems or has ideas how I can fix it?
        >
        > Cheers, Alex
        >
        > --
        > You received this message from the "vim_mac" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php

        --
        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_mac" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.