Loading ...
Sorry, an error occurred while loading the content.

cannot allocate color errors in terminal

Expand Messages
  • Chris Lott
    (I ve found a few proposed solutions for this problem, but none of them work for me.) **Problem** I am trying to use Vim as the git core.editor -- no matter
    Message 1 of 3 , Nov 27, 2012
    View Source
    • 0 Attachment
      (I've found a few proposed solutions for this problem, but none of
      them work for me.)

      **Problem**

      I am trying to use Vim as the git core.editor -- no matter what I do,
      I get "cannot allocate color" messages.

      I've tried setting the git core.editor (using --replace-all) to vim,
      mvim, vim -U NONE -u NONE, mvim -u NONE -U NONE, etc.

      **Notes**

      * I have nothing referring to Vim in my .bashrc

      * I have a `/usr/bin/vim` that is aliased to `/usr/bin/vim ->
      /Applications/MacVim.app/Contents/MacOS/Vim`

      * I have no aliases for vim or mvim set

      * If I execute vim in the terminal it starts up just fine, no errors

      * echo $TERM responds `xterm-256color`

      **Environment**

      Vim Version:

      IM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 1 2012 18:08:47)
      MacOS X (unix) version
      Included patches: 1-646

      OS: `OS X 10.8.2`

      Bash: `GNU bash, version 4.2.39(2)-release (i386-apple-darwin12.2.1)`


      Any ideas?

      c
      --
      Chris Lott <chris@...>

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Andrew Stewart
      ... I don t what the problem is, but as a shot in the dark: I set the EDITOR variable in my environment to the full path to MacVim s executable. export
      Message 2 of 3 , Nov 28, 2012
      View Source
      • 0 Attachment
        On 27 Nov 2012, at 20:32, Chris Lott wrote:
        > **Problem**
        >
        > I am trying to use Vim as the git core.editor -- no matter what I do,
        > I get "cannot allocate color" messages.
        >
        > I've tried setting the git core.editor (using --replace-all) to vim,
        > mvim, vim -U NONE -u NONE, mvim -u NONE -U NONE, etc.

        I don't what the problem is, but as a shot in the dark:

        I set the EDITOR variable in my environment to the full path to MacVim's executable.

        export EDITOR=/Applications/MacVim.app/Contents/MacOS/Vim

        I don't have GIT_EDITOR set, nor core.editor, nor VISUAL.

        Do you have anything configured in the color section of your git config?

        Yours,
        Andy Stewart

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Randy McMillan
        By setting the editor variable toeditor = /Applications/MacVim.app/Contents/MacOS/Vim instead, you can invoke the correct binaries. To be very specific, your
        Message 3 of 3 , Nov 28, 2012
        View Source
        • 0 Attachment

          By setting the editor variable toeditor = /Applications/MacVim.app/Contents/MacOS/Vim instead, you can invoke the correct binaries. To be very specific, your `~/.gitconfig' file should include the following:

          [core]
              editor = /Applications/MacVim.app/Contents/MacOS/Vim

        Your message has been successfully submitted and would be delivered to recipients shortly.