Loading ...
Sorry, an error occurred while loading the content.

why does sourcing my .vimrc is reducing font size?

Expand Messages
  • Chris Lott
    The following are links to my .vimrc and the included function files (the first for gvim, which is what I am using):
    Message 1 of 2 , Nov 25, 2012
    • 0 Attachment
      The following are links to my .vimrc and the included function files
      (the first for gvim, which is what I am using):

      https://github.com/fncll/vimfiles/blob/master/.vimrc
      https://github.com/fncll/vimfiles/blob/master/vimrc/mygfuncs.vim
      https://github.com/fncll/vimfiles/blob/master/vimrc/myfuncs.vim

      The strange thing that is happening is that everything is fine when I
      use Vim, generally, but if I make changes to the .vimrc and then
      source it (using :so %), the font size gets smaller (as does the
      window size) though set guifont? shows the proper size received at
      startup. And it appears to be changed globally because it persists
      when I open new files. Anyone have an idea what might be triggering
      this?

      (and apologies if my .vimrc has any issues--I'm poet not a programmer)

      c
      --
      Chris Lott <chris@...>

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Chris Lott
      ... Answered my own question (and I already had the answer in my own comments): I needed to set the font upon entering the GUI: au GUIEnter * set
      Message 2 of 2 , Nov 25, 2012
      • 0 Attachment
        On Sun, Nov 25, 2012 at 11:57 AM, Chris Lott <chris@...> wrote:
        > The strange thing that is happening is that everything is fine when I
        > use Vim, generally, but if I make changes to the .vimrc and then
        > source it (using :so %), the font size gets smaller (as does the
        > window size) though set guifont? shows the proper size received at
        > startup. And it appears to be changed globally because it persists
        > when I open new files. Anyone have an idea what might be triggering
        > this?

        Answered my own question (and I already had the answer in my own comments):

        I needed to set the font upon entering the GUI:
        au GUIEnter * set guifont=Source\ Code\ Pro:h16

        c
        --
        Chris Lott <chris@...>

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.