Loading ...
Sorry, an error occurred while loading the content.
 

How to get trackpad gestures to work?

Expand Messages
  • Gary Dance
    Hello, I am using Macvim Snapshot 65 and have the following lines in my .vimrc file: Touchpad functionality nmap :bN nmap
    Message 1 of 3 , Nov 21, 2012
      Hello,

      I am using Macvim Snapshot 65 and have the following lines in my .vimrc file:

      " Touchpad functionality
      nmap <SwipeLeft> :bN<CR>
      nmap <SwipeRight> :bn<CR>

      But for some reason the trackpad doesn't seem to work to change buffers. I can still scroll up and down though.

      Can anyone help me figure out what is wrong?

      Thanks

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Chris Lott
      ... Two things to check: 1) if you have mapped two finger swipes to go between pages (or anything else) in your System Preferences, you need to stop doing that
      Message 2 of 3 , Nov 21, 2012
        On Wed, Nov 21, 2012 at 12:13 AM, Gary Dance <yargy@...> wrote:
        > " Touchpad functionality
        > nmap <SwipeLeft> :bN<CR>
        > nmap <SwipeRight> :bn<CR>

        Two things to check:

        1) if you have mapped two finger swipes to go between pages (or
        anything else) in your System Preferences, you need to stop doing that
        because I don't believe Vim can override that.

        2) check the value of `mouse` -- I have mine set to `a`

        In that combination, the mapping works for me.

        c
        --
        Chris Lott <chris@...>

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Gary Dance
        Hmm I disabled the two finger swype between pages and my mouse is set to a and it still doesn t work :( -- -- You received this message from the vim_mac
        Message 3 of 3 , Feb 2, 2013
          Hmm I disabled the two finger swype between pages and my mouse is set to a and it still doesn't work :(

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.