Loading ...
Sorry, an error occurred while loading the content.

guifont + lines + colums

Expand Messages
  • Keyan
    Hi, I still have the problem that the following line ... does change the font, but not the lines and columns. Cheers, Keyan -- You received this message from
    Message 1 of 8 , Oct 5, 2012
    • 0 Attachment
      Hi,

      I still have the problem that the following line

      :set guifont=Menlo:h26 lines=30 columns=80

      does change the font, but not the lines and columns.

      Cheers,
      Keyan

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Bee
      ... Do you have that line in .vimrc? If yes, try it in .gvimrc Works here with one exception, my laptop screen is not large enough to display 80 columns at
      Message 2 of 8 , Oct 5, 2012
      • 0 Attachment
        On Oct 5, 7:59 am, Keyan <key....@...> wrote:
        > Hi,
        >
        > I still have the problem that the following line
        >
        > :set guifont=Menlo:h26 lines=30 columns=80
        >
        > does change the font, but not the lines and columns.
        >
        > Cheers,
        > Keyan

        Do you have that line in .vimrc?
        If yes, try it in .gvimrc

        Works here with one exception, my laptop screen is
        not large enough to display 80 columns at Menlo:h26

        But this works great:

        :set guifont=Menlo:h18 lines=30 columns=80

        Bill

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Keyan
        ... Hi, i had it in my .vimrc and in my .gvimrc. what i have send is from the command mode. the line you have posted does not work for me. i use VIM - Vi
        Message 3 of 8 , Oct 5, 2012
        • 0 Attachment
          On 5 Oct 2012, at 18:28, Bee <forth@...> wrote:

          >
          >
          > On Oct 5, 7:59 am, Keyan <key....@...> wrote:
          >> Hi,
          >>
          >> I still have the problem that the following line
          >>
          >> :set guifont=Menlo:h26 lines=30 columns=80
          >>
          >> does change the font, but not the lines and columns.
          >>
          >> Cheers,
          >> Keyan
          >
          > Do you have that line in .vimrc?
          > If yes, try it in .gvimrc
          >
          > Works here with one exception, my laptop screen is
          > not large enough to display 80 columns at Menlo:h26
          >
          > But this works great:
          >
          > :set guifont=Menlo:h18 lines=30 columns=80
          >
          > Bill

          Hi,

          i had it in my .vimrc and in my .gvimrc. what i have send is from the command mode. the line you have posted does not work for me. i use

          VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 1 2012 01:05:49)
          MacOS X (unix) version
          Included patches: 1-604

          (compiled from homebrew)

          Cheers,
          Keyan

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Bee
          ... Try this in .gvimrc, remove the reference to guifont set lines=30 columns=80 Does that work? -- You received this message from the vim_mac maillist. Do
          Message 4 of 8 , Oct 5, 2012
          • 0 Attachment
            Keyan wrote:
            > i had it in my .vimrc and in my .gvimrc.
            > what i have send is from the command mode.
            > the line you have posted does not work for me. i use
            >
            > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 1 2012 01:05:49)
            > MacOS X (unix) version
            > Included patches: 1-604

            Try this in .gvimrc, remove the reference to guifont

            set lines=30 columns=80

            Does that work?

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Keyan
            ... removed set guifont from .gvimrc, and I have none in the .vimrc. added set lines=30 colums=80 in the last line of my .gvimrc and it did not work, because i
            Message 5 of 8 , Oct 5, 2012
            • 0 Attachment
              On 5 Oct 2012, at 21:27, Bee <forth@...> wrote:

              > Keyan wrote:
              >> i had it in my .vimrc and in my .gvimrc.
              >> what i have send is from the command mode.
              >> the line you have posted does not work for me. i use
              >>
              >> VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 1 2012 01:05:49)
              >> MacOS X (unix) version
              >> Included patches: 1-604
              >
              > Try this in .gvimrc, remove the reference to guifont
              >
              > set lines=30 columns=80
              >
              > Does that work?

              removed set guifont from .gvimrc, and I have none in the .vimrc. added set lines=30 colums=80 in the last line of my .gvimrc and it did not work, because i have set fu. if i remove this option, it works. i like to use vim in full-screen mode by default, so that is why i forgot to add that important information. sorry for that.

              the initial :set command that i posted works fine in non-fullscreen mode. i use the build-in fullscreen method, not the mac os version of fullscreen, because i like to see the output (e.g. latex) on the second screen.

              cheers,
              Keyan

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Bee
              ... ... Note: Setting fullscreen usually changes the size of the Vim control. However, for technical reasons, lines and columns will currently only be
              Message 6 of 8 , Oct 5, 2012
              • 0 Attachment
                Keyan wrote:
                > On 5 Oct 2012, at 21:27, Bee <forth@...> wrote:
                >
                > > Keyan wrote:
                > >> i had it in my .vimrc and in my .gvimrc.
                > >> what i have send is from the command mode.
                > >> the line you have posted does not work for me. i use
                > >>
                > >> VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Sep 1 2012 01:05:49)
                > >> MacOS X (unix) version
                > >> Included patches: 1-604
                > >
                > > Try this in .gvimrc, remove the reference to guifont
                > >
                > > set lines=30 columns=80
                > >
                > > Does that work?
                >
                > removed set guifont from .gvimrc, and I have none in the .vimrc. added set lines=30 colums=80 in the last line of my .gvimrc and it did not work, because i have set fu. if i remove this option, it works. i like to use vim in full-screen mode by default, so that is why i forgot to add that important information. sorry for that.
                >
                > the initial :set command that i posted works fine in non-fullscreen mode. i use the build-in fullscreen method, not the mac os version of fullscreen, because i like to see the output (e.g. latex) on the second screen.
                >
                > cheers,
                > Keyan

                :help fullscreen
                ...
                Note: Setting 'fullscreen' usually changes the size of the Vim
                control. However, for technical reasons, 'lines' and 'columns'
                will currently only be updated when Vim runs its event loop. As
                a consequence, if you set 'fullscreen' and 'lines' or 'columns'
                in a Vim script file, you should always set 'fullscreen' after
                setting 'lines' and 'columns', else 'lines' and 'columns' will
                be overwritten with the values 'fullscreen' sets after the
                script has been executed and the event loop is ran again.

                Also see:
                :help fuoptions

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Bee
                PS If I set fullscreen in a script is does not work. In .gvimrc I set lines and columns and set fuoptions to do not change size of vim and this mapping to
                Message 7 of 8 , Oct 5, 2012
                • 0 Attachment
                  PS
                  If I set fullscreen in a script is does not work.

                  In .gvimrc I set lines and columns
                  and set fuoptions to do not change size of vim
                  and this mapping to toggle fullscreen

                  " -------1---------2---------3---------4---------5---------6----
                  :set guifont=Menlo:h18 lines=30 columns=80

                  " Don't change size of Vim when entering fullscreen
                  :set fuoptions=

                  " Toggle fullscreen
                  :nmap <F12> :set fullscreen!<cr>

                  " -------1---------2---------3---------4---------5---------6----

                  :help fuoptions

                  Bill

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Keyan
                  Hi, thanks a lot. The set fuoptions did the trick! :) Cheers, Keyan ... -- You received this message from the vim_mac maillist. Do not top-post! Type your
                  Message 8 of 8 , Oct 6, 2012
                  • 0 Attachment
                    Hi,

                    thanks a lot. The set fuoptions did the trick! :)

                    Cheers,
                    Keyan

                    On 5 Oct 2012, at 23:04, Bee <forth@...> wrote:

                    > PS
                    > If I set fullscreen in a script is does not work.
                    >
                    > In .gvimrc I set lines and columns
                    > and set fuoptions to do not change size of vim
                    > and this mapping to toggle fullscreen
                    >
                    > " -------1---------2---------3---------4---------5---------6----
                    > :set guifont=Menlo:h18 lines=30 columns=80
                    >
                    > " Don't change size of Vim when entering fullscreen
                    > :set fuoptions=
                    >
                    > " Toggle fullscreen
                    > :nmap <F12> :set fullscreen!<cr>
                    >
                    > " -------1---------2---------3---------4---------5---------6----
                    >
                    > :help fuoptions
                    >
                    > Bill
                    >
                    > --
                    > You received this message from the "vim_mac" maillist.
                    > Do not top-post! Type your reply below the text you are replying to.
                    > For more information, visit http://www.vim.org/maillist.php

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.