Loading ...
Sorry, an error occurred while loading the content.

Cannot get alloy's MacVim to work on OSX 10.7.4

Expand Messages
  • Marcelo de Moraes Serpa
    Hello everyone, I m trying to migrate to Alloy s MacVim (the one with the added native Cocoa FileBrowser - found here: https://github.com/alloy/macvim) on OSX
    Message 1 of 8 , Sep 11, 2012
    • 0 Attachment
      Hello everyone,

      I'm trying to migrate to Alloy's MacVim (the one with the added native Cocoa FileBrowser - found here: https://github.com/alloy/macvim) on OSX Lion. To build it, I used this homebrew formula:

      https://github.com/joelcogen/homebrew-macvimsplitbrowser

      It built successfully, but I just can't get it to run. When I try opening it using "open" or by double-clicking the app bundle, it just appears in the doc, but no window is shown.

      When I tried to run the binary directly from the command line, by cd'ing into Contents/MacOS, I got this:

      Vim: Caught deadly signal SEGV
      Vim: Finished.

      Does anyone know why this happens and hopefully a solution to it?

      Thanks in advance,

      - Marcelo.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Giovanni Lanzani
      ... With which Ruby did you compile it? -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are
      Message 2 of 8 , Sep 13, 2012
      • 0 Attachment
        On Wednesday, September 12, 2012 7:00:12 AM UTC+2, Marcelo de Moraes Serpa wrote:
        > Hello everyone,
        >
        > I'm trying to migrate to Alloy's MacVim (the one with the added native Cocoa FileBrowser - found here: https://github.com/alloy/macvim) on OSX Lion. To build it, I used this homebrew formula:
        >
        > https://github.com/joelcogen/homebrew-macvimsplitbrowser
        >
        > It built successfully, but I just can't get it to run. When I try opening it using "open" or by double-clicking the app bundle, it just appears in the doc, but no window is shown.
        >
        > When I tried to run the binary directly from the command line, by cd'ing into Contents/MacOS, I got this:
        >
        > Vim: Caught deadly signal SEGV
        > Vim: Finished.
        >
        > Does anyone know why this happens and hopefully a solution to it?
        >
        > Thanks in advance,
        >
        > - Marcelo.

        With which Ruby did you compile it?

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Marcelo de Moraes Serpa
        Hi Giovanni, I didn t notice that before, as I didn t pay attention to output of the configure script, here it is: checking --enable-rubyinterp argument... yes
        Message 3 of 8 , Sep 13, 2012
        • 0 Attachment
          Hi Giovanni,

          I didn't notice that before, as I didn't pay attention to output of the configure script, here it is:

          checking --enable-rubyinterp argument... yes
          checking --with-ruby-command argument... defaulting to ruby
          checking for ruby... /Users/fullofcaffeine/.rvm/rubies/ruby-1.9.3-p194/bin/ruby
          checking Ruby version... OK
          checking Ruby header files... /Users/fullofcaffeine/.rvm/rubies/ruby-1.9.3-p194/include/ruby-1.9.1

          It's using my default Ruby in RVM, which is Ruby 1.9.2.p194. Should I use a lower/upper version?

          Thanks,

          Marcelo.


          On Thu, Sep 13, 2012 at 9:37 AM, Giovanni Lanzani <gglanzani@...> wrote:
          On Wednesday, September 12, 2012 7:00:12 AM UTC+2, Marcelo de Moraes Serpa wrote:
          > Hello everyone,
          >
          > I'm trying to migrate to Alloy's MacVim (the one with the added native Cocoa FileBrowser - found here: https://github.com/alloy/macvim) on OSX Lion. To build it, I used this homebrew formula:
          >
          > https://github.com/joelcogen/homebrew-macvimsplitbrowser
          >
          > It built successfully, but I just can't get it to run. When I try opening it using "open" or by double-clicking the app bundle, it just appears in the doc, but no window is shown.
          >
          > When I tried to run the binary directly from the command line, by cd'ing into Contents/MacOS, I got this:
          >
          > Vim: Caught deadly signal SEGV
          > Vim: Finished.
          >
          > Does anyone know why this happens and hopefully a solution to it?
          >
          > Thanks in advance,
          >
          > - Marcelo.

          With which Ruby did you compile it?

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Phil Dobbin
          ... FWIW, I ve never been able to compile any Vim with rvm s 1.9.3 (haven t tried compiling 1.9.3 myself & giving it a go). I ve always used 1.8.4 via rvm.
          Message 4 of 8 , Sep 13, 2012
          • 0 Attachment
            Marcelo de Moraes Serpa wrote:

            > Hi Giovanni,
            >
            > I didn't notice that before, as I didn't pay attention to output of the
            > configure script, here it is:
            >
            > checking --enable-rubyinterp argument... yes
            > checking --with-ruby-command argument... defaulting to ruby
            > checking for ruby...
            > /Users/fullofcaffeine/.rvm/rubies/ruby-1.9.3-p194/bin/ruby
            > checking Ruby version... OK
            > checking Ruby header files...
            > /Users/fullofcaffeine/.rvm/rubies/ruby-1.9.3-p194/include/ruby-1.9.1
            >
            > It's using my default Ruby in RVM, which is Ruby 1.9.2.p194. Should I
            > use a lower/upper version?

            FWIW, I've never been able to compile any Vim with rvm's 1.9.3 (haven't
            tried compiling 1.9.3 myself & giving it a go).

            I've always used 1.8.4 via rvm.

            Cheers,

            Phil...

            --
            But masters, remember that I am an ass.
            Though it be not written down,
            yet forget not that I am an ass.

            Wm. Shakespeare - Much Ado About Nothing

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Marcelo de Moraes Serpa
            I installed Ruby ruby 1.8.7 (2012-06-29 patchlevel 370) using RVM and set it as the system default, did a make clean and compiled Alloy s MacVim again Now, I
            Message 5 of 8 , Sep 13, 2012
            • 0 Attachment
              I installed Ruby ruby 1.8.7 (2012-06-29 patchlevel 370) using RVM and set it as the system default, did a make clean and compiled Alloy's MacVim again

              Now, I don't get the error messages (Vim: Caught deadly signal SEGV
              Vim: Finished.) in the console anymore, but it still doesn't draw any windows. It just stays in the dock and shows the menubar. It doesn't crash either.

              Any ideas?

              Thanks,

              -Marcelo.

              On Thu, Sep 13, 2012 at 11:05 AM, Phil Dobbin <phildobbin@...> wrote:
              Marcelo de Moraes Serpa wrote:

              > Hi Giovanni,
              >
              > I didn't notice that before, as I didn't pay attention to output of the
              > configure script, here it is:
              >
              > checking --enable-rubyinterp argument... yes
              > checking --with-ruby-command argument... defaulting to ruby
              > checking for ruby...
              > /Users/fullofcaffeine/.rvm/rubies/ruby-1.9.3-p194/bin/ruby
              > checking Ruby version... OK
              > checking Ruby header files...
              > /Users/fullofcaffeine/.rvm/rubies/ruby-1.9.3-p194/include/ruby-1.9.1
              >
              > It's using my default Ruby in RVM, which is Ruby 1.9.2.p194. Should I
              > use a lower/upper version?

              FWIW, I've never been able to compile any Vim with rvm's 1.9.3 (haven't
              tried compiling 1.9.3 myself & giving it a go).

              I've always used 1.8.4 via rvm.

              Cheers,

                Phil...

              --
              But masters, remember that I am an ass.
              Though it be not written down,
              yet forget not that I am an ass.

                  Wm. Shakespeare - Much Ado About Nothing

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Giovanni Lanzani
              ... Try compiling it without RVM, using the stock OS X ruby. I remember I could get it to work (some months ago), but I stopped using the fork, as it was not
              Message 6 of 8 , Sep 14, 2012
              • 0 Attachment
                On Thursday, September 13, 2012 7:04:22 PM UTC+2, Marcelo de Moraes Serpa wrote:
                > I installed Ruby ruby 1.8.7 (2012-06-29 patchlevel 370) using RVM and set it as the system default, did a make clean and compiled Alloy's MacVim again
                >
                >
                > Now, I don't get the error messages (Vim: Caught deadly signal SEGV
                >
                > Vim: Finished.) in the console anymore, but it still doesn't draw any windows. It just stays in the dock and shows the menubar. It doesn't crash either.
                >
                >
                >
                > Any ideas?

                Try compiling it without RVM, using the stock OS X ruby. I remember I could get it to work (some months ago), but I stopped using the fork, as it was not enough "keyboard-centric".

                Giovanni

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Tim Gray
                ... For what it s worth, I ve manually compiled MacVim in the past on 10.7 using rvm. I never seemed to have too much of a problem with it. More recently
                Message 7 of 8 , Sep 14, 2012
                • 0 Attachment
                  On Sep 13, 2012 at 12:04 PM -0500, Marcelo de Moraes Serpa wrote:
                  >Any ideas?

                  For what it's worth, I've manually compiled MacVim in the past on 10.7
                  using rvm. I never seemed to have too much of a problem with it. More
                  recently I've switched to installing MacVim using homebrew, which
                  defaults to using the default install of Ruby. Since I'm not much of a
                  Ruby developer, it doesn't bother me too much that MacVim is linked to
                  an older version of Ruby.

                  Are you using something like Command-T? If that's compiled with a
                  different version of Ruby with respect to whatever MacVim is linked to,
                  you get funny startups. Crashes essentially, but the GUI is still
                  responsive - you never get editor windows, but you can interact with the
                  OS X menus just fine.

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Marcelo de Moraes Serpa
                  Thanks guys, I ended up reverting to vanilla MacVim, which compiles and runs fine under the same circumstances. I m using command-t, but I removed it from my
                  Message 8 of 8 , Sep 14, 2012
                  • 0 Attachment
                    Thanks guys,

                    I ended up reverting to vanilla MacVim, which compiles and runs fine under the same circumstances. I'm using command-t, but I removed it from my bundles when trying to run Alloy's MacVim, but got the same error. I'll get back to it perhaps, someday, as I'm curious on the FileBrowser integration, which I think could be a nice addition.

                    Thanks,

                    - Marcelo. 

                    On Fri, Sep 14, 2012 at 9:54 AM, Tim Gray <tgray@...> wrote:
                    On Sep 13, 2012 at 12:04 PM -0500, Marcelo de Moraes Serpa wrote:
                    Any ideas?

                    For what it's worth, I've manually compiled MacVim in the past on 10.7 using rvm.  I never seemed to have too much of a problem with it.  More recently I've switched to installing MacVim using homebrew, which defaults to using the default install of Ruby.  Since I'm not much of a Ruby developer, it doesn't bother me too much that MacVim is linked to an older version of Ruby.

                    Are you using something like Command-T?  If that's compiled with a different version of Ruby with respect to whatever MacVim is linked to, you get funny startups.  Crashes essentially, but the GUI is still responsive - you never get editor windows, but you can interact with the OS X menus just fine.


                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.