Loading ...
Sorry, an error occurred while loading the content.

Re: Disabling/changing cmd-P

Expand Messages
  • Tim Johnson
    ... Thanks for the reply Bjorn, unfortunately, that has no effect. What s more the examples from gui_mac.txt using that I have tried have no effect
    Message 1 of 5 , Aug 23, 2012
    • 0 Attachment
      * björn <bjorn.winckler@...> [120823 07:11]:
      > > I've recently started using vim on Mac OSX lion.
      > > I really don't like the cmd-P mapping to start a print job, because
      > > I use cmd-[ for application switch and being a bit of a clutz I
      > > annoy myself by hitting the 'p' instead.
      > >
      > > 1)How can I disable cmd-P ?
      >
      > Try adding the following line to your ~/.gvimrc file (create it if it
      > doesn't already exists):
      >
      > macmenu File.Print key=<nop>
      >
      > For more information see ":h :macmenu" and ":h cmd-key".

      Thanks for the reply Bjorn, unfortunately, that has no effect.
      What's more the examples from gui_mac.txt using <nop> that I have
      tried have no effect either. This may be because of some other
      configuration? But I wouldn't know what that would be.

      --
      Tim
      tim at tee jay forty nine dot com or akwebsoft dot com
      http://www.akwebsoft.com

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tim Johnson
      ... [blush] Amending the previous .... I haven t had all of my coffee yet. I had placed those instructions in .gvimrc and sourced and also executed those
      Message 2 of 5 , Aug 23, 2012
      • 0 Attachment
        * björn <bjorn.winckler@...> [120823 07:11]:
        > > I've recently started using vim on Mac OSX lion.
        > > I really don't like the cmd-P mapping to start a print job, because
        > > I use cmd-[ for application switch and being a bit of a clutz I
        > > annoy myself by hitting the 'p' instead.
        > >
        > > 1)How can I disable cmd-P ?
        >
        > Try adding the following line to your ~/.gvimrc file (create it if it
        > doesn't already exists):
        >
        > macmenu File.Print key=<nop>
        >
        > For more information see ":h :macmenu" and ":h cmd-key".
        [blush] Amending the previous .... I haven't had all of my coffee
        yet. I had placed those instructions in .gvimrc and sourced and
        also executed those instructions from ex to no avail, but when I
        shut gvim down entirely and restarted - the menu action is now
        disabled. Great!

        However, now cmd-p is is paste (as in p), can I disable that?
        thanks (more coffee and reading more)
        --
        Tim
        tim at tee jay forty nine dot com or akwebsoft dot com
        http://www.akwebsoft.com

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Tim Johnson
        ... Looks like the complete recipe is: macmenu File.Print key= map Thanks again, bjorn. -- Tim tim at tee jay forty nine dot com or
        Message 3 of 5 , Aug 23, 2012
        • 0 Attachment
          * Tim Johnson <tim@...> [120823 07:38]:
          >
          > However, now cmd-p is is paste (as in p), can I disable that?
          > thanks (more coffee and reading more)
          " Looks like the complete recipe is:
          macmenu File.Print key=<nop>
          map <D-p> <nop>

          Thanks again, bjorn.
          --
          Tim
          tim at tee jay forty nine dot com or akwebsoft dot com
          http://www.akwebsoft.com

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.