Loading ...
Sorry, an error occurred while loading the content.

MacVim Slow on Retina MBP

Expand Messages
  • Kyle Murphy
    Scrolling, moving, typing, etc. are all a bit sluggish on the new rMBP. I ve moved to native vim in iTerm2 in the meantime, which is quite fast, but I much
    Message 1 of 6 , Aug 11, 2012
    • 0 Attachment
      Scrolling, moving, typing, etc. are all a bit sluggish on the new rMBP.

      I've moved to native vim in iTerm2 in the meantime, which is quite fast, but I much prefer MacVim. Will a retina optimized version be coming out?

      Thank you.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Have you enabled the Experimental renderer in the advanced preferences? I don t really know what retina optimized entails, but I at least will not be
      Message 2 of 6 , Aug 12, 2012
      • 0 Attachment
        On Sun, Aug 12, 2012 at 7:23 AM, Kyle Murphy wrote:
        > Scrolling, moving, typing, etc. are all a bit sluggish on the new rMBP.
        >
        > I've moved to native vim in iTerm2 in the meantime, which is quite fast, but I much prefer MacVim. Will a retina optimized version be coming out?

        Have you enabled the "Experimental renderer" in the advanced preferences?

        I don't really know what "retina optimized" entails, but I at least
        will not be working on that since I do not have a retina display to
        test with. If there are minor problems that I can patch blindly, then
        I'll do my best to fix them, but that's all I can do.

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Hisashi T Fujinaka
        ... I don t see any delays. Any more specifics that I could use to try to reproduce your problems? You don t even metion your OS version, do you? -- Hisashi T
        Message 3 of 6 , Aug 12, 2012
        • 0 Attachment
          On Sun, 12 Aug 2012, bj?rn wrote:

          > On Sun, Aug 12, 2012 at 7:23 AM, Kyle Murphy wrote:
          >> Scrolling, moving, typing, etc. are all a bit sluggish on the new rMBP.
          >>
          >> I've moved to native vim in iTerm2 in the meantime, which is quite fast, but I much prefer MacVim. Will a retina optimized version be coming out?
          >
          > Have you enabled the "Experimental renderer" in the advanced preferences?
          >
          > I don't really know what "retina optimized" entails, but I at least
          > will not be working on that since I do not have a retina display to
          > test with. If there are minor problems that I can patch blindly, then
          > I'll do my best to fix them, but that's all I can do.

          I don't see any delays. Any more specifics that I could use to try to
          reproduce your problems? You don't even metion your OS version, do you?

          --
          Hisashi T Fujinaka - htodd@...
          BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Kyle Murphy
          ... Enabling experimental renderer fixed it. Thanks Bjorn. -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below
          Message 4 of 6 , Aug 12, 2012
          • 0 Attachment
            On Sunday, August 12, 2012 5:58:06 AM UTC-7, björn wrote:
            > On Sun, Aug 12, 2012 at 7:23 AM, Kyle Murphy wrote:
            >
            > > Scrolling, moving, typing, etc. are all a bit sluggish on the new rMBP.
            >
            > >
            >
            > > I've moved to native vim in iTerm2 in the meantime, which is quite fast, but I much prefer MacVim. Will a retina optimized version be coming out?
            >
            >
            >
            > Have you enabled the "Experimental renderer" in the advanced preferences?
            >
            >
            >
            > I don't really know what "retina optimized" entails, but I at least
            >
            > will not be working on that since I do not have a retina display to
            >
            > test with. If there are minor problems that I can patch blindly, then
            >
            > I'll do my best to fix them, but that's all I can do.
            >
            >
            >
            > Björn

            Enabling 'experimental renderer' fixed it. Thanks Bjorn.

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Kyle Murphy
            ... That did it. Thanks Bjorn (for that and MacVim). -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text
            Message 5 of 6 , Aug 12, 2012
            • 0 Attachment
              On Sunday, August 12, 2012 5:58:06 AM UTC-7, björn wrote:

              > Have you enabled the "Experimental renderer" in the advanced preferences?

              That did it. Thanks Bjorn (for that and MacVim).

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Sean Hess
              Experimental Renderer fixed it for me. I was only noticing the issue in large MacVim windows. It was fast in small ones. It seemed like a key repeat rate
              Message 6 of 6 , Aug 13, 2012
              • 0 Attachment
                Experimental Renderer fixed it for me. I was only noticing the issue in large MacVim windows. It was fast in small ones. It seemed like a key repeat rate problem at first. Thanks for the help!

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              Your message has been successfully submitted and would be delivered to recipients shortly.