Loading ...
Sorry, an error occurred while loading the content.

Bug: MacVim shows no window when build with the new Xcode 4.4 release

Expand Messages
  • Manpreet Singh
    The Xcode 4.4 release of a few days ago on Mac Lion (10.7.4) creates MacVim builds which can t create an edit window. vim works fine, gvim just refuses to
    Message 1 of 8 , Aug 2, 2012
    View Source
    • 0 Attachment
      The Xcode 4.4 release of a few days ago on Mac Lion (10.7.4) creates MacVim builds which can't create an edit window. vim works fine, gvim just refuses to create a window no matter what you try. But it thinks it has created the window because when you try to quit it, it warns you about open windows. Please see

      https://github.com/mxcl/homebrew/issues/13657

      for multiple reports of this issue.

      Thanks
      Manpreet Singh

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Chip Warden
      ... This appears to be an issue with Xcode 4.4, not MacVim. A solution to your problem is posted at:
      Message 2 of 8 , Aug 3, 2012
      View Source
      • 0 Attachment
        On Aug 2, 2012, at 4:56 PM, Manpreet Singh <manpreet.singh@...> wrote:

        > The Xcode 4.4 release of a few days ago on Mac Lion (10.7.4) creates MacVim builds which can't create an edit window. vim works fine, gvim just refuses to create a window no matter what you try. But it thinks it has created the window because when you try to quit it, it warns you about open windows. Please see
        >
        > https://github.com/mxcl/homebrew/issues/13657
        >
        > for multiple reports of this issue.
        >
        > Thanks
        > Manpreet Singh


        This appears to be an issue with Xcode 4.4, not MacVim. A solution to your problem is posted at:

        https://github.com/mxcl/homebrew/issues/13657#issuecomment-7465494

        Chip Warden

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Manpreet Singh
        ... Nope. Does not help if you read further comments. - Manpreet -- You received this message from the vim_mac maillist. Do not top-post! Type your reply
        Message 3 of 8 , Aug 3, 2012
        View Source
        • 0 Attachment
          On Friday, August 3, 2012 10:36:55 AM UTC-7, Chip Warden wrote:
          > On Aug 2, 2012, at 4:56 PM, Manpreet Singh <manpreet.singh@...> wrote:
          >
          >
          >
          > > The Xcode 4.4 release of a few days ago on Mac Lion (10.7.4) creates MacVim builds which can't create an edit window. vim works fine, gvim just refuses to create a window no matter what you try. But it thinks it has created the window because when you try to quit it, it warns you about open windows. Please see
          >
          > >
          >
          > > https://github.com/mxcl/homebrew/issues/13657
          >
          > >
          >
          > > for multiple reports of this issue.
          >
          > >
          >
          > > Thanks
          >
          > > Manpreet Singh
          >
          >
          >
          >
          >
          > This appears to be an issue with Xcode 4.4, not MacVim. A solution to your problem is posted at:
          >
          >
          >
          > https://github.com/mxcl/homebrew/issues/13657#issuecomment-7465494
          >
          >
          >
          > Chip Warden

          Nope. Does not help if you read further comments.

          - Manpreet

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Nico Weber
          ... I debugged an issue with the same symptoms a while ago. It happened when I ran `make` (which builds vim) with a different compiler than xcodebuild (which
          Message 4 of 8 , Aug 3, 2012
          View Source
          • 0 Attachment
            On Thursday, August 2, 2012 2:56:56 PM UTC-7, Manpreet Singh wrote:
            > The Xcode 4.4 release of a few days ago on Mac Lion (10.7.4) creates MacVim builds which can't create an edit window. vim works fine, gvim just refuses to create a window no matter what you try. But it thinks it has created the window because when you try to quit it, it warns you about open windows. Please see
            >
            > https://github.com/mxcl/homebrew/issues/13657
            >
            > for multiple reports of this issue.

            I debugged an issue with the same symptoms a while ago. It happened when I ran `make` (which builds vim) with a different compiler than xcodebuild (which builds MacVim). Maybe 4.4 uses clang by default for the MacVim build -- in that case, run `CC=clang ./configure; make -j6` to build the corresponding vim binary. Make sure both vim and MacVim are built with the same compiler.

            Nico

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Manpreet Singh
            ... That did the trick. Thank you! - Manpreet -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are
            Message 5 of 8 , Aug 3, 2012
            View Source
            • 0 Attachment
              On Friday, August 3, 2012 9:59:42 PM UTC-7, Nico Weber wrote:
              > On Thursday, August 2, 2012 2:56:56 PM UTC-7, Manpreet Singh wrote:
              > > The Xcode 4.4 release of a few days ago on Mac Lion (10.7.4) creates MacVim builds which can't create an edit window. vim works fine, gvim just refuses to create a window no matter what you try. But it thinks it has created the window because when you try to quit it, it warns you about open windows. Please see
              > >
              > > https://github.com/mxcl/homebrew/issues/13657
              > >
              > > for multiple reports of this issue.
              >
              > I debugged an issue with the same symptoms a while ago. It happened when I ran `make` (which builds vim) with a different compiler than xcodebuild (which builds MacVim). Maybe 4.4 uses clang by default for the MacVim build -- in that case, run `CC=clang ./configure; make -j6` to build the corresponding vim binary. Make sure both vim and MacVim are built with the same compiler.
              >
              > Nico

              That did the trick. Thank you!

              - Manpreet

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • gmn
              ... Yes, CC=clang ./configure; make -j6 works. But *jeez* it is annoying that special steps have to be taken. Plus, during the compliation of the Vim
              Message 6 of 8 , Aug 4, 2012
              View Source
              • 0 Attachment
                > I debugged an issue with the same symptoms a while ago. It happened
                > when I ran `make` (which builds vim) with a different compiler than
                > xcodebuild (which builds MacVim). Maybe 4.4 uses clang by default for
                > the MacVim build -- in that case, run `CC=clang ./configure; make -j6`
                > to build the corresponding vim binary. Make sure both vim and MacVim
                > are built with the same compiler.

                Yes, "CC=clang ./configure; make -j6" works. But *jeez* it is annoying
                that special steps have to be taken.

                Plus, during the compliation of the Vim binary, all sorts of warnings
                are thrown out that weren't there before. And it's annoying because I
                usually want to just run the ./configuring part first. In which case, I
                can do "export CC=clang" and then the configuring on a separate line,
                but then I have to remember to get rid of $CC after building MacVim lest
                I accidentally botch building something else.

                And now my steps for building have to be different between 10.7 and up,
                and 10.6 and below.

                Arrgh! Apple!

                -gmn

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • gmn
                ... Hey, has anyone else noticed that there is no need for this maneuver at all on Mountain Lion, even though it has XCode 4.4 as well? I know there s a
                Message 7 of 8 , Aug 4, 2012
                View Source
                • 0 Attachment
                  > > I debugged an issue with the same symptoms a while ago. It happened
                  > > when I ran `make` (which builds vim) with a different compiler than
                  > > xcodebuild (which builds MacVim). Maybe 4.4 uses clang by default for
                  > > the MacVim build -- in that case, run `CC=clang ./configure; make -j6`
                  > > to build the corresponding vim binary. Make sure both vim and MacVim
                  > > are built with the same compiler.
                  >
                  > Yes, "CC=clang ./configure; make -j6" works. But *jeez* it is annoying
                  > that special steps have to be taken.
                  >
                  > Plus, during the compliation of the Vim binary, all sorts of warnings
                  > are thrown out that weren't there before. And it's annoying because I
                  > usually want to just run the ./configuring part first. In which case, I
                  > can do "export CC=clang" and then the configuring on a separate line,
                  > but then I have to remember to get rid of $CC after building MacVim lest
                  > I accidentally botch building something else.
                  >
                  > And now my steps for building have to be different between 10.7 and up,
                  > and 10.6 and below.

                  Hey, has anyone else noticed that there is no need for this maneuver at all on Mountain Lion, even though it has XCode 4.4 as well? I know there's a different package of command-line tools for 10.8 than for 10.7; maybe that's the difference.

                  -gmn

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Ben Schmidt
                  ... Maybe a way to fix this would be to change the XCode project to use a specific version of GCC rather than just the default compiler . Then autotools and
                  Message 8 of 8 , Aug 5, 2012
                  View Source
                  • 0 Attachment
                    On 5/08/12 7:00 AM, gmn wrote:
                    >> I debugged an issue with the same symptoms a while ago. It happened
                    >> when I ran `make` (which builds vim) with a different compiler than
                    >> xcodebuild (which builds MacVim). Maybe 4.4 uses clang by default for
                    >> the MacVim build -- in that case, run `CC=clang ./configure; make -j6`
                    >> to build the corresponding vim binary. Make sure both vim and MacVim
                    >> are built with the same compiler.
                    >
                    > Yes, "CC=clang ./configure; make -j6" works. But *jeez* it is annoying
                    > that special steps have to be taken.
                    >
                    > Plus, during the compliation of the Vim binary, all sorts of warnings
                    > are thrown out that weren't there before. And it's annoying because I
                    > usually want to just run the ./configuring part first. In which case, I
                    > can do "export CC=clang" and then the configuring on a separate line,
                    > but then I have to remember to get rid of $CC after building MacVim lest
                    > I accidentally botch building something else.
                    >
                    > And now my steps for building have to be different between 10.7 and up,
                    > and 10.6 and below.
                    >
                    > Arrgh! Apple!

                    Maybe a way to fix this would be to change the XCode project to use a
                    specific version of GCC rather than just the 'default compiler'. Then
                    autotools and Xcode will use the same one, right, because autotools will
                    pick up GCC first? I'm sure it's still not foolproof, but perhaps it's
                    better?

                    Ben.



                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.