Loading ...
Sorry, an error occurred while loading the content.

Re: bug in experimental renderer

Expand Messages
  • dv1445@wayne.edu
    ... Nice work! ... Ah, my true console vim isn t the factory one from Apple, but compiled myself with a flag of ... sigh ... --disable-darwin! As to why this
    Message 1 of 10 , Jul 19, 2012
    View Source
    • 0 Attachment
      Ben Schmidt, on 07/19/12 at 22:31:49 +1000, wrote:
      > >This is indeed interesting. It is not a console Vim vs. MacVim issue,
      > >though. My Vim 7.3 compiled by Apple behaves differently to a 7.3.470
      > >I compiled myself. I don't know whether it's something about the way
      > >it was compiled or the version difference that's altered things.
      >
      > I have tracked down what this is.

      Nice work!

      > MacVim is compiled with Darwin support, but Apple's Vim is not (go
      > figure). That means that MacVim calls mac_precompose_path() while
      > evaluating glob(), but Apple's Vim doesn't. This function "converts a
      > decomposed HFS+ UTF-8 path to precomposed UTF-8". This explains why
      > there is a difference between glob() and :r !ls in MacVim but not in
      > Apple's Vim: MacVim does some extra processing for glob().

      Ah, my "true console" vim isn't the factory one from Apple, but compiled
      myself with a flag of ... sigh ... --disable-darwin!

      As to why this flag is in my bash alias for running ./configure for
      console vim, I can no longer recall; I know that I *had* a reason, and I
      *think* it had something to do with not wanting certain hard-wired
      mapping-related stuff that --enable-darwin stuck in there.

      Since --enable-darwin is really the way to go, for precomposing reasons
      as Björn pointed out, I will try to find out if my reason was actually
      any good. If it was, perhaps we can fiddle with what --enable-darwin
      does.

      Prediction: my reason was not any good. :)

      -gmn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.