Loading ...
Sorry, an error occurred while loading the content.
 

Re: weird behavior with .f90 and .F90 files

Expand Messages
  • Srinath
    Bumping since I never got a response. Do this: mvim foo.F type: foo.F in file (save and close). mvim foo.f type: foo.f in file (save and close) then run mvim
    Message 1 of 6 , Jun 11, 2012
      Bumping since I never got a response.

      Do this:

      mvim foo.F

      type: foo.F in file (save and close).

      mvim foo.f

      type: foo.f in file (save and close)


      then run mvim -d foo.F foo.f

      These are 2 different files, but only the first loads.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • René Köcher
      ... Provided you re not actually on a HFSX Volume (which IIRC is still not the default) foo.F and foo.f are *one and the same*. The default HFS+ is
      Message 2 of 6 , Jun 11, 2012
        Am Montag, 11. Juni 2012 um 21:29 schrieb Srinath:
        > Bumping since I never got a response.
        >
        > Do this:
        >
        > mvim foo.F
        >
        > type: foo.F in file (save and close).
        >
        > mvim foo.f
        >
        > type: foo.f in file (save and close)
        >
        >
        > then run mvim -d foo.F foo.f
        >
        > These are 2 different files, but only the first loads.
        Provided you're not actually on a HFSX Volume (which IIRC is still not the default) foo.F and foo.f are *one and the same*.
        The default HFS+ is case-preserving which allows you to use upper- and lowercase letters in filenames but also will compare
        them case-insensitive (thus foo.F == foo.f).

        Cheers,

        --
        To see a world in a grain of sand, and a heaven in a wild flower,
        hold infinity in the palm of your hand, and eternity in an hour.
        -- Auguries of Innocence, William Blake



        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Xiao G. Wu
        I think you are running up against the case-insensitivity of Mac OS X Extended FS. By default i believe most Macs are formatted as Mac OS X Extended
        Message 3 of 6 , Jun 11, 2012
          I think you are running up against the case-insensitivity of Mac OS X Extended FS.  By default i believe most Macs are formatted as Mac OS X Extended (Journaled).  There is an option to create a Mac OS X Entended (Case-sensitive, Journaled) partition.  

          This is not related to vim but the underlying FS.  

          in /tmp try this:

          touch me ME

          If you do a ls, you'll only see "me" and not "ME"  and visa versa depending on which filename you put first after the touch command.

          This blew my mind too as I thought the Mac OS was UNIX at heart.  If I'm off base please let me know and tell me how I can fix my FS.

          On Mon, Jun 11, 2012 at 12:29 PM, Srinath <srinath.vadlamani@...> wrote:
          Bumping since I never got a response.

          Do this:

          mvim foo.F

          type: foo.F in file (save and close).

          mvim foo.f

          type: foo.f in file (save and close)


          then run mvim -d foo.F foo.f

          These are 2 different files, but only the first loads.

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php



          --
          +xiaogwu
          xiaogwu@...
          (415) 891-9426 (GV)

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Srinath
          I have a case sensitive system. Running vim in Terminal does the correct thing. So, the file system case sensitivity is not the issue. Any other ideas? -- You
          Message 4 of 6 , Jun 12, 2012
            I have a case sensitive system.

            Running vim in Terminal does the correct thing.

            So, the file system case sensitivity is not the issue.

            Any other ideas?

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • björn
            ... You may have to build a custom binary. Take a look at the discussion titled case insensitivity on hfsx in the archives:
            Message 5 of 6 , Jun 12, 2012
              On Tue, Jun 12, 2012 at 6:14 PM, Srinath wrote:
              > I have a case sensitive system.
              >
              > Running vim in Terminal does the correct thing.
              >
              > So, the file system case sensitivity is not the issue.
              >
              > Any other ideas?

              You may have to build a custom binary. Take a look at the discussion
              titled "case insensitivity on hfsx" in the archives:

              http://groups.google.com/group/vim_mac/browse_thread/thread/b2aa9fb761016205?pli=1

              Björn

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.