Loading ...
Sorry, an error occurred while loading the content.

weird behavior with .f90 and .F90 files

Expand Messages
  • Srinath
    I opened a file (foo.f90) with macvim that had the .f90 suffix. Then, I realized I wanted it preprocessed. [No jokes about fortran ... space shuttle quality
    Message 1 of 6 , Apr 20, 2012
    • 0 Attachment
      I opened a file (foo.f90) with macvim that had the .f90 suffix. Then,
      I realized I wanted it preprocessed. [No jokes about fortran ...
      space shuttle quality stuff ... man]. So in terminal, I moved the file
      over to be foo.F90. Of course, MacVim notifies me that the foo.f90
      files does not exist any more. So I ":q" that tab, and command-T for
      a new tab.
      Then I type ":e foo.F90" in the new tab, and the buffer appears blank,
      with the file name listed as "foo.f90". Back to the lower cased
      suffix. If I starte a new macvim session: $mvim foo.F90, it opens up
      fine. Any insight? Some buffer voodoo?

      Btw..thanks for all the help.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Srinath
      Bumping since I never got a response. Do this: mvim foo.F type: foo.F in file (save and close). mvim foo.f type: foo.f in file (save and close) then run mvim
      Message 2 of 6 , Jun 11, 2012
      • 0 Attachment
        Bumping since I never got a response.

        Do this:

        mvim foo.F

        type: foo.F in file (save and close).

        mvim foo.f

        type: foo.f in file (save and close)


        then run mvim -d foo.F foo.f

        These are 2 different files, but only the first loads.

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • René Köcher
        ... Provided you re not actually on a HFSX Volume (which IIRC is still not the default) foo.F and foo.f are *one and the same*. The default HFS+ is
        Message 3 of 6 , Jun 11, 2012
        • 0 Attachment
          Am Montag, 11. Juni 2012 um 21:29 schrieb Srinath:
          > Bumping since I never got a response.
          >
          > Do this:
          >
          > mvim foo.F
          >
          > type: foo.F in file (save and close).
          >
          > mvim foo.f
          >
          > type: foo.f in file (save and close)
          >
          >
          > then run mvim -d foo.F foo.f
          >
          > These are 2 different files, but only the first loads.
          Provided you're not actually on a HFSX Volume (which IIRC is still not the default) foo.F and foo.f are *one and the same*.
          The default HFS+ is case-preserving which allows you to use upper- and lowercase letters in filenames but also will compare
          them case-insensitive (thus foo.F == foo.f).

          Cheers,

          --
          To see a world in a grain of sand, and a heaven in a wild flower,
          hold infinity in the palm of your hand, and eternity in an hour.
          -- Auguries of Innocence, William Blake



          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Xiao G. Wu
          I think you are running up against the case-insensitivity of Mac OS X Extended FS. By default i believe most Macs are formatted as Mac OS X Extended
          Message 4 of 6 , Jun 11, 2012
          • 0 Attachment
            I think you are running up against the case-insensitivity of Mac OS X Extended FS.  By default i believe most Macs are formatted as Mac OS X Extended (Journaled).  There is an option to create a Mac OS X Entended (Case-sensitive, Journaled) partition.  

            This is not related to vim but the underlying FS.  

            in /tmp try this:

            touch me ME

            If you do a ls, you'll only see "me" and not "ME"  and visa versa depending on which filename you put first after the touch command.

            This blew my mind too as I thought the Mac OS was UNIX at heart.  If I'm off base please let me know and tell me how I can fix my FS.

            On Mon, Jun 11, 2012 at 12:29 PM, Srinath <srinath.vadlamani@...> wrote:
            Bumping since I never got a response.

            Do this:

            mvim foo.F

            type: foo.F in file (save and close).

            mvim foo.f

            type: foo.f in file (save and close)


            then run mvim -d foo.F foo.f

            These are 2 different files, but only the first loads.

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php



            --
            +xiaogwu
            xiaogwu@...
            (415) 891-9426 (GV)

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Srinath
            I have a case sensitive system. Running vim in Terminal does the correct thing. So, the file system case sensitivity is not the issue. Any other ideas? -- You
            Message 5 of 6 , Jun 12, 2012
            • 0 Attachment
              I have a case sensitive system.

              Running vim in Terminal does the correct thing.

              So, the file system case sensitivity is not the issue.

              Any other ideas?

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • björn
              ... You may have to build a custom binary. Take a look at the discussion titled case insensitivity on hfsx in the archives:
              Message 6 of 6 , Jun 12, 2012
              • 0 Attachment
                On Tue, Jun 12, 2012 at 6:14 PM, Srinath wrote:
                > I have a case sensitive system.
                >
                > Running vim in Terminal does the correct thing.
                >
                > So, the file system case sensitivity is not the issue.
                >
                > Any other ideas?

                You may have to build a custom binary. Take a look at the discussion
                titled "case insensitivity on hfsx" in the archives:

                http://groups.google.com/group/vim_mac/browse_thread/thread/b2aa9fb761016205?pli=1

                Björn

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              Your message has been successfully submitted and would be delivered to recipients shortly.