Loading ...
Sorry, an error occurred while loading the content.

Local help file problem - works in Terminal Vim, not in MacVim

Expand Messages
  • Jeff Chasin
    I created a local help file, myvimnotes.txt. In that file, the Tags appear and function correctly in Terminal Vim. I can see the pipe characters around the
    Message 1 of 2 , Mar 29, 2012
    View Source
    • 0 Attachment
      I created a local help file, myvimnotes.txt. In that file, the Tags appear and function correctly in Terminal Vim. I can see the pipe characters around the "links" and the asterisks around the "targets" in both MacVim & Terminal vim. Ctrl-] works perfectly in Terminal Vim, doesn't work at all in MacVim.

      Jumping tags with Ctrl-] in Terminal Vim works fine, but in MacVim, nada. I get "E426: tag not found" on the status line when trying to Ctrl-].

      I ran :set in both Terminal & MacVim and there aren't any settings that are raising red flags - basically the same in both. I ran :helptags, checked file format and permissions, and I cannot figure this one out. Checked :help write-local-help, :help add-local-help, and didn't see anything "helpful".

      Not sure why MacVim isn't recognizing the tags or tag file but Terminal Vim is with no problem. Any suggestions from the group would really be appreciated. Thanks.

      Specs:
      OS X Lion 10.7.3
      MacVim 7.3-64 installed w/ Home Brew
      Janus Vim distro: https://github.com/carlhuda/janus

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Apart from the usual check that your plugins isn t interfering [1] answer all I can think is that something has changed in Vim (the version that ships
      Message 2 of 2 , Mar 31, 2012
      View Source
      • 0 Attachment
        On Fri, Mar 30, 2012 at 12:52 AM, Jeff Chasin wrote:
        > I created a local help file, myvimnotes.txt. In that file, the Tags appear and function correctly in Terminal Vim. I can see the pipe characters around the "links" and the asterisks around the "targets" in both MacVim & Terminal vim. Ctrl-] works perfectly in Terminal Vim, doesn't work at all in MacVim.
        >
        > Jumping tags with Ctrl-] in Terminal Vim works fine, but in MacVim, nada. I get "E426: tag not found" on the status line when trying to Ctrl-].
        >
        > I ran :set in both Terminal & MacVim and there aren't any settings that are raising red flags - basically the same in both.  I ran :helptags, checked file format and permissions, and I cannot figure this one out. Checked :help write-local-help, :help add-local-help, and didn't see anything "helpful".
        >
        > Not sure why MacVim isn't recognizing the tags or tag file but Terminal Vim is with no problem. Any suggestions from the group would really be appreciated. Thanks.

        Apart from the usual "check that your plugins isn't interfering" [1]
        answer all I can think is that something has changed in Vim (the
        version that ships with MacVim is much more recent than the one that
        ships with OS X).

        Can you reproduce the problem if you use the "Vim" binary that ships
        with MacVim without the GUI? To start it either type "mvim -v" or (if
        you don't have the mvim script)

        /Applications/MacVim.app/Contents/MacOS/Vim

        If this version doesn't work, then the problem is with core Vim in
        which case I would ask that you please report to the vim_dev Google
        group instead.

        Björn

        [1] https://github.com/b4winckler/macvim/wiki/Troubleshooting

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.