Loading ...
Sorry, an error occurred while loading the content.

Double-click file doesn't open in new tab

Expand Messages
  • Leonard Sitongia
    Hi, I m trying MacVim out. I set the option defaults write org.vim.MacVim MMOpenFilesInTabs 1 and double-clicking a text file opens a new window, not a new
    Message 1 of 3 , Mar 5, 2012
    • 0 Attachment
      Hi,

      I'm trying MacVim out. I set the option
      defaults write org.vim.MacVim MMOpenFilesInTabs 1
      and double-clicking a text file opens a new window, not a new tab.

      I have little in my .vimrc file:
      set guifont=Monaco:h14
      set lines=24
      set columns=100
      set tw=100

      There's nothing in the system log about this.

      I'm running Mac OS X 10.7.3.

      Thanks for your help,
      ==Leonard

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Martin Petrov
      ... The following seems to work in MacVim snapshot 62 on 10.7.3: Go into Preferences General Open files from applications: Select in the current window
      Message 2 of 3 , Mar 5, 2012
      • 0 Attachment
        Le 5 mars 2012 14:27, Leonard Sitongia <lsitongia@...> a écrit :
        > I'm trying MacVim out.  I set the option
        > defaults write org.vim.MacVim MMOpenFilesInTabs 1
        > and double-clicking a text file opens a new window, not a new tab.

        The following seems to work in MacVim snapshot 62 on 10.7.3:

        Go into Preferences > General > Open files from applications:
        Select "in the current window" and select "with a tab for each file"
        from the drop down menu.

        -- Martin

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Leonard Sitongia
        ... Thank you, Marin. That worked! ==Leonard -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are
        Message 3 of 3 , Mar 6, 2012
        • 0 Attachment
          On Mar 5, 2012, at 5:42 PM, Martin Petrov wrote:

          > Go into Preferences > General > Open files from applications:
          > Select "in the current window" and select "with a tab for each file"
          > from the drop down menu.

          Thank you, Marin. That worked!

          ==Leonard




          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.