Loading ...
Sorry, an error occurred while loading the content.

Erratic line spacing when using Consolas as my MacVim font

Expand Messages
  • jgarbers
    I like using Consolas in MacVim instead of my usual terminal font (Monaco) because it has bold and italic variants, which work nicely in many of the color
    Message 1 of 3 , Feb 2 2:41 PM
    • 0 Attachment
      I like using Consolas in MacVim instead of my usual terminal font
      (Monaco) because it has bold and italic variants, which work nicely in
      many of the color schemes I use. However, line spacing is erratic
      when Consolas is my guifont -- some lines are a pixel or two closer
      than others.

      I don't see any pattern to the spacing... at first I thought it might
      have to do with descenders, but it doesn't appear to. The effect
      happens regardless of what value I set for "linespace". With other
      fonts, like Monaco and Bitstream Vera Sans Mono, though, the
      linespacing is okay.

      I've posted a screenshot here: https://skitch.com/jgarbers/g687e/linespacing

      Anybody know what might be going on here? Thanks!

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Kyle Lippincott
      Does the same thing happen with Inconsolata? http://levien.com/type/myfonts/inconsolata.html ... -- You received this message from the vim_mac maillist. Do
      Message 2 of 3 , Feb 2 3:25 PM
      • 0 Attachment
        Does the same thing happen with Inconsolata?  http://levien.com/type/myfonts/inconsolata.html

        On Thu, Feb 2, 2012 at 2:41 PM, jgarbers <jgarbers@...> wrote:
        I like using Consolas in MacVim instead of my usual terminal font
        (Monaco) because it has bold and italic variants, which work nicely in
        many of the color schemes I use.  However, line spacing is erratic
        when Consolas is my guifont -- some lines are a pixel or two closer
        than others.

        I don't see any pattern to the spacing... at first I thought it might
        have to do with descenders, but it doesn't appear to.  The effect
        happens regardless of what value I set for "linespace".   With other
        fonts, like Monaco and Bitstream Vera Sans Mono, though, the
        linespacing is okay.

        I've posted a screenshot here: https://skitch.com/jgarbers/g687e/linespacing

        Anybody know what might be going on here? Thanks!

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... I m guessing it is NSTextView adjusting line heights. Try going in to the advanced preferences, enable the experimental renderer and restart. The
        Message 3 of 3 , Feb 5 10:26 AM
        • 0 Attachment
          On 2 February 2012 23:41, jgarbers wrote:
          > I like using Consolas in MacVim instead of my usual terminal font
          > (Monaco) because it has bold and italic variants, which work nicely in
          > many of the color schemes I use.  However, line spacing is erratic
          > when Consolas is my guifont -- some lines are a pixel or two closer
          > than others.
          >
          > I don't see any pattern to the spacing... at first I thought it might
          > have to do with descenders, but it doesn't appear to.  The effect
          > happens regardless of what value I set for "linespace".   With other
          > fonts, like Monaco and Bitstream Vera Sans Mono, though, the
          > linespacing is okay.
          >
          > I've posted a screenshot here: https://skitch.com/jgarbers/g687e/linespacing
          >
          > Anybody know what might be going on here? Thanks!

          I'm guessing it is NSTextView adjusting line heights. Try going in to
          the advanced preferences, enable the experimental renderer and
          restart. The experimental renderer keeps line heights fixed so it
          should not suffer from the problem you are describing.

          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.