Loading ...
Sorry, an error occurred while loading the content.

Re: Hot to add a syntax-file for AppleScript to MacVim?

Expand Messages
  • MacVlad
    ... I have never used this another way around (implicitly, through the extension) - and on a PC it works via the menu. No, it doesn t, you re right - but I m
    Message 1 of 9 , Dec 19, 2011
    • 0 Attachment
      :-)
      I have never used this another way around (implicitly, through the
      extension) - and on a PC it works via the menu.
      No, it doesn't, you're right - but I'm still wondering! ;-)

      Thanks again!
      Vlad

      On 19 Dez., 15:55, Zhao Cai <zhao...@...> wrote:
      > I never use the menu the select syntax… Mine does not show either. Does it matter?
      >
      > Cheers,
      >
      > Zhao Cai,
      > Mon 19 Dec 2011 09:55:11 AM EST
      >
      > On Dec 19, 2011, at 5:29 AM, MacVlad wrote:
      >
      >
      >
      >
      >
      >
      >
      > > Hello, Zhao Cai!
      >
      > > Thank you for your reply!
      >
      > > That works - the applescript is now colored as it should, according to
      > > the file-extension .applescript - but the entry "AppleScript" still
      > > doesn't appear under the Syntax-menu.
      >
      > > Any idea?
      >
      > > Thanks again!
      >
      > > Kind regards,
      > > Vlad Ghitulescu
      >
      > > On 19 Dez., 06:55, Zhao Cai <zhao...@...> wrote:
      > >> 1. use `au! BufNewFile,BufRead *.applescript setf applescript`. .scpt is compiled applescript file extension.
      >
      > >> On Dec 19, 2011, at 12:51 AM, MacVlad wrote:
      >
      > >>> Hello!
      >
      > >>> I want to add a syntax file for AppleScript to MacVim.
      > >>> I have found one athttp://www.vim.org/scripts/script.php?script_id=1736,
      > >>> that I copied in ~/.vim/syntax AND in /Applications/MacVim.app/
      > >>> Contents/Resources/vim/runtime/syntax, but AppleScript doesn't appear
      > >>> under the menu "Syntax" in MacVim.
      >
      > >>> After searching the group's discussions I have added the line
      >
      > >>>     au! BufNewFile,BufRead *.scpt setf applescript
      >
      > >>> in my ~/.vimrc... but this doesn't help either. :-(
      >
      > >>> Have I missed something?
      > >>> Or is another way to do this?
      >
      > >>> Thanks!
      >
      > >>> Kind regards,
      > >>> Vlad Ghitulescu
      >
      > >>> --
      > >>> You received this message from the "vim_mac" maillist.
      > >>> Do not top-post! Type your reply below the text you are replying to.
      > >>> For more information, visithttp://www.vim.org/maillist.php
      >
      > > --
      > > You received this message from the "vim_mac" maillist.
      > > Do not top-post! Type your reply below the text you are replying to.
      > > For more information, visithttp://www.vim.org/maillist.php

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Zhao Cai
      It is fast to `:set ft=???` instead of look for the menu. But if you really want to know, check the file `synmenu.vim` in system runtime path. ... -- You
      Message 2 of 9 , Dec 19, 2011
      • 0 Attachment
        It is fast to `:set ft=???` instead of look for the menu. But if you really want to know, check the file `synmenu.vim` in system runtime path.

        On Dec 19, 2011, at 1:33 PM, MacVlad wrote:

        > :-)
        > I have never used this another way around (implicitly, through the
        > extension) - and on a PC it works via the menu.
        > No, it doesn't, you're right - but I'm still wondering! ;-)
        >
        > Thanks again!
        > Vlad
        >
        > On 19 Dez., 15:55, Zhao Cai <zhao...@...> wrote:
        >> I never use the menu the select syntax… Mine does not show either. Does it matter?
        >>
        >> Cheers,
        >>
        >> Zhao Cai,
        >> Mon 19 Dec 2011 09:55:11 AM EST
        >>
        >> On Dec 19, 2011, at 5:29 AM, MacVlad wrote:
        >>
        >>
        >>
        >>
        >>
        >>
        >>
        >>> Hello, Zhao Cai!
        >>
        >>> Thank you for your reply!
        >>
        >>> That works - the applescript is now colored as it should, according to
        >>> the file-extension .applescript - but the entry "AppleScript" still
        >>> doesn't appear under the Syntax-menu.
        >>
        >>> Any idea?
        >>
        >>> Thanks again!
        >>
        >>> Kind regards,
        >>> Vlad Ghitulescu
        >>
        >>> On 19 Dez., 06:55, Zhao Cai <zhao...@...> wrote:
        >>>> 1. use `au! BufNewFile,BufRead *.applescript setf applescript`. .scpt is compiled applescript file extension.
        >>
        >>>> On Dec 19, 2011, at 12:51 AM, MacVlad wrote:
        >>
        >>>>> Hello!
        >>
        >>>>> I want to add a syntax file for AppleScript to MacVim.
        >>>>> I have found one athttp://www.vim.org/scripts/script.php?script_id=1736,
        >>>>> that I copied in ~/.vim/syntax AND in /Applications/MacVim.app/
        >>>>> Contents/Resources/vim/runtime/syntax, but AppleScript doesn't appear
        >>>>> under the menu "Syntax" in MacVim.
        >>
        >>>>> After searching the group's discussions I have added the line
        >>
        >>>>> au! BufNewFile,BufRead *.scpt setf applescript
        >>
        >>>>> in my ~/.vimrc... but this doesn't help either. :-(
        >>
        >>>>> Have I missed something?
        >>>>> Or is another way to do this?
        >>
        >>>>> Thanks!
        >>
        >>>>> Kind regards,
        >>>>> Vlad Ghitulescu
        >>
        >>>>> --
        >>>>> You received this message from the "vim_mac" maillist.
        >>>>> Do not top-post! Type your reply below the text you are replying to.
        >>>>> For more information, visithttp://www.vim.org/maillist.php
        >>
        >>> --
        >>> You received this message from the "vim_mac" maillist.
        >>> Do not top-post! Type your reply below the text you are replying to.
        >>> For more information, visithttp://www.vim.org/maillist.php
        >
        > --
        > You received this message from the "vim_mac" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • MacVlad
        Hello again, Zhao Cai! 1.- I don t quite understand what do you mean with :set ft=??? , it get s me an error (E474: Invalid argument: ft=???) in MacVim. 2.-
        Message 3 of 9 , Dec 19, 2011
        • 0 Attachment
          Hello again, Zhao Cai!


          1.- I don't quite understand what do you mean with ":set ft=???", it
          get's me an error (E474: Invalid argument: ft=???) in MacVim.

          2.- There is definitely NO entry for AppleScript in the synmenu.vim:

          (...)
          an 50.10.260 &Syntax.AB.Apache-style\ config :cal
          SetSyn("apachestyle")<CR>
          an 50.10.270 &Syntax.AB.Applix\ ELF :cal SetSyn("elf")<CR>
          (...)


          Kind regards,
          Vlad Ghitulescu


          On 19 Dez., 20:30, Zhao Cai <zhao...@...> wrote:
          > It is fast to `:set ft=???` instead of look for the menu. But if you really want to know, check the file `synmenu.vim` in system runtime path.
          >
          > On Dec 19, 2011, at 1:33 PM, MacVlad wrote:
          >
          >
          >
          >
          >
          >
          >
          > > :-)
          > > I have never used this another way around (implicitly, through the
          > > extension) - and on a PC it works via the menu.
          > > No, it doesn't, you're right - but I'm still wondering! ;-)
          >
          > > Thanks again!
          > > Vlad
          >
          > > On 19 Dez., 15:55, Zhao Cai <zhao...@...> wrote:
          > >> I never use the menu the select syntax… Mine does not show either. Does it matter?
          >
          > >> Cheers,
          >
          > >> Zhao Cai,
          > >> Mon 19 Dec 2011 09:55:11 AM EST
          >
          > >> On Dec 19, 2011, at 5:29 AM, MacVlad wrote:
          >
          > >>> Hello, Zhao Cai!
          >
          > >>> Thank you for your reply!
          >
          > >>> That works - the applescript is now colored as it should, according to
          > >>> the file-extension .applescript - but the entry "AppleScript" still
          > >>> doesn't appear under the Syntax-menu.
          >
          > >>> Any idea?
          >
          > >>> Thanks again!
          >
          > >>> Kind regards,
          > >>> Vlad Ghitulescu
          >
          > >>> On 19 Dez., 06:55, Zhao Cai <zhao...@...> wrote:
          > >>>> 1. use `au! BufNewFile,BufRead *.applescript setf applescript`. .scpt is compiled applescript file extension.
          >
          > >>>> On Dec 19, 2011, at 12:51 AM, MacVlad wrote:
          >
          > >>>>> Hello!
          >
          > >>>>> I want to add a syntax file for AppleScript to MacVim.
          > >>>>> I have found one athttp://www.vim.org/scripts/script.php?script_id=1736,
          > >>>>> that I copied in ~/.vim/syntax AND in /Applications/MacVim.app/
          > >>>>> Contents/Resources/vim/runtime/syntax, but AppleScript doesn't appear
          > >>>>> under the menu "Syntax" in MacVim.
          >
          > >>>>> After searching the group's discussions I have added the line
          >
          > >>>>>     au! BufNewFile,BufRead *.scpt setf applescript
          >
          > >>>>> in my ~/.vimrc... but this doesn't help either. :-(
          >
          > >>>>> Have I missed something?
          > >>>>> Or is another way to do this?
          >
          > >>>>> Thanks!
          >
          > >>>>> Kind regards,
          > >>>>> Vlad Ghitulescu
          >
          > >>>>> --
          > >>>>> You received this message from the "vim_mac" maillist.
          > >>>>> Do not top-post! Type your reply below the text you are replying to.
          > >>>>> For more information, visithttp://www.vim.org/maillist.php
          >
          > >>> --
          > >>> You received this message from the "vim_mac" maillist.
          > >>> Do not top-post! Type your reply below the text you are replying to.
          > >>> For more information, visithttp://www.vim.org/maillist.php
          >
          > > --
          > > You received this message from the "vim_mac" maillist.
          > > Do not top-post! Type your reply below the text you are replying to.
          > > For more information, visithttp://www.vim.org/maillist.php

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Niklas Lindström
          Hi Vlad, ... He meant the usage pattern of setting the filetype option with the ... There is also a shortcut command for this, :setfiletype, which also ...
          Message 4 of 9 , Dec 21, 2011
          • 0 Attachment
            Hi Vlad,

            On Tue, Dec 20, 2011 at 7:05 AM, MacVlad <vlad.ghitulescu@...> wrote:
            > Hello again, Zhao Cai!
            >
            >
            > 1.- I don't quite understand what do you mean with ":set ft=???", it
            > get's me an error (E474: Invalid argument: ft=???) in MacVim.

            He meant the usage pattern of setting the 'filetype' option with the
            :set command to the desired filetype/syntax; .i.e. in your case:

            :set ft=applescript

            There is also a shortcut command for this, :setfiletype, which also
            supports tabcompletion. So you can do e.g.:

            :setf applescript

            (Try typing e.g. :setf ap<Tab> to see the completion in action.)

            > 2.- There is definitely NO entry for AppleScript in the synmenu.vim:
            >
            > (...)
            > an 50.10.260 &Syntax.AB.Apache-style\ config :cal
            > SetSyn("apachestyle")<CR>
            > an 50.10.270 &Syntax.AB.Applix\ ELF :cal SetSyn("elf")<CR>
            > (...)

            You can add one manually by running:

            :anoremenu 50.10.265 &Syntax.AB.AppleScript :cal SetSyn("applescript")<CR>

            Best regards,
            Niklas
            --
            <http://neverspace.net/>

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • MacVlad
            Hi, Niklas! Thanks for your reply! ... NOW I understand! :-)) ... That s right! Thanks a lot! ... Everything works, wonderful! :-) Thanks again, I have learned
            Message 5 of 9 , Dec 22, 2011
            • 0 Attachment
              Hi, Niklas!


              Thanks for your reply!

              On 21 Dez., 15:33, Niklas Lindström <lindstr...@...> wrote:
              > Hi Vlad,
              >
              > On Tue, Dec 20, 2011 at 7:05 AM, MacVlad <vlad.ghitule...@...> wrote:
              > > Hello again, Zhao Cai!
              >
              > > 1.- I don't quite understand what do you mean with ":set ft=???", it
              > > get's me an error (E474: Invalid argument: ft=???) in MacVim.
              >
              > He meant the usage pattern of setting the 'filetype' option with the
              > :set command to the desired filetype/syntax; .i.e. in your case:
              >
              >   :set ft=applescript
              >
              NOW I understand! :-))


              > There is also a shortcut command for this, :setfiletype, which also
              > supports tabcompletion. So you can do e.g.:
              >
              >   :setf applescript
              >
              > (Try typing e.g. :setf ap<Tab> to see the completion in action.)
              That's right! Thanks a lot!


              > > 2.- There is definitely NO entry for AppleScript in the synmenu.vim:
              >
              > > (...)
              > > an 50.10.260 &Syntax.AB.Apache-style\ config :cal
              > > SetSyn("apachestyle")<CR>
              > > an 50.10.270 &Syntax.AB.Applix\ ELF :cal SetSyn("elf")<CR>
              > > (...)
              >
              > You can add one manually by running:
              >
              >     :anoremenu 50.10.265 &Syntax.AB.AppleScript :cal SetSyn("applescript")<CR>
              Everything works, wonderful! :-)
              Thanks again, I have learned a lot!


              > Best regards,
              > Niklas
              > --
              > <http://neverspace.net/>
              Kind regards,
              Vlad

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.