Loading ...
Sorry, an error occurred while loading the content.

Re: cannot use font in macvim

Expand Messages
  • Federico Calboli
    SOLVED I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from ... it just ignores the new
    Message 1 of 15 , Dec 1, 2011
    View Source
    • 0 Attachment
      SOLVED

      I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from

      :set guifont=*

      it just ignores the new font

      bw

      F



      On 30 Nov 2011, at 21:06, Richard Mitchell wrote:

      > My Italian is as rusty as google, but the Letter G font looks to be monospaced:
      >
      >
      > "Letter-g" , designed by Giovanni Battistiniwas born in Como, but resident in Bolognawww.kitchencoop.it , is a monospaced font inspired by the Olivetti typewriter 60s.
      >
      >
      > Is that the right font? I ask because you said it was proportional. If it is monospaced, even more surprising there is an issue with it.
      >
      > --
      > You received this message from the "vim_mac" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php

      --
      Federico Calboli
      f.calboli@...



      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... I assume it also works if you call set gfn=fontname ? Does the font contain weird characters or spaces? Maybe the code is not properly escaping
      Message 2 of 15 , Dec 2, 2011
      View Source
      • 0 Attachment
        On 1 December 2011 13:29, Federico Calboli wrote:
        > SOLVED
        >
        > I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from
        >
        > :set guifont=*
        >
        > it just ignores the new font

        I assume it also works if you call "set gfn=fontname"?

        Does the font contain weird characters or spaces? Maybe the code is
        not properly escaping something. If I had the font I'd try it out,
        but I'd rather avoid having to write and ask for a copy of the font.

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Federico Calboli
        ... it does ... not to the best of my knowledge, though the font is very much an alpha release I got from the author. bw F  Maybe the code is ... -- You
        Message 3 of 15 , Dec 4, 2011
        View Source
        • 0 Attachment
          On Dec 2, 5:12 pm, björn <bjorn.winck...@...> wrote:
          > On 1 December 2011 13:29, Federico Calboli wrote:
          >
          > > SOLVED
          >
          > > I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from
          >
          > > :set guifont=*
          >
          > > it just ignores the new font
          >
          > I assume it also works if you call "set gfn=fontname"?

          it does
          >
          > Does the font contain weird characters or spaces?

          not to the best of my knowledge, though the font is very much an alpha
          release I got from the author.

          bw

          F


           Maybe the code is
          > not properly escaping something.  If I had the font I'd try it out,
          > but I'd rather avoid having to write and ask for a copy of the font.
          >
          > Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • chadhs
          This has worked well for me: set some gui only options (for macvim / gvim) if has( gui_running ) GUI is running or is about to start. set the preferred
          Message 4 of 15 , Dec 5, 2011
          View Source
          • 0 Attachment
            This has worked well for me:

            " set some gui only options (for macvim / gvim)
            if has("gui_running")
            " GUI is running or is about to start.
            " set the preferred default height and width of your vim window
            set lines=53 columns=130
            " set your preferred color scheme
            colorscheme wombat256
            " set your preferred font
            set gfn=DejaVu\ Sans\ Mono:h13
            endif


            - Chad

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • björn
            ... Sorry, I meant to ask if the font _name_ contains weird characters? (As in, what is name when you type :set gfn=name to set the font?) Björn -- You
            Message 5 of 15 , Dec 7, 2011
            View Source
            • 0 Attachment
              On 4 December 2011 13:52, Federico Calboli wrote:
              > On Dec 2, 5:12 pm, björn wrote:
              >> On 1 December 2011 13:29, Federico Calboli wrote:
              >>
              >> Does the font contain weird characters or spaces?
              >
              > not to the best of my knowledge, though the font is very much an alpha
              > release I got from the author.

              Sorry, I meant to ask if the font _name_ contains weird characters?
              (As in, what is "name" when you type ":set gfn=name" to set the font?)

              Björn

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Brian Wolven
              I suspect it s the - (Letter-g). -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are replying
              Message 6 of 15 , Dec 7, 2011
              View Source
              • 0 Attachment
                I suspect it's the "-" (Letter-g).

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Federico Calboli
                ... from my .gvimrc: set guifont=letteragbeta:h17 works like a charm. Basically, the font name is letteragbeta, and both ... work on the gui. If I ... and
                Message 7 of 15 , Dec 8, 2011
                View Source
                • 0 Attachment
                  On Dec 7, 9:13 pm, björn <bjorn.winck...@...> wrote:
                  > Sorry, I meant to ask if the font _name_ contains weird characters?
                  > (As in, what is "name" when you type ":set gfn=name" to set the font?)

                  from my .gvimrc:

                  set guifont=letteragbeta:h17

                  works like a charm. Basically, the font name is letteragbeta, and both

                  :set guifont=letteragbeta or
                  :set gfn=letteragbeta

                  work on the gui.

                  If I

                  :set guifont=*

                  and select from the menu (where the font goes by the same very name)
                  it does not work.

                  bw

                  F

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                Your message has been successfully submitted and would be delivered to recipients shortly.