Loading ...
Sorry, an error occurred while loading the content.

cannot use font in macvim

Expand Messages
  • Federico Calboli
    Hi, I tried to use a new font I installed in MacVim but I am having no ... brings up the list of fonts, the font I want to use in on the list but if I select
    Message 1 of 15 , Nov 30, 2011
    • 0 Attachment
      Hi,

      I tried to use a new font I installed in MacVim but I am having no
      luck:

      :set guifont=*

      brings up the list of fonts, the font I want to use in on the list but
      if I select it it does noting, while if I select basically any other
      font the font gets changed to my selection.

      Any idea why?

      I'm on Lion 10.7.2 and I'm using the latest Lion MacVim snapshot.

      Cheers

      F

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Federico Calboli
      I forgot to mention, it it a proportional font, but I doubt it would matter given that MacVim seems to display every other proportional font in the list
      Message 2 of 15 , Nov 30, 2011
      • 0 Attachment
        I forgot to mention, it it a proportional font, but I doubt it would
        matter given that MacVim seems to display every other proportional
        font in the list anyway.



        On Nov 30, 10:56 am, Federico Calboli <f.calb...@...> wrote:
        > Hi,
        >
        > I tried to use a new font I installed in MacVim but I am having no
        > luck:
        >
        > :set guifont=*
        >
        > brings up the list of fonts, the font I want to use in on the list but
        > if I select it it does noting, while if I select basically any other
        > font the font gets changed to my selection.
        >
        > Any idea why?
        >
        > I'm on Lion 10.7.2 and I'm using the latest Lion MacVim snapshot.
        >
        > Cheers
        >
        > F

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Caleb Eggensperger
        I m not sure why you re having trouble, but it might not be worth it anyway; proportional fonts aren t supported in MacVim. When working properly, it spaces
        Message 3 of 15 , Nov 30, 2011
        • 0 Attachment
          I'm not sure why you're having trouble, but it might not be worth it anyway; proportional fonts aren't supported in MacVim. When working properly, it spaces out each character as though it were monospace.

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Federico Calboli
          ... It is worth the trouble, I would not have installed the font otherwise! ;) It does work beautifully in Aquamacs, and it would look pretty well in MacVim
          Message 4 of 15 , Nov 30, 2011
          • 0 Attachment
            On Nov 30, 6:46 pm, Caleb Eggensperger <caleb...@...> wrote:
            > I'm not sure why you're having trouble, but it might not be worth it
            > anyway; proportional fonts aren't supported in MacVim. When working
            > properly, it spaces out each character as though it were monospace.

            It is worth the trouble, I would not have installed the font
            otherwise! ;)

            It does work beautifully in Aquamacs, and it would look pretty well in
            MacVim too (it is proportional but not so extremely you'd notice if
            MacVim would render it as if monospaced).

            Any suggestion to make it work?

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Richard Mitchell
            If I was someone who could help you (and I m not) then I want the font name and where to get it. If the problem is with the font (and some weird interaction
            Message 5 of 15 , Nov 30, 2011
            • 0 Attachment
              If I was someone who could help you (and I'm not) then I want the font name and where to get it.

              If the problem is with the font (and some weird interaction with macvim), being able to work with it would go a long way to fixing the problem.

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Federico Calboli
              the font is this: http://blog.giofugatype.com/?p=1533 and to get it you have to email Giovanni Battistini | kitchen to ask for it, it
              Message 6 of 15 , Nov 30, 2011
              • 0 Attachment
                the font is this:

                http://blog.giofugatype.com/?p=1533

                and to get it you have to email

                Giovanni Battistini | kitchen <giovanni@...>

                to ask for it, it is not publicly available -- to he gave it to me for free when I asked (politely) to use it.

                F



                On 30 Nov 2011, at 19:46, Richard Mitchell wrote:

                > If I was someone who could help you (and I'm not) then I want the font name and where to get it.
                >
                > If the problem is with the font (and some weird interaction with macvim), being able to work with it would go a long way to fixing the problem.
                >
                >
                > --
                > You received this message from the "vim_mac" maillist.
                > Do not top-post! Type your reply below the text you are replying to.
                > For more information, visit http://www.vim.org/maillist.php

                --
                Federico Calboli
                f.calboli@...



                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Richard Mitchell
                My Italian is as rusty as google, but the Letter G font looks to be monospaced: * Letter-g * , designed by *Giovanni Battistini*was born in Como, but resident
                Message 7 of 15 , Nov 30, 2011
                • 0 Attachment
                  My Italian is as rusty as google, but the Letter G font looks to be monospaced:


                  "Letter-g" , designed by Giovanni Battistiniwas born in Como, but resident in Bolognawww.kitchencoop.it , is a monospaced font inspired by the Olivetti typewriter 60s.


                  Is that the right font?  I ask because you said it was proportional.  If it is monospaced, even more surprising there is an issue with it.

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Federico Calboli
                  ... It is, and I am obviously an idiot. But I am sure it is not working. F -- You received this message from the vim_mac maillist. Do not top-post! Type your
                  Message 8 of 15 , Nov 30, 2011
                  • 0 Attachment
                    On 30 Nov 2011, at 21:06, Richard Mitchell wrote:

                    > My Italian is as rusty as google, but the Letter G font looks to be monospaced:
                    >
                    >
                    > "Letter-g" , designed by Giovanni Battistiniwas born in Como, but resident in Bolognawww.kitchencoop.it , is a monospaced font inspired by the Olivetti typewriter 60s.
                    >
                    >
                    > Is that the right font? I ask because you said it was proportional. If it is monospaced, even more surprising there is an issue with it.


                    It is, and I am obviously an idiot. But I am sure it is not working.

                    F



                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Federico Calboli
                    SOLVED I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from ... it just ignores the new
                    Message 9 of 15 , Dec 1, 2011
                    • 0 Attachment
                      SOLVED

                      I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from

                      :set guifont=*

                      it just ignores the new font

                      bw

                      F



                      On 30 Nov 2011, at 21:06, Richard Mitchell wrote:

                      > My Italian is as rusty as google, but the Letter G font looks to be monospaced:
                      >
                      >
                      > "Letter-g" , designed by Giovanni Battistiniwas born in Como, but resident in Bolognawww.kitchencoop.it , is a monospaced font inspired by the Olivetti typewriter 60s.
                      >
                      >
                      > Is that the right font? I ask because you said it was proportional. If it is monospaced, even more surprising there is an issue with it.
                      >
                      > --
                      > You received this message from the "vim_mac" maillist.
                      > Do not top-post! Type your reply below the text you are replying to.
                      > For more information, visit http://www.vim.org/maillist.php

                      --
                      Federico Calboli
                      f.calboli@...



                      --
                      You received this message from the "vim_mac" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • björn
                      ... I assume it also works if you call set gfn=fontname ? Does the font contain weird characters or spaces? Maybe the code is not properly escaping
                      Message 10 of 15 , Dec 2, 2011
                      • 0 Attachment
                        On 1 December 2011 13:29, Federico Calboli wrote:
                        > SOLVED
                        >
                        > I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from
                        >
                        > :set guifont=*
                        >
                        > it just ignores the new font

                        I assume it also works if you call "set gfn=fontname"?

                        Does the font contain weird characters or spaces? Maybe the code is
                        not properly escaping something. If I had the font I'd try it out,
                        but I'd rather avoid having to write and ask for a copy of the font.

                        Björn

                        --
                        You received this message from the "vim_mac" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • Federico Calboli
                        ... it does ... not to the best of my knowledge, though the font is very much an alpha release I got from the author. bw F  Maybe the code is ... -- You
                        Message 11 of 15 , Dec 4, 2011
                        • 0 Attachment
                          On Dec 2, 5:12 pm, björn <bjorn.winck...@...> wrote:
                          > On 1 December 2011 13:29, Federico Calboli wrote:
                          >
                          > > SOLVED
                          >
                          > > I just changed the font in .vimrc and .gvimrc to the new font and it works. What does not work is selecting the font from
                          >
                          > > :set guifont=*
                          >
                          > > it just ignores the new font
                          >
                          > I assume it also works if you call "set gfn=fontname"?

                          it does
                          >
                          > Does the font contain weird characters or spaces?

                          not to the best of my knowledge, though the font is very much an alpha
                          release I got from the author.

                          bw

                          F


                           Maybe the code is
                          > not properly escaping something.  If I had the font I'd try it out,
                          > but I'd rather avoid having to write and ask for a copy of the font.
                          >
                          > Björn

                          --
                          You received this message from the "vim_mac" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • chadhs
                          This has worked well for me: set some gui only options (for macvim / gvim) if has( gui_running ) GUI is running or is about to start. set the preferred
                          Message 12 of 15 , Dec 5, 2011
                          • 0 Attachment
                            This has worked well for me:

                            " set some gui only options (for macvim / gvim)
                            if has("gui_running")
                            " GUI is running or is about to start.
                            " set the preferred default height and width of your vim window
                            set lines=53 columns=130
                            " set your preferred color scheme
                            colorscheme wombat256
                            " set your preferred font
                            set gfn=DejaVu\ Sans\ Mono:h13
                            endif


                            - Chad

                            --
                            You received this message from the "vim_mac" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • björn
                            ... Sorry, I meant to ask if the font _name_ contains weird characters? (As in, what is name when you type :set gfn=name to set the font?) Björn -- You
                            Message 13 of 15 , Dec 7, 2011
                            • 0 Attachment
                              On 4 December 2011 13:52, Federico Calboli wrote:
                              > On Dec 2, 5:12 pm, björn wrote:
                              >> On 1 December 2011 13:29, Federico Calboli wrote:
                              >>
                              >> Does the font contain weird characters or spaces?
                              >
                              > not to the best of my knowledge, though the font is very much an alpha
                              > release I got from the author.

                              Sorry, I meant to ask if the font _name_ contains weird characters?
                              (As in, what is "name" when you type ":set gfn=name" to set the font?)

                              Björn

                              --
                              You received this message from the "vim_mac" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            • Brian Wolven
                              I suspect it s the - (Letter-g). -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are replying
                              Message 14 of 15 , Dec 7, 2011
                              • 0 Attachment
                                I suspect it's the "-" (Letter-g).

                                --
                                You received this message from the "vim_mac" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php
                              • Federico Calboli
                                ... from my .gvimrc: set guifont=letteragbeta:h17 works like a charm. Basically, the font name is letteragbeta, and both ... work on the gui. If I ... and
                                Message 15 of 15 , Dec 8, 2011
                                • 0 Attachment
                                  On Dec 7, 9:13 pm, björn <bjorn.winck...@...> wrote:
                                  > Sorry, I meant to ask if the font _name_ contains weird characters?
                                  > (As in, what is "name" when you type ":set gfn=name" to set the font?)

                                  from my .gvimrc:

                                  set guifont=letteragbeta:h17

                                  works like a charm. Basically, the font name is letteragbeta, and both

                                  :set guifont=letteragbeta or
                                  :set gfn=letteragbeta

                                  work on the gui.

                                  If I

                                  :set guifont=*

                                  and select from the menu (where the font goes by the same very name)
                                  it does not work.

                                  bw

                                  F

                                  --
                                  You received this message from the "vim_mac" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php
                                Your message has been successfully submitted and would be delivered to recipients shortly.